ubuntuusers.de

Caja

Dieser Artikel wurde für die folgenden Ubuntu-Versionen getestet:

Zum Verständnis dieses Artikels sind folgende Seiten hilfreich:

./Caja_logo.png Caja 🇬🇧 ist der Standard-Dateimanager der Desktop-Umgebung MATE. Es handelt sich dabei um eine Abspaltung (Fork) und Weiterentwicklung der Nautilus-Version 2.32. Caja soll die Handhabung von Dateien leicht machen. Er bietet neben den normalen Funktionen eines Dateimanagers eine Vorschau für diverse Dateitypen inkl. Audiodateien, kann bei der Erstellung optischer Datenträger weiterhelfen, auf entfernte Freigaben im Netzwerk zugreifen u.v.a.m. Man kann Caja wie seinen Vorgänger auch als grafische "Shell" bezeichnen.

Das Programm lässt sich durch zusätzliche Skripte in seinen Funktionen leicht erweitern (aber derzeit nicht in dem Maß wie bei Nautilus). Intern wird Caja bei MATE auch zur Verwaltung des Desktop verwendet (siehe Desktop-Symbole).

Installation

Hinweis:

Derzeit liegen noch keine Erfahrungen vor, ob und wie man Caja mit anderen Desktop-Umgebungen kombinieren kann.

Der Dateimanager ist bei einer Installation von Ubuntu MATE bereits vorinstalliert. Ansonsten kann er ab Ubuntu 14.10 über folgendes Paket nachinstalliert werden:

  • caja (universe)

Paketliste zum Kopieren:

sudo apt-get install caja 

Oder mit apturl installieren, Link: apt://caja

Start

Den Dateimanager startet man, indem man beispielsweise im Panel von MATE auf einen der unter "Orte" aufgeführten Einträge wie beispielsweise "Persönlicher Ordner" auswählt. Dies öffnet dann in diesem Fall Caja mit dem eigenen Homeverzeichnis. Auf Wunsch ist auch ein Tastenkombination möglich (siehe MATE Tastenkürzel).

Ansichten

./caja_home.png ./caja_2colums.png
Browser-Ansicht (Standard) Zwei-Spalten-Ansicht

Caja kennt drei verschiedene Ansichtsmodi:

  • Die Browser-Ansicht - dabei ist im Menü unter "Bearbeiten → Einstellungen → Verhalten" das Kontrollkästchen "Jeden Ordner in seinem eigenen Fenster öffnen" deaktiviert (Standard)

  • Die Einzel-Ansicht - kann unter "Bearbeiten → Einstellungen → Verhalten → Jeden Ordner in seinem eigenen Fenster öffnen" aktiviert werden. Eine Änderung dieser Einstellung wird erst mit dem der nächsten Start von Caja wirksam

  • Die Zwei-Spalten-Ansicht - mit F3 de/aktivieren

In jedem der drei Ansichtsmodi lässt sich mit der Tastenkombination Strg + T ein neuer Reiter öffnen, sodass eine Ansicht mit mehreren Reitern entsteht.

./caja_locationbar.png
Navigation ohne und mit Adressleiste

Adressleiste

Als Standardeinstellung wird die Adresse in Form von Navigationsknöpfen angezeigt. Wer Adressen lieber direkt eintippen will, schaltet mittels Strg + L zu einem Textfeld um, wo Pfade direkt eingeben werden können. Zur Vervollständigung von Pfaden dient die Tab ⇆ Taste. Mit Esc kommt man wieder zurück zu den Navigationsknöpfen.

Möchte man die Adressleiste dauerhaft anzeigen, verwendet man das Stiftsymbol vor den Navigationsknöpfen. Alternativ kann man im Konfigurationseditor [2] die Option "org.mate.caja.preferences always-use-location-entry" aktivieren.

Seitenleiste

./Caja_seitenleiste.png

Die Seitenleiste lässt sich mit F9 bzw. im Menü "Ansicht → Seitenleiste" aktivieren. Klickt man auf die Schaltfläche "Orte", öffnet sich ein Menü, in dem man alternative Informationsanzeigen wählen kann. Zur Verfügung stehen:

  • "Orte" - aufgelistet werden im oberen Abschnitt (oberhalb des Trennstriches) der Persönliche Ordner, der Desktop, eingehängte Datenträger und Netzlaufwerke und im unteren Abschnitt die Lesezeichen (Standardansicht)

  • "Informationen" - zum aktuell geöffneten Ordner

  • "Baum" - Baumansicht für schnelle Navigation (siehe Abbildung rechts)

  • "Verlauf" - die letzten aufgerufenen Ordner, auch über das Menü unter "Gehe zu" erreichbar

  • "Notizen" - Platz für Notizen, wird mit einem kleinen Symbol links neben der "Schließen"-Schaltfläche der Seitenleiste angezeigt. Hier wird der im Eigenschaftsfenster unter "Notizen" hinterlassene Text des aktuell geöffneten Ordners angezeigt. Das Editieren der Notiz ist dabei auch möglich.

  • "Embleme" - Ordnern Embleme zuweisen, funktioniert auch über Rechtsklick rechte Maustaste auf den Ordner und "Eigenschaften → Embleme".

Orte

Im oberen Abschnitt werden die Lesezeichen angezeigt. Unterhalb davon werden interne (und falls verbunden, auch externe) Datenträger wie Festplatten bzw. -Partitionen, optische Laufwerke, USB-Sticks etc. angezeigt.

Lesezeichen

Um ein Lesezeichen hinzuzufügen, öffnet man den gewünschten Ordner oder markiert die gewünschte Datei und wählt im Menü "Lesezeichen → Lesezeichen hinzufügen". Ab sofort ist der Eintrag als Lesezeichen dort schnell anwählbar und nun auch u.a. im Dateiauswahl-Dialog der Anwendungen erreichbar. Unter "Orte" sind bereits ein paar Ordner zu finden, z.B. "Dokumente, Bilder, Musik, Videos".

Ein Lesezeichen kann auf zwei Arten entfernt werden:

  • über den Eintrag in der Seitenleiste mit einem rechte Maustaste-Klick darauf und dann "Entfernen" oder

  • über das Menü "Lesezeichen → Lesezeichen bearbeiten"

Die Lesezeicheneinträge werden in der versteckten Datei ~/.gtk-bookmarks im Homeverzeichnis bzw. ab Ubuntu 18.04 in ~/.config/gtk-3.0/bookmarks gespeichert.

Dateimanagement

./caja_trash_full.png

Papierkorb

Eine Datei oder ein Ordner lässt sich mit Entf oder Rechtsklick rechte Maustaste "→ In den Papierkorb verschieben" löschen. Über das Kontextmenü rechte Maustaste des Papierkorbsymbols lässt sich der komplette Papierkorb leeren. Will man, dass Dateien sofort gelöscht werden und nicht erst in den Papierkorb verschoben werden, kann man Dateien auch mit + Entf nach Rückfrage sofort löschen.

Möchte man den Papierkorb mehr oder weniger regelmäßig umgehen, dann kann man in den Optionen von Caja unter "Bearbeiten → Einstellungen → Verhalten" die Option "Einen Löschbefehl bereitstellen, der den Papierkorb umgeht" aktivieren. Ist die Option aktiviert und klickt man mit der rechten Maustaste auf eine Datei oder einen Ordner, so erscheint die zusätzliche Wahlmöglichkeit "Löschen". Wählt man diese Aktion aus, so werden Dateien sofort und unwiderruflich gelöscht.

Darstellung

./hintergruende.png

Auf Wunsch kann man das Hintergrundbild in Caja ändern (der Standard (weiß) hängt vom verwendeten Design ab). Dazu geht man unter "Bearbeiten → Hintergründe und Embleme" und wählt ein Bild oder eine Farbe aus. Auch eigene Muster können ausgewählt werden. Oder man versieht ein Ordnersymbol mit einem Emblem wie z.B. einem ♥ , um ihn als zentralen Ort für die Korrespondenz mit einer bestimmten Person zu kennzeichnen.

Wer dagegen ein Ordner-Symbol umfärben möchte, braucht eine spezielle Erweiterung mit dem Namen Folder Color.

Verknüpfungen mit Programmen

Caja öffnet bekannte Dateitypen (z.B. .pdf, .avi oder .png) immer mit einem bestimmten Programm. Diese Verknüpfung kann man auch innerhalb von Caja ändern. Üblicherweise verknüpft Caja Dateitypen mit den MATE-eigenen Programmen wie Pluma (gedit), Atril (Evince), Engrampa (File Roller) usw. Möchte man eine Datei mit einem anderen Programm öffnen, so kann dies entweder einmalig erfolgen oder die Verknüpfung permanent geändert werden.

Einmalig

./oeffnenmit_temp.png

Jedes installierte Programm übermittelt dem System, mit welchen Dateitypen es arbeiten möchte. Möchte man ein Dateityp nur einmalig mit einer anderen Anwendung öffnen als die üblicherweise verknüpfte Anwendung, so klickt man mit der rechten Maustaste rechte Maustaste auf die Datei und findet unter "Mit XXX öffnen" alle Programme, die mit diesem Dateityp etwas anfangen können.

Sollte man die Datei mit einem ganz anderen Programm öffnen wollen, so findet man am Ende der Liste den Eintrag "Mit anderer Anwendung öffnen..." Wählt man diesen aus, so bekommt man eine Liste aller Anwendungen des Systems. Die Option "Diese Anwendung für <DATEITYP> merken" ist vorausgewählt und muss für einmaliges Öffnen mit der Anwendung abgewählt werden. So kann man eine Datei mit einer beliebigen Anwendung starten. Alternativ lassen sich über "Benutzerdefinierten Befehl benutzen" spezielle Start-Befehle und -Optionen festlegen.

Permanent

./oeffnenmit_permanent.png

Um einen Dateityp permanent mit einer bestimmten Anwendung zu öffnen, kann man einen etwas anderen Weg gehen.

  • Eine Datei des gewünschten Typs auswählen

  • Mit Rechtsklick rechte Maustaste das Kontextmenü öffnen und "Eigenschaften" auswählen

  • Nun sieht man einige Karteireiter mit diversen Einstellmöglichkeiten

  • Reiter "Öffnen mit" auswählen. In diesem Reiter sind alle Programme aufgeführt, die schon einmal zum Anzeigen der gewählten Datei verwendet wurden.

  • Über den Button "Hinzufügen" (unten rechts) können auch andere Programme ausgewählt werden

  • Durch Anklicken der Option vor dem Programmnamen wird dieses als Standardprogramm zum Öffnen des gewählten Dateityps (hier .png) definiert

Wählt man nun eine Datei des Typs .png aus (durch einfachen Klick bzw. Doppelklick, je nach Einstellung von Caja), wird diese ab sofort mit dem eingestellten Programm geöffnet.

Datei-Vorschau

Caja erstellt für verschiedene Datei-Typen eine Vorschau.

Videos

Damit Caja Vorschaubilder (Thumbnails) von Videodateien anzeigt, muss das Programm Totem installiert sein:

  • totem

Paketliste zum Kopieren:

sudo apt-get install totem 

Oder mit apturl installieren, Link: apt://totem

Nun werden spätestens nach dem nächsten Neustart von Caja automatisch Vorschaubilder erzeugt. Wichtig für eine korrekte Funktion ist außerdem, dass die benötigten Codecs installiert sind. So praktisch diese Funktion auch ist, so hinderlich kann sie beim Einsatz externer Datenträger sein. Es kann z.B. passieren, dass das Auswerfen (unmount) blockiert wird, weil Totem noch mit der Erstellung der Vorschaubilder beschäftigt ist.

./Cajaaudiovorschau.png

Audiodateien

Caja kann Audiodateien abspielen, wenn der Mauszeiger in der Symbolansicht über eine Audiodatei schwebt oder eine Datei über die Pfeiltasten der Tastatur ausgewählt wurde. Voraussetzung ist wie bei der Vorschau von Videodateien die Installation von Totem. Nach einer kurzen Verzögerung wird die Audio-Vorschau automatisch aktiv. In der Listenansicht ist diese Funktionalität nicht vorhanden. Unter "Bearbeiten → Einstellungen → Vorschau" kann man die Vorschau für Audio-Dateien bei Bedarf auch deaktivieren.

RAW-Dateien

Um unter Caja eine Bildvorschau für RAW-Dateien (digitale Bilder) zu erhalten, muss man ein wenig nachhelfen. Zunächst muss das folgende Paket installiert [1] werden:

  • ufraw (universe)

Paketliste zum Kopieren:

sudo apt-get install ufraw 

Oder mit apturl installieren, Link: apt://ufraw

Anschließend muss die Datei /usr/share/thumbnailers/raw.thumbnailer mit Root-Rechten erstellt [2] und folgender Inhalt eingefügt werden:

[Thumbnailer Entry]
Exec=/usr/bin/ufraw-batch --embedded-image --out-type=png --size=%s %u --overwrite --silent --output=%o
MimeType=image/x-3fr;image/x-adobe-dng;image/x-arw;image/x-bay;image/x-canon-cr2;image/x-canon-crw;image/x-cap;image/x-cr2;image/x-crw;image/x-dcr;image/x-dcraw;image/x-dcs;image/x-dng;image/x-drf;image/x-eip;image/x-erf;image/x-fff;image/x-fuji-raf;image/x-iiq;image/x-k25;image/x-kdc;image/x-mef;image/x-minolta-mrw;image/x-mos;image/x-mrw;image/x-nef;image/x-nikon-nef;image/x-nrw;image/x-olympus-orf;image/x-orf;image/x-panasonic-raw;image/x-pef;image/x-pentax-pef;image/x-ptx;image/x-pxn;image/x-r3d;image/x-raf;image/x-raw;image/x-rw2;image/x-rwl;image/x-rwz;image/x-sigma-x3f;image/x-sony-arw;image/x-sony-sr2;image/x-sony-srf;image/x-sr2;image/x-srf;image/x-x3f;

Jetzt ist Caja in der Lage, Vorschaubilder für RAW-Dateien zu erzeugen.

Suchfunktion

Caja bietet die Möglichkeit, eine ausgeführte Suche als Lesezeichen zu speichern. Diese gespeicherten Suchen erscheinen wie ein Ordner, dessen Inhalt beim Aufrufen jeweils neu berechnet wird. Ist Tracker installiert, bedient sich Caja dessen Suchtechnik, so dass auch der Inhalt von Dokumenten durchsucht wird und die stets aktuellen Suchergebnisse deutlich schneller zur Verfügung stehen.

Daten brennen

Caja ermöglicht im Zusammenspiel mit Brasero, Daten oder Musiktitel direkt auf ein Medium wie eine CD oder DVD zu brennen. Hierzu wählt man bei einer Datei oder einem Ordner über das Kontextmenü (rechte Maustaste) "Senden an..." aus und benutzt als Zielort "CD/DVD-Ersteller". Die hinzugefügten Dateien erscheinen daraufhin im virtuellen Ordner (siehe Abschnitt Virtuelle Ordner) burn:///, dem auch weitere Daten hinzugefügt werden können.

Entfernte Dateisysteme

Caja kann via GVFS auch mit Dateien auf entfernten Computern umgehen (Netzlaufwerke, Freigaben). Diese Dateien werden wie lokale Dateien in einem Ordner dargestellt. Dazu öffnet man in Caja die Adresszeile und verwendet die folgenden Angaben. Wie man erkennen kann, ist es möglich, gleich Zugangsdaten und Pfade entfernter Dateisysteme mit anzugeben.

./Cajaentferntedateisysteme.png

Entfernte Dateisysteme
Protokoll Beispiel Beschreibung
Samba smb://rechnername/freigabe Das Linux-Pendant zur Windows-Dateifreigabe. Über Samba kann man nicht nur auf Freigaben von Windowsrechner zugreifen, sondern es auch unter Linux und Mac OS X nutzen. Durch die plattformübergreifende Verwendung die "Lingua franca" unter den Netzwerkprotokollen.
FTP ftp://192.168.0.1 Ein beliebtes Protokoll, um Dateien zu transferieren. Üblicherweise bekommt man die Möglichkeit, per FTP Dateien auf einem Webserver abzulegen.
WebDAV dav://login@example.com/ordner Ein Protokoll, um Dateien über das Internet bereitzustellen. Beispiele sind Apples iDisk oder das GMX Mediacenter.
davs://login:passwort@example.com Identisch zu dav://, allerdings wird die Verbindung verschlüsselt.

SSH ssh://benutzer@server:port/pfad/ordner Datei-Transfer zur sicheren und unkomplizierten Datenübertragung zwischen Linux/Unix-Systemen. Die Angabe der Portnummer ist nur erforderlich, wenn dieser vom Standardport 22 abweicht.
SFTP sftp://benutzer:passwort@server:port "Secure File Transfer Protocol". Praktisch identisch zu ssh://.

Virtuelle Ordner

Caja kann neben entfernten Dateisystemen auch lokale Verzeichnisse und Dateien zusammenfassen und als virtuelle Ordner darstellen. Diese lassen sich über bestimmte Adressen direkt aufrufen. Ein Beispiel: trash:/// steht symbolisch für den Papierkorb (siehe Adressleiste). Eine Übersicht ist im Artikel GVFS (Abschnitt „Anwendung“) zu finden.

Dokument anlegen erweitern

Caja bietet eine Funktion, um im geöffneten Ordner eine neue Datei anzulegen. Diese erreicht man über "Datei → Dokument anlegen" oder "rechte Maustaste-Klick → Dokument anlegen". Standardmäßig wird hier nur der Eintrag "Leere Datei" angeboten, mit dem man ein leeres Textdokument erstellen kann.

Um weitere Vorlagen zur Verfügung zu haben, kann man Dateien in den Ordner ~/Vorlagen im Homeverzeichnis ablegen. Also z.B. eine leere ~/Vorlagen/LibreOffice_Writer.odt zur Textverarbeitung. Auch für Quelltexte ist dies nützlich: So kann man beispielsweise LaTeX-Dateien, die für verschiedene Zwecke ein Grundgerüst enthalten, dort ablegen.

Funktionsumfang erweitern

Wie Eingangs erwähnt, können Funktionen über Erweiterungen, Aktionen und Skripte ergänzt werden.

Caja neu starten

Neu installierte Erweiterungen, Skripte sowie manche Einstellungen sind erst nach einem Neustart von Caja verfügbar. Da Caja als Hintergrundprozess läuft (siehe Desktop-Symbole), reicht es nicht, alle offenen Fenster von Caja zu schließen. Ab- und neu anmelden oder ein kompletter Neustart des Systems erreichen das Gewünschte, aber es gibt einen schnelleren Weg über ein Terminal:

caja --quit 

Gleichwertig ist:

caja -q 

Hinweis:

Beide Befehle beenden Caja komplett und führen dazu, dass alle Dateimanager-Fenster geschlossen werden. Man sollte also nicht gerade nebenbei größere Dateien kopieren.

Neu gestartet wird Caja meist automatisch. Sollte dies nicht der Fall sein, kann Caja über die Eingabe caja im Terminal wieder aufgerufen werden.

Mit Root-Rechten arbeiten

./Caja_gksu.png Nicht ohne Grund arbeitet man unter Linux nur selten mit Root-Rechten. Ganz besonders bei einer grafischen Oberfläche besteht das Risiko, Fehler zu machen. Oder eine Schwachstelle in einem Programm beeinträchtigt die Sicherheit. Trotzdem ist es manchmal angebracht, einen Dateimanager mit vollen Rechten zur Hand zu haben.

Dazu startet man Caja kurzerhand aus einem Terminal oder über Alt + F2 mittels des Befehls:

gksudo caja 

(Hinweis: Ab Ubuntu 18.04 ist gksudo nicht mehr in den Paketlisten enthalten.) Nach der Eingabe des Passwortes öffnet sich ein Caja-Fenster mit Root-Rechten.

Alternativ kann bis Ubuntu 16.04 das folgende Paket installiert [1] werden:

  • caja-gksu (universe)

Paketliste zum Kopieren:

sudo apt-get install caja-gksu 

Oder mit apturl installieren, Link: apt://caja-gksu

ab Ubuntu 18.04

  • caja-admin (universe)

Paketliste zum Kopieren:

sudo apt-get install caja-admin 

Oder mit apturl installieren, Link: apt://caja-admin

Nach der Installation des Paketes und einem Neustart von Caja erscheint im Kontextmenü rechte Maustaste einer Datei oder eines Ordners die Option "Als Administrator öffnen". (Hinweis: Ab Ubuntu 19.10 ist caja-admin bereits standardmäßig installiert.)

Erweiterungen

In den offiziellen Paketquellen sind ab Ubuntu 14.10 folgende Erweiterungen enthalten:

./folder_color.png

  • caja-image-converter (universe, Bildgröße und Ausrichtung per Kontextmenü rechte Maustaste ändern)

  • caja-open-terminal (universe, Ein Terminal via Kontextmenü rechte Maustaste aus Caja heraus öffnen)

  • caja-sendto (universe, Ausgewählte Dateien an entfernte Dateisysteme oder als Anlage an ein E-Mail-Programm senden. Optional können sie dabei gepackt werden.)

  • caja-share (universe, Eine persönliche Freigabe im Netzwerk via Samba und net usershare erstellen)

  • caja-dropbox (multiverse, Dropbox-Integration, erst ab Ubuntu 16.04)

  • folder-color-caja (universe, Ordnersymbole einfärben)

Paketliste zum Kopieren:

sudo apt-get install caja-image-converter caja-open-terminal caja-sendto caja-share caja-dropbox folder-color-caja 

Oder mit apturl installieren, Link: apt://caja-image-converter,caja-open-terminal,caja-sendto,caja-share,caja-dropbox,folder-color-caja

Darüber hinaus gibt es noch Erweiterungen, die aus Fremdquellen stammen:

Damit neu installierte Erweiterungen verfügbar sind, muss Caja neu gestartet werden.

./caja-actions_logo.png

Aktionen

Caja bietet zusätzliche Funktionen durch die direkte Integration weiterer Programme bzw. Systemfunktionen ("Caja Actions"). Diese Funktionen entsprechen denen von Nautilus. Dazu muss zuerst folgendes Paket installiert werden:

Paketliste zum Kopieren:

sudo apt-get install caja-actions 

Oder mit apturl installieren, Link: apt://caja-actions

Anschließend steht ein grafisches Verwaltungswerkzeug zur Verfügung, das über den Menüeintrag "System → Einstellungen → Darstellung → Einstellungen für Caja-Actionen" gestartet werden kann. Verfügbare Aktionen sind im Kontextmenü rechte Maustaste unter "Caja-Actions actions" zu finden.

Auch das Erstellen eigener Aktionen mit einem Editor ist nicht sonderlich schwer. Ein Beispiel, um Dateien mit wipe sicher zu löschen:

[Desktop Entry]
Type=Action
Description=secure delete with wipe
Description[de]=Mit wipe sicher löschen
ToolbarLabel=secure delete
ToolbarLabel[de]=Sicher löschen
Name=secure delete
Name[de]=Sicher löschen
Profiles=profile-zero;

[X-Action-Profile profile-zero]
OnlyShowIn=MATE;
Exec=/usr/bin/wipe -rf %F
Name=Default profile
Name[de]=Vorgabeprofil

Aktionen müssen mit der Endung .desktop unter:

  • ~/.local/share/file-manager/actions/

gespeichert werden, beispielsweise als wipe.desktop. Wer tiefer einsteigen möchte, zieht die Dateien im Ordner /usr/share/caja-actions/samples/ zu Rate.

Skripte

Caja ermöglicht – analog zu Nautilus – die Verwendung von Skripten als Erweiterung im Kontextmenü. Diese Skripte sind ausführbare Dateien, welche im Verzeichnis ~/.config/caja/scripts/ gespeichert werden. Damit neu installierte Erweiterungen verfügbar sind, muss Caja neu gestartet werden. Sie sind über den Kontextmenüeintrag "Skripte" aufrufbar, der Name des Menüeintrages entspricht dabei dem Namen des Skriptes. Eine Zuordnung von Hot-Keys ist leider nicht möglich. In diesem Kontextmenü ist via "Skriptordner öffnen | Mehr Details anzeigen" eine kurze Doku über den im Skript verfügbaren Kontext (Parameter, Umgebungsvariablen CAJA_SCRIPT*) vorhanden.

Weitere Tipps gibt es unter Migrating from Nautilus 🇬🇧 im MATE-Wiki. Zwei Beispiele:

  • Sammeldruck - Mehrere ausgewählte PDF-, ODT-, DOC-, DOCX- oder HTML-Dateien direkt über das Kontextmenü rechte Maustaste drucken.

     1
     2
     3
     4
     5
     6
     7
     8
     9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32
    33
    34
    35
    36
    37
    38
    39
    40
    41
    42
    43
    44
    45
    46
    47
    48
    49
    50
    51
    52
    53
    54
    55
    56
    57
    58
    59
    60
    61
    62
    63
    64
    65
    66
    67
    68
    69
    70
    71
    72
    73
    74
    75
    76
    77
    78
    79
    80
    81
    82
    83
    84
    85
    86
    87
    88
    89
    90
    #!/bin/bash
    
    ################################################################################
    ####                       Batch-Print unter Linux                         #####
    ################################################################################
    
    ################################################################################
    ####  Funktion: Nautilus oder Caja Skript zum Ausdrucken                    ####
    ####            mehrerer ausgewählter Dateien                               ####
    ####  Quellen:  http://wiki.ubuntuusers.de/caja#Funktionsumfang-erweitern   ####
    ####            http://wiki.ubuntuusers.de/Nautilus/Skripte                 ####
    ####            http://wiki.mate-desktop.org/migrating                      ####
    ####  Autor:    Joachim Jakob                                               ####
    ####            Kronberg-Gymnasium Aschaffenburg                            ####
    ####  Datum:    26.02.2015                                                  ####
    ####  Verwendung:                                                           ####
    ####            Speichere dieses Skript in...                               ####
    ####            .config/caja/scripts           # für Caja                   ####
    ####            .local/share/nautilus/scripts  # für Nautilus               ####
    ####  Benötigt: caja-actions                                                ####
    ####            unoconv                                                     ####
    ####            zenity                                                      ####
    ################################################################################
    
    ## ist unoconv installiert?
    ## aptitude search unoconv|grep ^i | wc -l
    ## muss als Ausgabe 1 liefern (falls 0 ist das Programm nicht installiert)
    ## nötigenfalls nachinstallieren mit
    ## sudo apt-get install unoconv
    
    DRUCKER="$(lpstat -p |awk '{print $2}'|head -n1)"
    DRUCKOPTIONEN_PDF="-o PrinterResolution=FromPrintoutMode -o PrintoutMode=Normal -o PageSize=A4 -o PageRegion=A4 -o InputSlot=Default -o Duplex=None"
    DRUCKOPTIONEN_ASCII="--file-align=virtual --no-header -1"
    DRUCKOPTIONEN_OpenDocument=""
    TDIR=$(mktemp -d)
    
    for FILE in "$@"; do
        DATEITYP="$(file ${FILE} | awk '{print $2}')"
        case "${DATEITYP}" in
            PDF)
                ## PDF-Dateien
                zenity --info "Datei wird gedruckt" --text "PDF $FILE"
                lpr -P "${DRUCKER}" "${DRUCKOPTIONEN_PDF}" "${FILE}"
                ;;
            ASCII)
                ## Textdateien
                zenity --info "Datei wird gedruckt" --text "ASCII ${FILE}"
                #a2ps --printer="${DRUCKER}" "${DRUCKOPTIONEN_ASCII}" "${FILE}"
                unoconv --format=pdf --doctype=document --output="${TDIR}" "${FILE}"
                NEWFILE=$(echo "${FILE}"| sed -e 's/.txt$/.pdf/')
                lpr -P "${DRUCKER}" "${DRUCKOPTIONEN_PDF}" "${TDIR}/${NEWFILE}"
                rm "${TDIR}/${NEWFILE}"
                ;;
            OpenDocument)
                ## ODF-Dateien
                zenity --info "Datei wird gedruckt" --text "OpenDocument ${FILE}"
                unoconv --format=pdf --doctype=document --output="${TDIR}" "${FILE}"
                NEWFILE=$(echo "${FILE}"| sed -e 's/.odt$/.pdf/')
                lpr -P "${DRUCKER}" "${DRUCKOPTIONEN_PDF}" "${TDIR}/${NEWFILE}"
                rm "${TDIR}/${NEWFILE}"
                ;;
            Composite)
                ## DOC-Dateien
                zenity --info "Datei wird gedruckt" --text "Word DOC ${FILE}"
                unoconv --format=pdf --doctype=document --output="${TDIR}" "${FILE}"
                NEWFILE=$(echo "${FILE}"| sed -e 's/.doc$/.pdf/')
                lpr -P "${DRUCKER}" "${DRUCKOPTIONEN_PDF}" "${TDIR}/${NEWFILE}"
                rm "${TDIR}/${NEWFILE}"
                ;;
            Zip)
                ## DOCX-Dateien
                zenity --info "Datei wird gedruckt" --text "Word DOCX ${FILE}"
                unoconv --format=pdf --doctype=document --output="${TDIR}" "${FILE}"
                NEWFILE=$(echo "${FILE}"| sed -e 's/.docx$/.pdf/')
                lpr -P "${DRUCKER}" "${DRUCKOPTIONEN_PDF}" "${TDIR}/${NEWFILE}"
                rm "${TDIR}/${NEWFILE}"
                ;;
            HTML)
                ## HTML-Dateien
                zenity --info "Datei wird gedruckt" --text "HTML ${FILE}"
                unoconv --format=pdf --doctype=document --output="${TDIR}" "${FILE}"
                NEWFILE=$(echo "${FILE}"| sed -e 's/.html$/.pdf/')
                lpr -P "${DRUCKER}" "${DRUCKOPTIONEN_PDF}" "${TDIR}/${NEWFILE}"
                rm "${TDIR}/${NEWFILE}"
                ;;
        esac
    done
    
    rm -rf "${TDIR}"
    exit 0
    

  • Mit wipe sicher löschen:

    1
    2
    3
    4
    #!/bin/bash
    for FILE in "$@"; do
        /usr/bin/wipe -rf "${FILE}"
    done
    

Weitere Beispiele sind auf GitHub 🇬🇧 zu finden.

Erweiterte Einstellungen

Neben den Einstellungen im Menü unter "Bearbeiten → Einstellungen" kann vieles auch mit dem Konfigurationseditor dconf unterhalb des Schlüssels "org.mate.caja.preferences" eingestellt werden. Manche Optionen sind nur so erreichbar.

Zugriffsrechte-Dialog

Im Dialog für die Einstellung der Zugriffsrechte (zu erreichen über die Eigenschaften einer Datei/eines Verzeichnisses ) kann anstelle der DropDown-Boxen eine Matrix mit CheckBoxen dargestellt werden, in der sich die Zugriffsrechte für Lesen, Schreiben und Ausführen einzeln für jede Benutzergruppe einstellen lassen (besonders interessant für jemanden, der mit der "rwx"-Schreibweise vertraut ist). Hierzu muss man den Konfigurationseditor starten und "org.mate.caja.preferences-show_advanced_permissions" auf true setzen.

Dateien und Verzeichnisse verstecken

Möchte man einige Dateien oder Ordner permanent verstecken, so ist (in dem jeweiligen Verzeichnis, in dem sich die zu versteckenden Einträge befinden) eine Datei .hidden zu erstellen [3], in der die gewünschten Dateien und Verzeichnisse aufgelistet werden.

Datei1
Verzeichnis1
Datei2

Werkzeugleiste anpassen

Möchte man bestimmte Symbole/Funktionen in der Werkzeugleiste ausblenden, so muss man die entsprechende Funktion in einer XML-Datei auskommentieren oder löschen. Diese befindet sich unter /usr/share/caja/ui/caja-navigation-window-ui.xml und muss mit Root-Rechten editiert werden.

Dort findet man unten unter:

<toolbar name="Toolbar">

die entsprechenden Einträge, z.B. für "Zurück" die Zeile:

<toolitem name="Back" action="Back"/>

Wenn man den Eintrag für "Zurück" in der Werkzeugleiste nicht mehr sehen möchte, benutzt man XML-Kommentare. Beispiel:

<!-- toolitem name="Back" action="Back"/ -->

Anschließend Caja neu starten oder ab- und wieder neu anmelden, damit die Änderungen wirksam werden. Da diese Änderung bei einem Update wieder überschrieben werden kann, sollte man die geänderte Datei zusätzlich ins Homeverzeichnis kopieren, um sie bei Bedarf wiederherstellen zu können.

Chronik/Historie nicht anzeigen

Über "Gehe zu" zeigt Caja zehn der zuletzt geöffneten Ordner an. Aus Gründen der Privatsphäre lässt sich dies abschalten, indem man die GUI-Einstellungen bearbeitet. Zuerst legt man eine Sicherung der Datei an:

sudo cp /usr/share/caja/ui/caja-navigation-window-ui.xml /usr/share/caja/ui/caja-navigation-window-ui.xml.bak 

Dann öffnet man die Datei /usr/share/caja/ui/caja-navigation-window-ui.xml in einem Editor mit Root-Rechten und löscht die folgenden vier Zeilen:

<separator/>Skripte
<menuitem name="Clear History" action="Clear History"/>
<separator/>
<placeholder name="History Placeholder"/>

Nun Caja neu starten. Ein Ab- und wieder Anmelden des Benutzers oder Neustart des Systems bewirken das Gleiche.

Hinweis:

Zuletzt geöffnete Ordner werden weiterhin gespeichert, aber nicht mehr angezeigt.

Tastenkürzel

Tastenkürzel
Taste(n) Zweck
Strg + L Adresszeile anzeigen ( Esc schaltet wieder zurück)
Strg + H Versteckte Dateien anzeigen/ausblenden
Strg + W Aktuellen Reiter schließen. Wenn nur ein Reiter vorhanden ist, wird das komplette Caja-Fenster geschlossen. In der Einzel-Ansicht wird der Eltern-Ordner geschlossen.
Strg + + W Schließt alle übergeordneten Ordner (in der Einzel-Ansicht)
Strg + 1 Symbol-Ansicht
Strg + 2 Listen-Ansicht
Strg + + Voransicht vergrößern
Strg + - Voransicht verkleinern
Strg + 0 Standardgröße anzeigen
F9 Öffnet oder schließt die Seitenleiste
Entf Verschiebt eine Datei/Verzeichnis in den Papierkorb
+ Entf Löscht eine Datei/Verzeichnis sofort (und verschiebt sie nicht in den Papierkorb)
+ Strg + N Neues Verzeichnis anlegen
Strg + M Verknüpfung für das ausgewählte Element (Datei, Ordner) erzeugen
Strg + A alle Dateien auswählen
Strg + S Nach Suchmuster auswählen
F2 Ausgewählte Datei/Verzeichnis umbenennen
F5 aktuelle Ansicht neu laden (refresh)
Strg + T Neuen Reiter öffnen (nicht in Einzel-Ansicht)
Tab ⇆ Wechselt den Fokus zwischen Dateibereich, Dateipfad und Seitenleiste
Alt + Einen Schritt zurück in der Historie
Alt + Einen Schritt vor in der Historie
Alt + oder Öffnet den übergeordneten Ordner
Alt + oder Öffnet den ausgewählten Ordner

Mausaktionen

./Caja_mittlere_Maustaste.png

Mausaktionen
Aktion Wirkung
linke Maustaste + Strg Dateien immer kopieren
linke Maustaste + Dateien immer verschieben
linke Maustaste + Strg + Verknüpfung erstellen
linke Maustaste + Alt oder mittlere Maustaste Bestätigung einer Aktion (Kopieren, Verschieben, Verknüpfen)

Problembehebung

Caja mit Root-Rechten öffnen

In Mate 1.8.x kann es passieren, wenn man Caja als Administrator ausführt, der Desktophintergrund und die Desktop-Einstellungen auf die des Benutzers root geändert werden. Dies kann vermieden werden, wenn Caja mit der Option --nodesktop gestartet wird:

gksudo caja --nodesktop 

Siehe auch Andere Desktop-Umgebungen weiter unten.

Persönliche Orte öffnen sich nicht mit Caja

Teilweise kommt es vor, dass der Aufruf von "Orte → Persönliche Orte" im MATE-Menü Rhythmbox, VLC, Shotwell oder ein anderes Programm statt Caja öffnet. Die naheliegendste Lösung bietet Caja selbst: rechte Maustaste auf einen Ordner und dann "Öffnen mit". Das Problem kann alternativ auch folgendermaßen behoben werden.

  • Von Hand:

    • die Datei ~/.local/share/applications/mimeapps.list editieren [3]

    • dort die Zeile inode/directory=...;Caja-folder-handler.desktop; ändern in inode/directory=Caja-folder-handler.desktop; (... steht hier für evtl. vorhandene andere Programme)

Orte können nicht verwendet werden

Sollte diese Meldung beim Aufrufen von "Netzwerk" oder beim Einbinden eines entfernten Datei-Systems über ftp, sftp etc. erscheinen, dann kann die (Neu-)Installation des folgenden Pakets Abhilfe schaffen:

  • gvfs-backends

Paketliste zum Kopieren:

sudo apt-get install gvfs-backends 

Oder mit apturl installieren, Link: apt://gvfs-backends

Partitionen doppelt angezeigt

Wenn Partitionen über die Datei /etc/fstab per UUID eingebunden werden, kann es vorkommen, dass sie von Caja doppelt angezeigt werden. Dies kann man leicht verhindern, ohne auf den Komfort der UUIDs verzichten zu müssen. Anstatt die Partitionen wie bisher so einzubinden:

UUID=UUID_DER_PARTITION /media/EINHÄNGEPUNKT     ext4 defaults  0  2

schreibt man Folgendes in die Datei /etc/fstab:

/dev/disk/by-uuid/UUID_DER_PARTITION /media/EINHÄNGEPUNKT     ext4 defaults  0  2

Partitionen vor Caja verstecken

Möchte man bestimmte Partitionen in Caja nicht anzeigen, kann man die Partition in der /etc/fstab mit dem Parameter noauto eintragen. Das System hängt die Partition also nicht automatisch ein und Caja zeigt die Partition auch nicht mehr an. Dazu ein Verzeichnis erstellen, an der die Partition eingehängt würde, z.B. mit:

mkdir -p /mnt/unused/partition1 

und die entsprechende Partition mit dem noauto-flag versehen.

UUID=UUID_DER_PARTITION  /mnt/unused/partition1          ext4    defaults,noauto           0       2

Siehe auch Hiding partition in Caja Devices 🇬🇧.

Andere Desktop-Umgebungen

Caja lässt sich auch unter anderen Desktop-Umgebungen verwenden. Da Caja standardmäßig den Desktop verwaltet, muss man Caja aber mit einer Option starten, die dies vermeidet:

caja --no-desktop 

Um nicht jedes Mal den kompletten Befehl angeben zu müssen, empfiehlt es sich, einen alias anzulegen. Dazu öffnet man die Datei ~/.bashrc und ergänzt eine alias-Zeile:

## some more aliases
alias caja='caja --no-desktop'

Alternativ kann man den Programmstarter /usr/share/applications/caja.desktop entsprechend anpassen. Allerdings lauert dabei ein kleine Falle, denn Optionen mit einem -- erfordern eine Sonderbehandlung:

Exec=sh -c "caja --no-desktop"

Diese Revision wurde am 28. März 2020 19:08 von Heinrich_Schwietering erstellt.
Die folgenden Schlagworte wurden dem Artikel zugewiesen: Caja, MATE, Dateimanager