ubuntuusers.de

Tipps

Achtung!

Da von Firefox alle sechs Wochen eine neue Version erscheint, kann dieser Artikel leider nicht – wie sonst in diesem Wiki üblich – mit einer bestimmten Ubuntu-Version getestet werden. Die Mozilla-Entwickler behalten sich vor, jederzeit neue Funktionen hinzuzufügen oder vorhandene wieder aus dem Programm zu entfernen. Unter solchen Umständen ist es nicht möglich, die Korrektheit der in diesem Artikel beschriebenen Informationen dauerhaft für eine Ubuntu-Version zu garantieren.

Firefox/firefox-logo.png Dieser Artikel versucht, die zahllosen im Laufe der Zeit entstandenen Anpassungen des Webbrowsers Firefox an die jeweiligen persönlichen Bedürfnisse zu bündeln. Nicht jeder Tipp hat für jede Firefox- bzw. Ubuntu-Version Gültigkeit – falls dies nicht bereits aus dem jeweiligen Abschnitt hervorgeht, sollte man nicht zögern, diesbezügliche Fragen im hiesigen Forum zu stellen.

Ab Firefox 4

Erscheinungsbild

Den kleinen Pfeil neben dem Zurück/Vor Button, welcher eine Liste aller zuletzt besuchten Websites anzeigt, gibt es in dieser Form nicht mehr. Allerdings genügt ein Rechtsklick rechte Maustaste auf die Schaltfläche, um den Verlauf der letzten Seiten anklicken zu können.

Sitzung speichern

Um die Frage "Sitzung speichern" beim Beenden wieder zu aktivieren, about:config aufrufen und "browser.showQuitWarning" von false in true ändern.

Allgemeine Tipps

Hardware Beschleunigung aktivieren

Wie bei askubuntu beschrieben, ist bei Firefox 30 die Hardware Beschleunigung standardmäßig deaktiviert. Man kann es bei about:support testen, wobei "GPU-beschleunigte Fenster" auf 0/1 gesetzt ist, wenn sie deaktiviert ist. Um sie anzuschalten, setzt man bei about:config layers.acceleration.force-enabled und layers.offmainthreadcomposition.enabled auf true. Danach führt man $ sudo bash -c "echo export MOZ_USE_OMTC=1 >> /etc/X11/Xsession.d/90environment" aus und startet Firefox neu. Wenn man dann bei about:support nachschaut, sollte "GPU-beschleunigte Fenster" auf 1/1 gesetzt sein.

sqlite Datenbanken verdichten

Wenn man die sqlite Datenbanken bei Firefox verdichtet, sollte von der Festplatte weniger gelesen werden, wenn Firefox gestartet oder geschlossen wird (siehe http://ubuntuguide.net/ubuntu-tipspeed-up-firefox-by-compacting-sqlite-databases ubuntuguide.net). Dadurch kann Firefox schneller starten und geschlossen werden. Um sie zu verdichten, muss nur Firefox geschlossen werden und der Befehl $ for f in ~/.mozilla/firefox/*/*.sqlite; do sqlite3 $f 'VACUUM;' & done ausgeführt werden. Möglicherweise muss vorher das Paket sqlite3 installiert werden.

Schrift an MS Windows-Stil anpassen

Unter Ubuntu sehen Webseiten ggf. völlig anders als unter Windows, hin und wieder ist z.B. die Schrift zu breit oder zu groß. Um ein einheitliches Aussehen zu erreichen, kann man die Windows-Schriften installieren.

Dann aktiviert man unter "Bearbeiten → Einstellungen" den Punkt "Inhalt → Schriftarten → Erweitern → Seiten das Verwenden von eigenen statt der oben gewählten Schriftarten erlauben".

Sollte dies wider Erwarten nicht funktionieren, so kann man die Schrift "von Hand" einstellen:

  • "Bearbeiten → Einstellungen → Inhalt → Schriften und Farben → Erweitert"

Dort stellt man Folgendes ein:

  • "Proportional": Serif - Größe (Pixel): 16

  • "Serif": Times New Roman

  • "Sans Serif": Arial

  • "Feste Breite": Courier New - Größe (Pixel): 13

Dann zweimal mit "OK" bestätigen und fertig.

Umlaute/Sonderzeichen werden nicht korrekt dargestellt

Manchmal kommt es vor, dass auf bestimmten Webseiten statt der Umlaute ä,ö,ü und Sonderzeichen (ß etc.) nur Fragezeichen oder seltsame Kodierungen erscheinen. Eine Lösung hier für ist, dass man unter "Einstellungen" den Punkt "Ansicht → Zeichencodierung → automatisch bestimmen → Universell" auswählt.

Test- bzw. Problemseiten:

Verzerrtes Schriftbild/Schlechtes Hinting

Leider folgt der Firefox nicht (immer) den in GNOME/Mate/Xfce festgelegten Einstellungen zur Schriftdarstellung. Mehr Informationen und Tipps für persönliche Anpassungen sind im Artikel Schriftbild verbessern (Abschnitt „Firefox“) zu finden. Die Darstellung kann auch durch die Auswahl anderer Schriftarten in Firefox beeinflusst werden (siehe oben).

Schriftart und -größe der Oberfläche anpassen

Einstellungen für Schriften der Oberfläche (Adressleiste, Tabs, Menüs usw.) werden normalerweise von den Systemeinstellungen übernommen. Allerdings lassen sich diese Einstellungen auch unabhängig vom System den eigenen Bedürfnissen entsprechend anpassen. Dazu wechselt man ins Verzeichnis /home/BENUTZERNAME/.mozilla/. Dort gibt es ein Verzeichnis, dessen Namen aus einer zufälligen Zeichenfolge mit der Endung .default lautet. Dort hinein wechselt man. Jetzt legt man - falls nicht vorhanden . den Ordner chrome und darin die Datei userChrome.css an. In dieser Datei kann man nun Schriftart und -größe festlegen.

Folgender CSS-Code legt z.B. global für die Oberfläche die Ubuntu-Schriftart mit 12pt Grösse fest:

1
2
3
4
* {
    font-family: Ubuntu !important;
    font-size: 12pt !important;
}

Nach einem Neustart von Firefox werden die Änderungen übernommen.

Drucken

Häufig möchte man nur einen bestimmten Teil einer Webseite ausdrucken, z.B. nur den Haupttext ohne die Menüleiste. Firefox unter Linux bringt aber von Haus aus keine Möglichkeit mit, nur eine Markierung oder bestimmte Elemente zum Druck auszuwählen. In diese Lücke springen einige Erweiterungen, wie z.B. Nuke Anything Enhanced 🇬🇧. Mit dieser Erweiterung kann man z.B. den zu druckenden Text auswählen und über "rechte Maustaste → Remove everything else" alle anderen Seitenelemente entfernen.

Alternative Druckdialoge benutzen

Firefox zeigt manchmal nicht alle Drucker im Druckdialog an. Dieses Problem kann man umgehen, indem man die Druckerdialoge von GNOME oder KDE benutzt. Das setzt voraus, dass die Druckfunktion auch in KDE bzw. GNOME richtig konfiguriert ist.

Druckdialoge:

  • KDE: KPrinting

  • GNOME: gtklp

Um diese Druckdialoge zu verwenden, muss im Firefox unter "Datei → Drucken" der Standard-Drucker ausgewählt und dann auf "Eigenschaften" geklickt werden. In dem Eigenschaftendialog muss als Druckbefehl "gtklp" oder "kprinter" eingetragen werden. Die Papiergröße (A4) entsprechend anpassen.

E-Mail Programm mit "mailto-Adressen" verknüpfen

GNOME

Alle installierten Mailprogramme, wie etwa Thunderbird, Evolution, KMail oder Mozilla-Mail werden im GNOME-Menü unter

  • "System → Einstellungen → Bevorzugte Anwendungen → Mailreader"

aufgeführt.

KDE

Im Firefox in die Adresszeile "about:config" eingeben. Danach "Rechte Maustaste → Neu → einen String" "network.protocol-handler.app.mailto" mit dem Wert "kmailservice" anlegen. Möchte man die Mail mit Thunderbird versenden, muss als Wert "thunderbird" angegeben werden.

Klickt man nun im Internet eine E-Mail-Adresse an, die mit mailto eingeleitet wird, so wird das gewünschte Mailprogramm geöffnet.

Hinweis:

Die folgende Anleitung funktioniert auch mit anderen IRC-Clients, wenn der Befehl zum Start des Programms entsprechend angepasst wird.

Hin und wieder trifft man im Internet auf IRC-Links. Diese beinhalten meist einen IRC-Server und einen Channel. Damit sich beim Klick auf den Link XChat öffnet, muss man die Firefox-Konfiguration anpassen: Zunächst gibt man in der Adresszeile von Firefox

about:config

ein. Mit der rechten Maustaste rechte Maustaste klickt man in den unten stehenden Bereich mit den Einstellungen und wählt "Neu → Boolean" aus. In dem erscheinenden Eingabefenster gibt man als Eigenschaftsnamen

network.protocol-handler.external.irc

an und klickt auf "OK". Im neuen Fenster wählt man true aus, klickt nochmals auf "OK". Damit wurde der neue Wert hinzugefügt. Nun muss man noch einen weiteren Eintrag erstellen. Diesmal wählt man den Typ "String" und als Namen

network.protocol-handler.app.irc

Nun erscheint wieder ein Eingabefenster. Hier gibt man xchat %s ein und drückt auf "OK". Jetzt sollte sich bei solchen IRC-Links XChat öffnen, normalerweise auch ohne Firefox-Neustart. Zum Ausprobieren: Der Deutsche Ubuntu-Channel (bis man mit dem Channel verbunden ist, kann einige Zeit vergehen.)

Hinweis:

Bei der Verwendung von HexChat den Befehl nach hexchat %s abändern.

Bei Problemen mit Firefox 3 kann man network.protocol-handler.app.irc auch mit einem Skript verbinden bzw. über "Bearbeiten → Einstellungen → Anwendungen" den Dateityp irc damit neu verbinden, um Server/Channel in einem bereits laufenden XChat zu öffnen. Das Skript dann z.B. unter /bin/xchat.sh abspeichern (Rechte anpassen):

1
2
#!/bin/sh
/usr/bin/xchat -e --url=$1 

Wenn das alles nicht funktioniert, kann man auch den URL-Handler der jeweiligen Desktop-Umgebung ändern. Dazu z.B. für Unity bzw. GNOME den Konfigurationseditor starten, dann den Schlüssel "desktop.gnome.url-handlers.irc" heraussuchen. Dort dann Folgendes eintragen, damit IRC-Links in einem bereits gestarteten XChat geöffnet werden:

xchat -e --url="%s"

DNS-Auflösung über IPv6 abschalten

Falls (und nur wenn) man IPv6 systemweit deaktiviert hat, sollte man auch die Auflösung von Internetadressen anpassen. Dazu öffnet man:

about:config

und setzt den Parameter

network.dns.disableIPv6

auf true.

Mauszeigerdesign in Mozilla-Programmen [KDE]

Häufig ist es der Fall, dass in Mozilla-Programmen (Firefox, Thunderbird) das Mauszeigerdesign mit dem in KDE nicht übereinstimmt. Die Lösung ist ganz einfach, indem man die Datei /usr/share/icons/default/index.theme in einem Editor mit Root-Rechten [2] öffnet bzw. erstellt. Nun fügt man Folgendes in die Datei ein:

[Icon Theme]
Inherits=kubuntu

Abspeichern und gegebenenfalls Firefox neustarten.

URL mit einzelnem Mausklick markieren

Viele Benutzer wünschen sich, wie es unter Mac/Windows Standard ist, dass die komplette URL in der Adressleiste mit einem einzelnen statt einem Doppelklick, wie es unter Linux Standard ist, markiert werden kann. Auch für Umsteiger oder solche, die oft an verschiedenen Betriebssystemen arbeiten, kann es eine Hilfe sein.

Als erstes muss man in die Adressleiste

about:config

eingeben und mit bestätigen. Dann gibt man oben im Filter-Feld den zu ändernden Schlüssel an:

browser.urlbar.clickSelectsAll

Nun sollte dieser als einziger sichtbar sein. Um den Wert zu ändern, reicht ein Doppelklick auf selbigen bzw. setzt man den Wert von false auf true.

Adressleiste

Seit Firefox 7 wird das http:// am Beginn der URL der aufgerufenen Webseite nicht mehr angezeigt. Andere Protokolle wie HTTPS (https://) werden allerdings immer noch angezeigt. Um auch bei HTTP wieder die volle URL zu sehen, gibt man

about:config

in der Adresszeile des Browsers ein und ändert

browser.urlbar.trimURLs

den Wert per Doppelklick auf false.

Firefox mit mehreren Tabs starten

Manchmal ist es gewünscht, Firefox mit beliebig vielen Startseiten als Tabs zu starten. Dazu kann man unter

  • "Hamburger-Menü" → Einstellungen → Startseite"

mehrere Webseiten getrennt durch einen "|" ablegen. Also z.B. einfach

https://www.ubuntuusers.de | https://www.google.de | https://bildblog.de

oder schnell und 4 klicks sparend z.B.

 about:blank | about:blank | about:blank | about:blank | about:blank 

(dunkles) GTK-Design beeinflusst Darstellung

Wenn man ein dunkles GTK-Design benutzt, dann werden innerhalb von Firefox manche Seiten unlesbar dunkel/schwarz dargestellt. Um dies zu verhindern, lädt man sich folgende CSS-Datei herunter: forms.css ⮷ . Diese verschiebt man mit Root-Rechten [5] nach /usr/lib/firefox/res/. Danach öffnet man mit einem Editor [3] mit Root-Rechten [5] die Datei /usr/lib/firefox/res/html.css und ändert ungefähr um die 60. Zeile herum den Text:

body {
 display: block;
 margin: 8px;
}

in Folgendes ab:

body {
 background-color: white;
 color: black;
 display: block;
 margin: 8px;
}

Nach einem Neustart von Firefox ist das Farbproblem gelöst.

Nützliche „Drag and Drop“-Tipps

  • Nicht verlinkte Webadressen schneller aufrufen: Eine nicht verlinkte Webadresse kann schnell geöffnet werden, indem man den Link markiert und diesen mit der Maus in die Adressleiste oder auf einen existierenden Tab zieht.

  • Suchbegriffe im Text schneller finden: Man markiert den Begriff im Text und zieht diesen in die Suchleiste seiner Wahl. Die Suchmaschine wird anschließend automatisch den Begriff finden. Alternativ kann man auch den Begriff markieren und im Kontextmenü (Rechtsklick) über Suchmaschine Suche Begriff den Begriff suchen lassen.

  • Kurzfristig wichtigen Link auf dem Desktop speichern: Indem man das Favicon (das Symbol links neben der Adresse) auf den Desktop zieht, wird eine Verknüpfung mit der jeweiligen Seite auf dem Desktop erstellt. Leider ist das Verhalten von der Desktop-Umgebung abhängig. Unter Xubuntu und Lubuntu funktioniert dieses Verfahren nicht. Hier muss man zuerst ein Lesezeichen anlegen, das anschließend auf den Desktop gezogen werden kann (das Favicon geht dabei verloren). Ob sich dieser Aufwand lohnt, muss jede/r selbst entscheiden.

  • Schnelles Speichern von ganzen Textpassagen in einer Textdatei: Wenn man den Text eines Artikels auf den Desktop zieht, wird automatisch die Datei "kopierter Text.txt" mit dem gewählten Inhalt erstellt. Leider kann es zu Problemen mit den Umlauten und Sonderzeichen kommen. Für Tomboy-Nutzer ist das Firefox-Add-on Tomfox eine Alternative, um dieses Problem zu umgehen.

Suchen mit der Adresszeile

Standardsuchmaschine ändern

Wenn man nicht mit Google suchen möchte, aber es praktisch findet, auch mit der Adresszeile suchen zu können, kann man die verwendete Suchmachine ändern, indem man about:config aufruft, nach keyword sucht und dann den Wert von keyword.URL anpasst. Der Suchbegriff wird an das, was man dort eingibt, angehängt.

Um Ixquick 🇩🇪 als Suchmaschine hinzufügen (keine Speicherung der IP-Adresse, HTTPS-Abfrage und Webproxy möglich), gibt man in das oben genannte Feld folgendes ein:

https://eu2.ixquick.com/do/metasearch.pl?language=deutsch&cat=web&query=

Nach der Änderung des jeweiligen Werts bestätigt man und schließt den Tab. Die Adressleisten-Suche wurde nun umgestellt. Um wieder auf den Vorgabewert zu bekommen, klickt man mit der rechte Maustaste-Taste auf keyword.URL, wählt "Zurücksetzen" und bestätigt mit der linken Maustaste. Die Google-Standardsuche ist wiederhergestellt. Um die Suche in der Adresszeile zu deaktivieren, ruft man die Seite about:config auf, sucht nach "keyword" und ändert dort mit einem Doppelklick den Wert von keyword.enabled auf false. Weitere Hinweise zu Suchmaschinen liefert der Artikel Firefox/Suchfeld.

Vor allem bei kleinen Bildschirmen kann es auch interessant sein, die Adresszeile und das Suchfeld in einem zu haben. Das geht ganz einfach, indem man die Erweiterung Omnibar 🇬🇧 installiert.

Tipps zur Integration in KDE

bei Downloads automatisch den gewünschten Dateimanager öffnen lassen

Hat man eine Datei mit Firefox heruntergeladen und möchte man den Zielordner dieser Datei durch klicken auf "Ziel-Ordner öffnen" anzeigen, verwendet hier Firefox automatisch Nautilus - sofern dieser installiert ist.

Die in der Systemeinstellung von z.B. KDE oder generell mit dem Konsolenbefehl xdg-mime eingestellte Standard-Anwendung für die Dateiverwaltung wird hierbei von Firefox in der aktuellen Version 50.1.0 ignoriert.

Möchte man dieses Verhalten ändern, z.b. weil man möchte, dass der Dateimanager Dolphin anstatt Nautilus geöffnet wird, dann gibt es hierfür einen Workaround. Und zwar muss man dafür für jeden einzelnen Benutzer im Ordner

~/.local/share/dbus-1/services/ 

eine Datei mit dem Dateinamen

org.freedesktop.FileManager1.service

erstellen. Falls es den Ordner mit seinen jeweiligen Unterverzeichnissen in ~/.local/share/ nicht gibt, dann muss dieser erstellt werden.

Die Datei org.freedesktop.FileManager1.service sollte anschließend folgenden Inhalt erhalten:

[D-BUS Service]
Name=org.freedesktop.FileManager1
Exec=/usr/bin/false

Nach einem Neustart des Rechner sollte Firefox beim Klicken von "Ziel-Ordner öffnen" neben dem Feld einer heruntergeladenen Datei, den für den Benutzer standardmäßig eingestellten Dateimanager öffnen. Welcher das ist, kann mit folgendem Konsolenbefehl herausgefunden werden:

xdg-mime query default inode/directory 

Downloads automatisch mit dem richtigen Programm öffnen lassen

Unter GNOME öffnet Firefox heruntergeladene Dateien automatisch mit dem richtigen Programm. Dafür zuständig ist das Programm gnome-open, welches für jede Datei das Standardprogramm der Desktopumgebung auswählt. Unter KDE existiert ein ähnliches Werkzeug: kde-open. Dieses ist nur nicht standardmäßig in Firefox zum Öffnen von Dateien eingestellt. Das lässt sich allerdings ganz einfach nachholen:

  • im Firefox: "Bearbeiten → Einstellungen → Anwendungen"

  • Dort in der Spalte "Dateiteityp" den Eintrag "file" suchen, "Aktion" → Andere Anwendung" auswählen, um im sich öffnenden Fenster zum Pfad /usr/bin/kde-open navigieren. Einen Haken setzen bei "Für alle file-links speichern", dann ist man fertig. Von nun an öffnen sich alle Dateien aus dem Download-Manager mit dem in KDE festgelegten Standardprogramm.

Sollte "kde-open" nicht aufzufinden sein kann man es mit "xdg-open" versuchen.

Tipp: Sollte in der Spalte "Dateityp" der Eintrag "file" nicht angezeigt werden, kann es notwendig sein, erst eine beliebige Datei herunterzuladen und über einen Doppelklick im '"Downloads" Fenster zu öffnen. Danach obige Prozedur wiederholen.

Auf neuen Füchsen bietet sich dieses add-on an: https://addons.mozilla.org/en-US/firefox/addon/content-type-fixer/ womit man bequem jede Dateiart festlegen kann z.B. .pls fürl VLC oder .pdf gleich ins Okular.

Hinweis:

In neueren Firefox Versionen gibt es den Eintrag "file" als Dateityp nicht mehr und dieser wird auch nicht erstellt, in dem man eine beliebige Datei downloaded und über einen Doppelklick im '"Downloads" Fenster öffnet. Als Workaround kann man allerdings den Ordner dieser Datei in einem Dateimanager aufrufen und welcher Dateimanager dafür verwendet werden soll, das kann man in folgendem Tipp nachlesen: Firefox/Tipps (Abschnitt „bei-Downloads-automatisch-den-gewuenschten-Dateimanager-oeffnen-lassen“)

Verlagerung des Browser-Caches

Da der Webbrowser häufig das meistgenutzte Programm ist, macht es u.U. Sinn, den Browser-Zwischenspeicher (Cache) in eine schnelle RAM-Disk zu verlagern. Nachdem diese eingerichtet wurde, gibt man

about:config

in die Adresszeile ein, bestätigt die Sicherheitsabfrage und erstellt über das Kontextmenü rechte Maustaste einen neuen Eintrag vom Typ "String":

browser.cache.disk.parent_directory

Als Wert trägt man den Ordner ein, in den die RAM-Disk eingebunden wurde, beispielsweise /media/ramdisk. Nach einem Neustart des Browsers ist die Änderung aktiv. Überprüfen kann man dies, indem man about:cache eingibt. Dort sollte Cache Directory: /media/ramdisk/Cache stehen und anzeigen, dass der Cache nun auf der RAM-Disk liegt.

Mit einer Verlagerung geht jedoch mit jedem Neustart der gesamte Cache verloren. Dies kann mit dem profile-sync-daemon 🇬🇧, der den Cache beim Neustart automatisch auf/von Festplatte speichert/lädt, vermieden werden. Eine Anleitung zur Einrichtung findet man bei ubuntuforums.org 🇬🇧.

Problembehebung

Ab Firefox 36

Ab Firefox Version 36 entfällt der Kommandozeilenparameter -remote ... ersatzlos. Viele Programme verwendeten diese Option in der Form firefox -remote openURL(<URL>,new-tab). Klickt man dann in diesen Programmen auf einen Link, öffnet sich eine neue Instanz des Firefox mit dessen Standard-Einstellungen - ohne dass die URL geladen wird. Von dieser Problematik sind insbesondere ältere Programme betroffen, die diesen Parameter weiterhin voraussetzen bzw. nicht an die neuen Gegebenheiten angepasst wurden.

Als Lösung entweder den Standard-Browser des Betriebssystems oder einen anderen Browser verwenden (sofern möglich).

Absturzmelder

Stürzt Firefox unvorhergesehen ab, wird eine Dialogbox angezeigt, über die man die Möglichkeit hat einen Report über den Absturz an Mozilla zu senden (Mozilla-Absturzmelder 🇩🇪). Die Reports (abgesendet oder nicht) werden lokal im Verzeichnis ~/.mozilla/firefox/Crash Reports gespeichert.

Mit der Zeit können diese Reports ziemlich viel Plattenplatz in Anspruch nehmen. Das Problem lässt sich beheben, indem man in einem neuen Tab die URL about:crashes eingibt und dort über den entsprechenden Button alle Reports löscht.

Wie man Firefox im abgesicherten Modus startet, ist im Wiki-Artikel Safe-Mode beschrieben.

Diese Revision wurde am 1. Juli 2019 19:54 von ubot erstellt.
Die folgenden Schlagworte wurden dem Artikel zugewiesen: Firefox, Internet