ubuntuusers.de

🛈 Aktuell gibt es im Wiki ca. 380 Artikel, die nur für Xenial getestet sind. Dies entspricht ca. 4,8 % aller Wikiartikel. Damit diese im Frühjahr nicht alle archiviert werden müssen, ist eure Mithilfe gefragt!

jdTextEdit

Dieser Artikel wurde für die folgenden Ubuntu-Versionen getestet:


Du möchtest den Artikel für eine weitere Ubuntu-Version testen? Mitarbeit im Wiki ist immer willkommen! Dazu sind die Hinweise zum Testen von Artikeln zu beachten.

Zum Verständnis dieses Artikels sind folgende Seiten hilfreich:

./Logo.png jdTextEdit ist ein in Python geschriebener Texteditor, der auf dem Qt-Toolkit basiert. Als Editorkomponente dient Scintilla 🇬🇧, welches u.a. auch in Geany und SciTE verwendet wird.

./Screenshot.png Zu den Funktionen von jdTextEdit gehören u.a.:

Installation

pip

jdTextEdit kann mit pip installiert werden.

Wer die neueste Version installieren möchte, kann das Programm über den Python Paketmanager pip installieren:

pip3 install --user jdTextEdit       # Programm wird nur für den aktuellen Nutzer installiert  

Hinweis!

Fremdsoftware kann das System gefährden.

Dabei ist jedoch zu beachten, dass kein Eintrag im Menü angelegt wird.

manuell

Wer jdTextEdit manuell installieren möchte, kann das wie folgt tun:

git clone https://gitlab.com/JakobDev/jdTextEdit.git
cd jdTextEdit
pip3 install -r requirements.txt
chmod u+x jdTextEdit.py 

Anschließend kann jdTextEdit durch ausführen von jdTextEdit.py gestartet werden.

Bedienung

jdTextEdit steht im Menü unter "Entwicklung → jdTextEdit" zur Verfügung.

Das Programm lässt sich ähnlich wie jeder andere Texteditor benutzen. Dateien können entweder über das Menü oder über die Seitenleiste, welche mit "Ansicht → Seitenleiste" eingeblendet werden kann, öffnen. Die Einstellungen lassen "Bearbeiten → Einstellungen" finden.

Plugins können mithilfe des Pluginmanagers, der unter "Bearbeiten → Pluginmanager" zu finden ist, installiert werden. Dazu setzt man einfach ein Häkchen bei den Plugins, die installiert werden sollen und klickt auf OK.

Um eigene Vorlagen dem Menü hinzuzufügen, muss man sie in den Ordner "templates" im Speicherordner, welchen man unter "? → Speicherordner öffnen" öffnen kann, kopieren.

Portabler Modus

jdTextEdit lässt sich mithilfe des Arguments -p im portablen Modus starten. Dabei werden alle Dateien im gleichen Ordner gespeichert, in dem das Programm abgelegt ist. Dadurch kann das Programm z.B. auf einem USB-Stick mitgenommen und ohne Instalation benutzt werden. Voraussetzung dafür ist jedoch, dass sich entweder auf dem USB-Stick oder auf dem Zielsystem Python mit allen benötigten Paketen installiert ist.

Einrichtung für mehre Nutzer

jdTextEdit kann auch für die Benutzung von mehren Nutzern eingerichtet werden. Mit Programmordner ist im folgenden der Ordner gemeint, denn man mit "? → Programmordner öffnen" öffnen kann. Mit Speicherordner ist im folgenden der Ordner gemeint, denn man mit "? → Speicherordner öffnen" öffnen kann.

Voreinstellungen festlegen

jdTextEdit speichert alle Daten wie z.B. Einstellungen, eigene Makros und Befehle usw. in seinem Speicherordner. Es kann ein vordefinierter Speicherordner festgelegt werden. Dazu muss der Speicherordner als default_data in den Programmordner kopiert werden. Wenn ein Nutzer, der noch keinen eigenen Speicherordner besitzt, jdTextEdit startet, wird der Inhalt von default_data in den eigenen neu erstellten Speicherordner kopiert. Auf Nutzer mit bereits vorhandenen Speicherordner, hat default_data keinen Einfluss.

Einstellungen für mehrere Nutzer treffen

Es können Makros, Befehle, Plugins und Vorlagen für mehrere Nutzer bereitgestellt werden. Vorlagen müssen dazu in den Ordner templates und Plugins in den Ordner plugins im Programmordner kopiert werden. Für Makros legt man im Programmordner die Datei macros.json und für Befehle die Datei commands.json an. Beiden Dateien haben exakt den selben Aufbau wie die gleichnamigen Dateien im Speicherordner. Es ist also empfehlenswert, Makros und Befehle normal über das entsprechende Menü hinzuzufügen und danach die entsprechenden Dateien vom eigenen Speicherordner in den Programmordner zu kopieren.

Diese Revision wurde am 18. Januar 2021 17:08 von JakobDev erstellt.
Die folgenden Schlagworte wurden dem Artikel zugewiesen: Programmierung, Editor