ubuntuusers.de

SciTE

Dieser Artikel wurde für die folgenden Ubuntu-Versionen getestet:


Du möchtest den Artikel für eine weitere Ubuntu-Version testen? Mitarbeit im Wiki ist immer willkommen! Dazu sind die Hinweise zum Testen von Artikeln zu beachten.

Zum Verständnis dieses Artikels sind folgende Seiten hilfreich:

./icon.png SciTE 🇬🇧 ist ein übersichtlicher und mächtiger Texteditor. Als ressourcenschonender Editor mit wenigen Abhängigkeiten ist SciTE ein beliebter Texteditor bei Nutzern, die Wert auf schlanke, aber funktionsreiche Programme legen.

Durch viele Funktionen für das Arbeiten mit Quellcode kann der Editor als kleine Entwicklungsumgebung angesehen werden. So bietet SciTE neben Syntaxhervorhebung, Zuklappen von Funktionen und automatischem Einrücken Möglichkeiten zum Ausgeben, Kompilieren und zur Fehlersuche in Programmen verschiedener Programmiersprachen. Mehrere Dateien können in Reitern (Tabs) geöffnet werden und als Sitzung gespeichert werden.

Installation

Folgendes Paket muss installiert werden [1]:

  • scite (universe)

Befehl zum Installieren der Pakete:

sudo apt-get install scite 

Oder mit apturl installieren, Link: apt://scite

Benutzung

./scite.png SciTE kann man bei Ubuntu-Varianten mit einem Anwendungsmenü über "Entwicklung → SciTE" oder mit folgendem Befehl starten [2]:

scite 

Die Bedienung als Texteditor unterscheidet sich im Grunde nicht von den Standard-Editoren der Ubuntu-Derivate und ist am ehesten mit gedit und Geany zu vergleichen.

Alle Befehle zum Arbeiten stehen in der Menüleiste, für die meisten Aktionen gibt es Tastenkürzel. SciTE startet standardmäßig mit englischer und sehr schlichter Benutzeroberfläche. Unter "Languages" ("Hervorhebung" ) wird die gewünschte Syntaxhervorhebung ausgewählt und nicht etwa die Sprache der Oberfläche. Veränderungen am Programmfenster unter "View" ("Ansicht" ) gelten nur für dieses Fenster und nur bis zum Schließen.

Sprache

Ist systemweit die deutschsprachige Oberfläche gewünscht, reicht es die Datei locale.de.properties von GitHub 🇬🇧 herunterzuladen und als locale.properties mit Root-Rechten [3] nach /usr/share/scite/ zu verschieben.

Mehrsprachig wird SciTE, wenn man alle benötigten Sprachdateien herunterlädt und mit Root-Rechten im Ordner /usr/share/scite/ speichert. So kann jeder die gewünschte Sprachdatei in den eigenen Benutzer-Einstellungen selbst festlegen.

Konfiguration

Die für die Grundeinstellungen verantwortlichen globalen Konfigurationsdateien befinden sich in /usr/share/scite/SciTEGlobal.properties. Diese kann aber jeder für sich über "Optionen → Benutzer-Einstellungen bearbeiten" ("Options → Open User Options File" ) in der Datei ~/.SciTEUser.properties überschreiben.

Auswahl von Startoptionen aus SciTEDoc 🇬🇧
Schlüssel Beschreibung
locale.properties locale.XX.properties benennt die lokalisierte Sprachdatei. Diese muss in /usr/share/scite/ vorhanden sein. XX wird durch die Länderkennung nach ISO 639-1 ersetzt.
position.maximize Mit position.maximize=1 wird SciTE maximiert gestartet.
position.left
position.top
position.width
position.height
Positions- und Größenangaben des Fensters werden in Pixel angegeben. Diese Werte werden auch bei position.maximize übergeben und wirken sich erst bei "Maximierung aufheben" aus.
Bei zu großen Werten wird das Fenster nur bis an den Rand der Arbeitsfläche geschoben oder gedehnt.
toolbar.visible
toolbar.usestockicons
toolbar.visible=1 blendet die Werkzeugleiste beim Start ein; um die Icons der Desktopumgebung zu nutzen wird toolbar.usestockicons=1 gesetzt
line.margin.visible
line.margin.width
Eine Spalte für die Zeilennummern bewirkt line.margin.visible=1. Deren Breite wird durch die Anzahl der Zeichen bestimmt. Bei line.margin.width=3+ werden durch das angehängte Plus auch vier- und mehrstellige Zahlen vollständig angezeigt.

Beispielkonfiguration

## Deutsche Sprachdatei für diesen Benutzer. Muss in /usr/share/scite/ liegen.
 locale.properties=locale.de.properties

## Breite und Höhe des Fensters in Pixeln festlegen, maximiert starten
 position.width=1200
 position.height=900
 position.maximize=1

## Werkzeugleiste anzeigen, Icons vom Desktop-Theme benutzen
 toolbar.visible=1
 toolbar.usestockicons=1

## nichtproportionale Schrift für alle Texte
 font.base=$(font.monospace)
 font.small=$(font.monospace)
 font.comment=$(font.monospace)
 font.text=$(font.monospace)
 font.text.comment=$(font.monospace)
 font.embedded.base=$(font.monospace)
 font.embedded.comment=$(font.monospace)
 font.vbs=$(font.monospace)

## Zeilennummern anzeigen, Ziffernanzahl (hier mindestens 4, mehr wenn nötig) festlegen
 line.margin.visible=1
 line.margin.width=4+

## Pfadanzeige ausblenden, Statusbar anzeigen, Anzeige personalisieren kompletten Pfad unter der Tableiste anzeigen
 pathbar.visible=0
 statusbar.visible=1
 statusbar.text.1=\
	$(FilePath) | $(FileDate) - $(FileTime) |\
	| $(BufferLength) Zeichen, $(NbOfLines) Zeilen | Position $(LineNumber)/$(ColumnNumber) |\
	| Attribute:$(FileAttr) | Highlighting:$(Language) | Eingabemodus:$(OverType)

Programmierung

Über den Menüpunkt "Extras" können die Funktionen zum Starten, Kompilieren und Debuggen (Fehlersuche) von Programmen aufgerufen werden. Dabei öffnet sich eine Seitenleiste mit der Ausgabe, die auch über das Menü geöffnet werden kann:

  • "Ansicht → Ausgabe"

Dieses Ausgabefenster ist eine Terminal-Emulation, kann also auch als Eingabe verwendet werden.

Projektverwaltung

Hinweis:

Für umfangreiche Projekte sollte besser eine der hier im Wiki vorgestellten Entwicklungsumgebungen verwendet werden.

Sitzung

SciTE bietet lediglich die Möglichkeit, mehrere Dateien als Sitzung zu verwalten:

  • "Datei → Sitzung laden..."

  • "Datei → Sitzung speichern..."

SciteProj

sciteproj.png Für kleinere Projekte eignet sich die schlichte Projektverwaltung SciteProj 🇬🇧. Sie wird verwendet, um Dateien gruppiert anzuzeigen und so einen einfacheren Zugang durch SciTE zu haben. Dateioperationen wie Löschen, Verschieben, Kopieren und Umbenennen sind nicht möglich. Seit Version 0.8 hat SciteProj die Art und Weise wie "Projekte" behandelt werden verändert.

Folgendes Paket muss installiert werden [1]:

  • sciteproj (universe)

Befehl zum Installieren der Pakete:

sudo apt-get install sciteproj 

Oder mit apturl installieren, Link: apt://sciteproj

SciteProj bindet sich nicht automatisch in ein Startmenü ein und wird daher über den folgenden Befehl gestartet [2]:

sciteproj 

ab Version 0.8

Arbeitsweise

In SciteProj werden zunächst alle Ordner und Dateien unterhalb des Projektordners gelistet. Dateien lassen sich dabei ausblenden, Ordner von außerhalb hinzufügen.

Konfiguration

SciteProj sucht nach der Datei ~/.config/sciteprojrc.lua, in der einige globale Einstellungen gemacht werden können.

-- Hier die gewünschte Fenstergeometrie/Positionierung eingeben, die beim nächsten Programmstart auf das Programm angewendet wird.
xpos = 0
ypos = 0
width = 300
height = 700
-- Das SciTE-Fenster erhält den Fokus, wenn eine Datei aus SciteProj geöffnet wird. (Default: false)
give_scite_focus = true

-- Statusbar ausblenden um Platz zu sparen (Default: false)
hide_statusbar = true

-- Geschlossenes Ordnersymbol des Systems verwenden. Hinweis: SciteProj unterscheidet zwischen offenen und geschlossenen Ordnern. (Default: false)
use_stock_folder_icon = false

-- SciTE direkt beim Start von SciteProj starten. (Default: false)
start_scite = false

Benutzung

Zweckmäßigerweise übergibt man beim Start von SciteProj den vorhandenen Projektordner.

sciteproj -l /var/www/html/projekt/ 

Eine eigene sciteprojrc.lua in diesem Ordner sorgt für projektbezogene Einstellungen.

-- Liste der ausgeblendeten Dateien - Wildcards funktionieren.
hide_filter = {
	-- ".htacess",
	-- "log/*.log",
	-- "todo",
	".htpasswd",
	"bak"
}

-- Hier individuelle Sortierreihenfolge für Ordner festlegen. Der Punkt bezeichnet den Projektordner wenn kein kompletter Pfad angegeben ist.
-- 0 - aufsteigend (Default)
-- 1 - absteigend
-- 2 - aufsteigend, sortiert nach Dateiendung
-- 3 - absteigend, sortiert nach Dateiendung
sort_order = {
	["./img/temp/"] = 0,
	["~/upload"] = 2
}

-- Welche Ordner sollen beim Start geöffnet oder geschlossen dargestellt werden? (Default: false)
open_folders = {
	["bin"] = true,
	["src"] = true,
	["src/test"] = false,
	["po"] = false
	
}

Diese Revision wurde am 6. Mai 2021 07:18 von frustschieber erstellt.
Die folgenden Schlagworte wurden dem Artikel zugewiesen: Programmierung, Editor