ubuntuusers.de

ubuntuusers.deWikiPidgin

Pidgin

Dieser Artikel wurde für die folgenden Ubuntu-Versionen getestet:

./pidgin_logo.png Pidgin {en} ist ein Instant Messenger, der es erlaubt, dasselbe Programm für verschiedene Instant-Messenger-Dienste zu nutzen. Ursprünglich ist das Projekt unter dem Namen Gaim geführt, jedoch wegen markenrechtlicher Probleme in Pidgin umbenannt worden. Erweiterungen ermöglichen es, die jeweiligen Protokolle für Pidgin zu implementieren.

Unterstützte Protokolle

./Pidgin.png

Installation

Pidgin wird mittels des folgenden Pakets installiert [1]:

  • pidgin

Wiki/Vorlagen/Installbutton/button.png mit apturl

Paketliste zum Kopieren:

sudo apt-get install pidgin 

sudo aptitude install pidgin 

PPA

Adresszeile zum Hinzufügen des PPAs:

  • ppa:pidgin-developers/ppa

Hinweis!

Zusätzliche Fremdquellen können das System gefährden.


Ein PPA unterstützt nicht zwangsläufig alle Ubuntu-Versionen. Weitere Informationen sind der Wiki/Vorlagen/PPA/ppa.png PPA-Beschreibung des Eigentümers/Teams pidgin-developers zu entnehmen.

Damit Pakete aus dem PPA genutzt werden können, müssen die Paketquellen neu eingelesen werden.

Nach dem Aktualisieren der Paketquellen erfolgt die Installation wie oben beschrieben.

Selber kompilieren

Wie man Pidgin selber kompiliert, steht unter Pidgin/Kompilieren.

Einrichten

Nach Abschluss der Installation kann das Programm im Startmenü über

  • "Anwendungen -> Internet -> Pidgin" (Gnome)

  • "Applications -> Netzwerk -> Pidgin" (Xfce)

  • "K-Menü -> Internet -> Pidgin" (KDE)

oder alternativ mit dem Befehl pidgin gestartet werden [4]. Um Pidgin automatisch beim Anmelden des Benutzers zu starten, kann man einen Eintrag im Autostart [5] hinzufügen.

./Konto.png

Konto

Um ein bestehendes Konto hinzuzufügen:

  1. Protokoll auswählen (IRC, XMPP (Jabber) ... )

  2. Benutzernamen, Passwort und Alias eingeben

  3. Domain angeben (z.B. debianforum.de)

  4. [X] Häkchen setzen, falls die Option "Passwort speichern" gewünscht ist.

    Hinweis:

    Alle Passwörter werden im Klartext in einer XML-Datei gespeichert und können dementsprechend von jedem, der darauf Zugriff hat, ausgelesen werden. Abhilfe schafft die Verwendung des GNOME-Keyring.

  5. Buddy-Icon auswählen durch Anwählen von "Dieses Buddy-Icon für dieses Konto benutzen:" und ./select-avatar.png (optional)

  6. Speichern

Nun findet man das soeben eingerichtete Konto bei "Anmelden" und "Konten" wieder. Der Punkt "Konten" kann geschlossen werden. Um sich anzumelden, nur noch auf "Anmeldung" klicken, schon wird man verbunden.

Sollte für das gewünschte Protokoll kein Zugang bestehen, so kann man sich auf den jeweiligen Webseiten anmelden.

Als ein neues Fenster öffnet sich nun die Kontaktliste.

ICQ

./icq.png Den Zugang für ICQ einrichten:

  1. Unter "Konten -> Hinzufügen -> [Hinzufügen]" das Protokoll "ICQ" wählen

  2. Benutzername: ICQ-Nummer angeben

  3. Passwort: ********

  4. Lokaler Alias: Nickname angeben (optional)

  5. Passwort speichern: an-/abwählen

  6. Buddy-Icon auswählen durch Anwählen von "Dieses Buddy-Icon für dieses Konto benutzen:" und ./select-avatar.png (optional)

  7. Auf den Reiter "/Erweitert/" wechseln

  8. "Benutze SSL" anwählen

  9. "clientLogin benutzen" anwählen

  10. "[Speichern]"

IRC

./irc.png Für einen Internet Relay Chat-Zugang folgende Daten verwenden:

  1. Unter "Konten -> Hinzufügen -> [Hinzufügen]" das Protokoll "IRC" wählen.

  2. Server angeben z.B. irc.freenode.net

  3. Benutzernamen (z.B. Foren-Spitzname), Passwort und Alias eingeben.

  4. Häkchen setzen bei den Optionen "Passwort speichern" und "Autologin".

  5. "[Speichern]"

Zum Anmelden (Login) nur noch auf "Anmeldung" klicken, und schon wird man verbunden. Nach erfolgreichem Anmelden beginnt das Pidgin-Icon zu blinken. Ein Klick darauf und ein neues Fenster öffnet sich. Es empfiehlt sich, das Purple Plugin Pack {en} zu verwenden (Paket pidgin-plugin-pack), das einige wichtige IRC-Funktionen bereitstellt. Weitere Informationen zu IRC

Wen Status-Meldungen des IRC-Servers stören, kann den Namen, unter dem die Meldungen laufen (z.B. "Nickserv"), unter "Werkzeuge -> Privatsphäre -> Nur unten stehende Benutzer Blockieren" eintragen. Man sollte aber bedenken, dass man so auch erwünschte Meldungen (beispielsweise über Service-Zeiten) blockiert.

XMPP (Facebook, GoogleTalk, u.v.m.)

./jabber.png Um sich mit einem neuen oder bereits bestehenden XMPP-Zugang (Jabber) zu verbinden, genügen folgende Schritte:

  1. Unter "Konten -> Hinzufügen -> [Hinzufügen]" das Protokoll "XMPP" wählen

  2. Benutzer: z.B. Forennick

  3. Domain: siehe XMPP/Server

  4. Ressource: z.B: Home, Laptop oder Arbeit

  5. Passwort: ********

  6. Passwort speichern: an-/abwählen

  7. Buddy-Icon auswählen durch Anwählen von "Dieses Buddy-Icon für dieses Konto benutzen:" und ./select-avatar.png

  8. Falls der Account noch nicht existiert, "Dieses neue Konto auf dem Server anlegen" anwählen.

  9. Zugang "[Speichern]"

MSN

./msn.png Um sich mit dem MSN-Zugang von messenger.live.de {de} zu verbinden, genügen folgende Schritte:

  1. Unter "Konten -> Hinzufügen -> [Hinzufügen]" das Protokoll "MSN" wählen

  2. Benutzer: MSN-Email (z.B: Mustermann@live.de)

  3. Passwort: ********

  4. Passwort speichern: an-/abwählen

  5. Buddy-Icon auswählen durch Anwählen von "Dieses Buddy-Icon für dieses Konto benutzen:" und ./select-avatar.png

  6. Zugang "[Speichern]"

Yahoo Messenger

Archiv/Gaim/yim.png Um sich mit einem Yahoo-Konto zu verbinden, genügen folgende Schritte:

  1. Unter "Konten -> Hinzufügen -> [Hinzufügen]" das Protokoll "Yahoo" wählen

  2. Benutzer: Vollständige Mail-Adresse

  3. Passwort: ********

  4. Passwort speichern: an-/abwählen

  5. Buddy-Icon auswählen durch Anwählen von "Dieses Buddy-Icon für dieses Konto benutzen:" und ./select-avatar.png

  6. Zugang "[Speichern]"

Zeroconf/Avahi

./bonjour.png Wie einige andere XMPP-Clients auch, bietet Pidgin die Möglichkeit, über Avahi auch ohne Server bzw. Internetverbindung mit Kontakten im LAN zu chatten. Dabei nutzt Pidgin das sogenannte Zeroconf-Protokoll, um potentielle Chatpartner zu finden. Das funktioniert völlig unabhängig von der Kontaktliste. Man kann also alle Benutzer im lokalen Netz automatisch "sehen", ohne irgendwelche JIDs irgendeinem Raster hinzuzufügen.

Zeroconf stammt ursprünglich von der Firma Apple, deren Implementation "Bonjour" heißt. Deswegen wird das Protokoll in Pidgin auch so genannt. Um es zu nutzen, muss man also ein neues Bonjour-Konto einrichten. Die einzigen Daten, die man dabei unbedingt eingeben muss, heißen Benutzer und Rechnername, wobei man aber frei wählen kann.

Unter dem neu erstellten Konto erscheinen nun automatisch alle anderen lokalen Benutzer, die dieses Protokoll ebenfalls aktiviert haben. Mit diesen kann man nun ganz normal chatten, wie man es bei XMPP (Jabber) gewöhnt ist. Auch Dateiübertragungen funktionieren.

Leider unterstützen noch nicht alle XMPP-Clients dieses Protokoll. Ein anderes Programm, das es tut, ist Gajim, ebenso wie iChat von Apple.

Hinweis:

Unter Verwendung eines Bonjour-Konto können keine Dateien > 2GiB übertragen werden.

XMPP-Transport nutzen

Um unter Pidgin die Transports eines XMPP-Servers nutzen zu können, müssen diese erst gefunden werden, um sich bei ihnen registrieren zu können.

Standardmäßig ist die XMPP-Dienstsuche in Pidgin deaktiviert, und man muss sie erst über "Werkzeuge -> Plugins" aktivieren. Ist dies geschehen, kann man unter "Werkzeuge -> XMPP-Dienstsuche" den Server des jeweiligen Kontos nach Diensten durchsuchen und sich mit einem Klick auf "Registrieren" anmelden.

XMPP-Verschlüsselung

Um den XMPP-Chat zu verschlüsseln, muss das OTR-Plugin installiert und unter "Werkzeuge -> Erweiterungen -> Off-the-Record Messaging" aktiviert werden. Nun befindet sich im Gesprächsfenster eine OTR-Schaltfläche. Bei der ersten Nutzung wird automatisch ein Schlüssel generiert. Während das Fenster erscheint, dass der Schlüssel generiert wird, sollte man nicht geduldig warten, sondern einfach den Rechner weiter nutzen. Der Schlüssel wird nämlich durch die eigene Aktivität zufallsgeneriert. Verschlüsselt werden kann natürlich nur, wenn beide Seiten ein OTR-fähiges Programm nutzen. Ist die Verschlüsselung einmal eingerichtet, wird die Verschlüsselung in Gesprächen immer automatisch aktiviert.

Hinweis:

Audio-/Video-Anrufe werden nicht verschlüsselt. Auch Offline-Text-Nachrichten sind von der Verschlüsselung ausgenommen, da zur Verschlüsselung beide Seiten gleichzeitig online sein müssen. Ob die Verschlüsselung gerade aktiv ist, erkennt man an der OTR-Schalftläche im Gesprächsfenster.

./skype.png

Skype-Protokoll hinzufügen

Hinweis:

Um Skype via Pidgin nutzen zu können, muss Skype installiert sein. Zum Chatten in Pidgin muss auch Skype zur selben Zeit laufen und verbunden sein!

Man installiert aus den Paketquellen das Plugin pidgin-skype, welches das Chatten über Pidgin (oder Empathy und andere Instant Messenger, die libpurple verwenden) erlaubt.

  • pidgin-skype

Wiki/Vorlagen/Installbutton/button.png mit apturl

Paketliste zum Kopieren:

sudo apt-get install pidgin-skype 

sudo aptitude install pidgin-skype 

Einrichtung

Man schließt Pidgin, startet Skype und meldet sich mit seinen Nutzerdaten an. Ist man mit Skype verbunden, startet man Pidgin und wechselt in die Kontenübersicht: ./attachment_linux-skype-confirmation.png

  1. Unter "Konten -> Hinzufügen -> [Hinzufügen]" das Protokoll "Skype" wählen

  2. Skype-Benutzername, Skype-Passwort (nur bis Ubuntu 9.10) und frei wählbaren Alias eingeben

  3. Buddy-Icon auswählen durch anwählen von "Dieses Buddy-Icon für dieses Konto benutzen:" und ./select-avatar.png

  4. Im Reiter "Erweitert" kann man weitere Einstellungen seinen Wünschen entsprechend aktivieren.

  5. "[Speichern]"

  6. Kurz darauf fragt Skype, ob Pidgin auf Skype zugreifen darf (siehe nebenstehendes Bild), was man erlauben muss, und beendet Pidgin.

  7. Man startet nun Pidgin erneut, um die Skype-Kontakte in der Buddy-List sichtbar zu machen (Gruppe Skype).

Testanruf für Skype-Plugin

Um zu prüfen, ob Telefonieren mit Pidgin möglich ist, kann man einen neuen Kontakt ("Buddy") anlegen, indem man als Name echo123 angibt. In der Liste erscheint dies als "Echo / Sound Test Service".

Steam-Protokoll hinzufügen

pidgin-opensteamworks {en} nutzt Steams Mobile-API, und so muss Steam selbst weder im Hintergrund laufen noch überhaupt installiert sein. Auch ein Login über mehrere Geräte gleichzeitig ist möglich. Wie im Steam-Chat im normalen Steam-Client sieht man, in welchem Spiel sich gerade die Freunde befinden.

Das entsprechende Plugin ist auf der Projektseite von openstreamworks zu finden. Je nachdem, ob es sich um ein 32bit- oder 64bit-System handelt, muss die entsprechende .so-Datei heruntergeladen werden. Nach abgeschlossenem Download wird diese in den Ordner ~/.purple/Plugins verschoben. Nach einem erfolgten Neustart von Pidgin ist das Plugin eingelesen.

Das Plugin von Opensteamwork funktioniert derzeit nicht. Ersatzweise gibt es steampurple, das sich genauso installieren lässt und funktioniert.

Einrichtung

Man wechselt in die Kontenübersicht:

  1. Unter "Konten -> Hinzufügen -> [Hinzufügen]" das Protokoll "Steam" wählen

  2. Steam-Benutzername, Steam-Passwort und optional frei wählbaren Alias eingeben

  3. "[Hinzufügen]"

  4. Sofern Steam Guard aktiviert ist, erscheint nun ein Fenster, um den Steam Guard-Code einzugeben. Dazu wartet man auf die automatisch versendete E-Mail vom Steam-Support und trägt nach Empfang den Code entsprechend ein.

    • Der Steam Guard-Code kann nachträglich über den Reiter "Erweitert -> Steam Guard Code" angepasst werden.

XFire-Protokoll hinzufügen

./Gfire-Logo-48x48.png Damit man über Pidgin auch mit Spiel-Kollegen aus dem XFire {en} - Netzwerk kommunizieren kann, gibt es das Plugin gFire {en}, das direkt von der Entwicklerseite {en} als Paket[1] heruntergeladen werden kann.

Hinweis!

Zusätzliche Fremdquellen können das System gefährden.

Nach der Installation und einem Neustart von Pidgin kann man sich wie folgt mit seinem Benutzerkonto ("account") bei Xfire anmelden:

  1. Unter "Konten -> Hinzufügen -> [Hinzufügen]" das Protokoll "Xfire" wählen

  2. Xfire-Benutzername, Xfire-Passwort und frei wählbaren Alias eingeben.

  3. Im Reiter "Erweitert" kann man weitere Einstellungen seinen Wünschen entsprechend aktivieren.

  4. "[Speichern]"

Hinweis: Um dieses Plugin benutzen zu können, muss ein Nutzerkonto auf XFire {en} vorhanden sein.

Twittern mit Pidgin

./twitter.png Um Mikroblogging-Dienste wie Twitter {en} oder Identi.ca {de} mit Pidgin nutzen, also Nachrichten empfangen oder absenden zu können, muss das folgende Plugin installiert werden [1]:

  • pidgin-microblog (universe)

Wiki/Vorlagen/Installbutton/button.png mit apturl

Paketliste zum Kopieren:

sudo apt-get install pidgin-microblog 

sudo aptitude install pidgin-microblog 

Hinweis:

Nach der Installation ist ein Neustart von Pidgin erforderlich.

Die Einrichtung für ein bestehendes Twitter-Konto erfolgt dann beispielsweise so:

  1. Unter "Konten -> Hinzufügen -> [Hinzufügen]" das Protokoll "Twitter" wählen

  2. Twitter-Benutzername, Twitter-Passwort und frei wählbaren Alias eingeben

  3. Im Reiter "Erweitert" kann man weitere Einstellungen entsprechend den eigenen Wünschen aktivieren

  4. "[Speichern]"

Buddys hinzufügen

Sofern man jemanden kennt, der z.B. einen XMPP-Zugang hat, so kann man diesen wie folgt hinzufügen: "Buddys -> Buddy hinzufügen...". Nun die bekannten Daten eingeben.

Status

Der Status ist entweder im "Systray" oder in der geöffneten Buddy-Liste zu erkennen. Sie zeigt den eigenen Status und den der Buddys an. Es gibt im Systray oder in der Buddy-Liste folgende Status als Standard zur Auswahl:

Status
./available.png Verfügbar sein für alle Buddys
./away.png Abwesend - z.B. nach längerer Inaktivität
./extended-away.png Persönliche Abwesenheitsnachricht z.B. Ich bin gerade nicht hier.
./busy.png Beschäftigt
./invisible.png Unsichtbar für andere Buddys
./offline.png Trennung der Verbindung / nicht im Chat

Weiterhin kann man dem ausgewählten Status auch noch eine Meldung hinzufügen, dazu ist diese einfach im Textfeld darunter einzugeben. Wenn kein Textfeld vorhanden ist, muss das Auswahlmenü geöffnet und der gewollte Status noch einmal ausgesucht werden. Ein banales Beispiel: Man könnte "Abwesend" mit der Meldung darunter "Bin gerade beim Lösen eines schwierigen Linux-Problems" verwenden.

Jede Meldung wird im Status-Menü gespeichert. Um Meldungen wieder zu Löschen, muss man lediglich die rechte Maustaste auf einer Meldung im Status-Menü gedrückt halten und dann Entf eingeben. Über das erscheinende Abfrage-Fenster kann die Meldung entfernt werden.

Außerdem kann man auch weitere Status mittels "Neuer Status..." im bereits erwähnten Menü erstellen und über "Gespeicherter Status" verwalten.

Automatisches Ausloggen bei Standby

Wenn man den Computer in den Ruhezustand ("standby") schickt, meldet sich Pidgin vorher nicht ab ("logout"), so dass man je nach Server noch ca. 15 Minuten online erscheint. Nachrichten, die in diesen Zeitraum kommen, gehen verloren (icq/jabber/irc). Damit sich Pidgin vor dem Ruhezustand automatisch abmeldet und nachher wieder anmeldet ("login"), kann man folgendes Script 00pidgin in /etc/pm/sleep.d/ erstellen (man ersetze dabei "user" mit dem Benutzernamen; die Statusnachricht bleibt unberührt):

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
#!/bin/sh
#
# 00pidgin: set offline/online status

case "$1" in
hibernate|suspend)
DISPLAY=:0 su -c 'purple-remote setstatus?status=offline' user
;;
thaw|resume)
DISPLAY=:0 su -c 'purple-remote setstatus?status=available' user
;;
*) exit $NA
;;
esac

./Einstellungen.png

Einstellungen

Einige sinnvolle Erweiterungen, die aktiviert werden sollten:

Offline-Buddys anzeigen

Normalerweise werden die Offline-Buddys ausgeblendet. Um dies zu ändern, die Option "Buddys -> Zeige Offline-Buddys" aktivieren.

Tonausgabe (de)aktivieren

In manchen Situationen ist es angenehmer, die Tonausgabe zu deaktivieren. Dies kann man unter "Werkzeuge -> Einstellungen -> Klänge" tun und ist besonders empfehlenswert, wenn man z.B. neben dem Chatten noch ein anderes Programm laufen hat, welches, die Tonausgabe blockiert. Schließt man dieses Programm, werden alle bis dahin eingegangenen Meldungen abgespielt! Alternativ kann man deswegen die Klänge abschalten.

Gesprächsmitschnitt

Um die Gespräche mit den unterschiedlichen Chatpartnern ggf. nochmals nachlesen zu können, empfiehlt es sich, bei "Werkzeuge -> Einstellungen -> Mitschnitt" als Format "einfacher Text" zu wählen und beim "Nachrichtenmitschnitt" alle Häkchen zu setzen. Nun wird im Homeverzeichnis ein Ordner ~/.purple/logs erstellt. Hier findet man alle Protokolle fein säuberlich sortiert nach den Kriterien:

  • Dienst

  • benutztes Konto

  • Gesprächspartner und

  • Gesprächsmitschnitt

Privatsphäre

Um Einstellungen an der Privatsphäre vorzunehmen, "Werkzeuge -> Privatsphäre" anwählen. Nun das gewünschte Konto wählen und zwischen den Einstellungsoptionen wählen:

  • Allen Benutzern erlauben, mich zu kontaktieren

  • Nur den Benutzern in meiner Buddy-Liste erlauben, mir Nachrichten zu senden

  • Erlaube nur den unten stehenden Benutzern, mir eine Nachricht zu senden

  • Blockiere alle Benutzer

  • Blockiere nur unten stehende Benutzer

Chatroom

Um mit vielen Menschen über das ein oder andere Thema zu sprechen, kann man Chatrooms aufsuchen. In Pidgin geht man wie folgt vor: "Werkzeuge -> Chaträume -> Liste abrufen". Nun einen Raum, z.B. ubuntu-de, auswählen und "Betreten". Möchte man diesen Chatraum der eigenen Liste hinzufügen, wählt man vorher "Chat hinzufügen" aus. Dies funktioniert nur bei Zugängen von: Y!M, XMPP (Jabber) und IRC.

./audio-videochat.png

Audio-/Videochat via XMPP

  1. Kontakt mit Rechtsklick auswählen

  2. Audio-Anruf bzw. Audio/Video-Anruf auswählen (nur verfügbar bei Kontakten, bei denen es auch möglich ist)

Plugins

Pidgin verfügt über eine Reihe von Erweiterungen. Diese müssen teilweise bei Bedarf nachinstalliert werden. Die Plugins findet man unter "Werkzeuge -> Plugins". Diese können im nun erscheinenden Fenster (de)aktiviert werden. Neben den Basiserweiterungen stehen unter anderem diese Plugins zur Verfügung:

  • pidgin-otr (universe, Das Off-the-Record Messaging Plugin bietet Verschlüsselung. Das OTR-Plugin steht für viele weitere IM-Programme zur Verfügung, wie z.B. Miranda, Trillian, Kopete, Psi und Adium))

  • pidgin-encryption (universe, Verschlüsselung)

  • pidgin-extprefs (universe, Eine Reihe von Plugins, um das Verhalten und die Darstellung von Pidgin zu ändern.)

  • pidgin-libnotify (universe, Popups beim Empfang von Nachrichten über den Benachrichtigungsdienst von GNOME)

  • pidgin-guifications (universe, Popups beim Empfang von Nachrichten)

  • pidgin-hotkeys (universe, Die Hotkeys individuell einstellen)

  • pidgin-librvp (universe, MS Exchange RVP Instant Messaging Plugin)

  • pidgin-blinklight (universe, Lässt die LEDs ThinkLight eines IBM/Lenovo ThinkPad bei neuen Nachrichten blinken)

  • pidgin-plugin-pack (universe, 30 weitere zum Teil nützliche Plugins)

  • pidgin-musictracker (universe, Aktueller Status deines Musik Players anzeigen lassen)

Wiki/Vorlagen/Installbutton/button.png mit apturl

Paketliste zum Kopieren:

sudo apt-get install pidgin-otr pidgin-encryption pidgin-extprefs pidgin-libnotify pidgin-guifications pidgin-hotkeys pidgin-librvp pidgin-blinklight pidgin-plugin-pack pidgin-musictracker 

sudo aptitude install pidgin-otr pidgin-encryption pidgin-extprefs pidgin-libnotify pidgin-guifications pidgin-hotkeys pidgin-librvp pidgin-blinklight pidgin-plugin-pack pidgin-musictracker 

Pidgin-LaTeX

Für LaTeX-Liebhaber existieren verschiedene Plugins, die LaTeX-Code rendern und als Bild ins Chat-Fenster einfügen. Informationen und Installationshinweise finden sich im Wiki-Artikel Pidgin/PidginTeX.

Pidgin-GNOME-Keyring

Das Pidgin-GNOME-Keyring Plugin (32bit) {dl} von der Projektseite {en} herunterladen und in den Ordner ~/.purple/plugins/ kopieren. Danach sollte man das Plugin in Pidgin aktivieren. Benötigt man eine 64bit-Version der Datei, muss das Plugin kompiliert oder direkt als Debianpaket installiert werden. Zum Kompilieren wird das Paket libgnome-keyring-dev benötigt.

Kompilieren

Zum Kompilieren des Plugins einfach folgende Befehle nacheinander in ein Terminalfenster [2] eingeben.

svn checkout http://pidgin-gnome-keyring.googlecode.com/svn/trunk/ pidgin-gnome-keyring-read-only
cd pidgin-gnome-keyring-read-only/
sudo apt-get install libgnome-keyring-dev
make
cp gnome-keyring.so ~/.purple/plugins/ 

Debian-Pakete

Download 32-/64-Bit {{dl}

KDE/KWallet-Integration

Da Pidgin eingegebene Passwörter in Klartext speichert können diese von jedem der Zugriff auf den PC hat recht einfach ausgelesen werden. Mit Hilfe eines Plugins kann man, sofern man Pidgin unter KDE verwendet, die Passwörter in der KDE Brieftasche speichern lassen. Dazu benötigt man das Libpurple KWallet Plugin {en}. Voraussetzung ist die Installation [1] des folgenden Pakets:

  • libnet-dbus-perl

Wiki/Vorlagen/Installbutton/button.png mit apturl

Paketliste zum Kopieren:

sudo apt-get install libnet-dbus-perl 

sudo aptitude install libnet-dbus-perl 

Anschließend kann man das Plugin einfach mit den folgenden Befehlen [2] in das Plugin-Verzeichnis von Pidgin herunterladen:

mkdir ~/.purple/plugins
cd ~/.purple/plugins
wget http://gitorious.org/libpurple-kwallet-plugin/libpurple-kwallet-plugin/blobs/raw/master/libpurple_kwallet_plugin.pl 

Zuletzt muss man alle gespeicherten Passwörter in den Pidgin-Einstellungen löschen, die Häkchen unter "Passwort speichern" entfernen und Pidgin neustarten. Nun gibt man nacheinander die benötigten Passwörter ein ("Passwort speichern" nicht aktivieren) und sie werden automatisch von KWallet gespeichert.

./logo.png

Optische Anpassungen

Startbildschirm ändern

Um den Startbildschirm den individuellen Bedürfnissen anzupassen, benötigt man ein PNG-Bild mit folgenden Maßen: Breite: 331 px. Höhe: 90 px.

Man kann im Internet passende Bilder herunterladen oder die Beispielbilder nutzen, die hier {en} zu finden sind. Das gewünschte Bild herunterladen und umbenennen in logo.png. Alternativ kann GIMP genutzt werden.

Danach öffnet man den Ordner, in dem sich das Logo befindet, und gibt im Terminal [2] folgendes ein:

sudo cp /usr/share/pixmaps/pidgin/logo.png  /usr/share/pixmaps/pidgin/logo.png_old   #legt eine Sicherheitskopie des alten Logos an
sudo cp logo.png /usr/share/pixmaps/pidgin                                           #kopiert das neue Logo 

./pidgin-screenlet_small.png

Buddy-Liste als Screenlet

Die sehr schöne Möglichkeit, sich die Buddy-Liste auch direkt auf dem Desktop anzeigen zu lassen, bietet das Pidgin-Screenlet {en}.

Nach der Installation des Hauptprogramms Screenlets wird das Pidgin-Screenlet heruntergeladen und entpackt. Den dabei entstandenen Ordner "Pidgin" dann in den versteckten Ordner ~/.screenlets/ kopieren. Jetzt kann Pidgin, genau wie alle anderen Screenlets, über den Screenlets Manager aufgerufen und konfiguriert werden. Es existieren zur Zeit noch fünf weitere Themes für Pidgin, um die Buddy-Liste im gewünschten Design anzeigen zu lassen.

Themen ändern

Man kann das Smiley-, Kontaktlisten-, Klang- und Status-Symbolthema anpassen. Ändern kann man die Themen unter "Werkzeuge -> Einstellungen -> Themen". Es können auch weitere Themen heruntergeladen (s. Links) und installiert werden. Dafür entpackt [3] man heruntergeladene Smileythemen einfach in das Verzeichnis ~/.purple/smileys und alle anderen in ~/.purple/themes. Sollen die Themen für alle Nutzer des Rechners verfügbar sein, entpackt man sie mit Root-Rechten [10] nach /usr/share/pixmaps/pidgin/.

Buddy Icon

Buddy Icons sind kleine Bilder, ähnlich wie die Avatare im Forum. Um diese zu verwenden, wählt man "Konten -> Hinzufügen / Ändern". Nun das Konto auswählen und "Bearbeiten" anwählen. ./select-avatar.png anwählen und das gewünschte Bild auswählen. Dieses sollte jedoch nicht größer als 4 kB sein und als .gif, .jpg oder .bmp vorliegen. Abschließend "Speichern".

Tastenkürzel

Chatfenster
Strg + letzte gesendete Zeile wieder aufrufen
Strg + M Neuen Gesprächs-Tab öffnen (nach Eingabe des Empfängers)
Strg + W Aktiven (Gesprächs-)Tab schließen

Kontaktliste
Strg + B Buddys hinzufügen
Strg + A Konten hinzufügen / ändern
Strg + P Einstellungen
Strg + T Dateiübertragungen
Strg + Q Programm beenden

Tastenkürzel für Senden ändern

Um zusätzlich zu Enter mit Alt + S senden zu können, fügt man folgenden Code in die .purple/gtkrc-2.0 im Homeverzeichnis ein [6]:

binding "my-bindings"
{
    bind "<alt>s" { "message_send" () }
}
widget "*pidgin_conv_entry" binding "my-bindings" 

Wenn die Tastenbelegung schon belegt ist, bei der englischen Pidgin-Version z.B. durch "Smile!", muss die Werkzeugleiste für Formatierungen unter "Optionen" ausgeblendet werden.

Rechtschreibkorrektur

Als Vorgabe sind lediglich die Korrektur in der deutschen und der englischen Sprache zu finden. Um eine weitere Sprache hinzuzufügen, muss das entsprechende myspell-Paket installiert [1] werden:

  • myspell-es (spanische Sprache)

  • myspell-fr (französische Sprache)

  • myspell-it (italienische Sprache)

  • myspell-nl (niederländische Sprache)

  • myspell-pl (polnische Sprache)

  • myspell-ru (russische Sprache)

Wiki/Vorlagen/Installbutton/button.png mit apturl

Paketliste zum Kopieren:

sudo apt-get install myspell-es myspell-fr myspell-it myspell-nl myspell-pl myspell-ru 

sudo aptitude install myspell-es myspell-fr myspell-it myspell-nl myspell-pl myspell-ru 

Nach der Installation muss Pidgin neugestartet, aber sonst nichts weiter eingerichtet werden. Es ist lediglich im Kontextmenü des Eingabefeldes die entsprechende Sprache zu wählen. Weitere Sprachpakete sind in den Paketquellen zu finden.

Speicherort

Möchte man isoliert seine Konto- oder Buddyeinstellungen sichern bzw. transferieren, findet man diese im Verzeichnis ".purple"

  • Zertifikate im Verzeichnis "certificates"

  • Mitschnitte im Verzeichnis "logs"

  • das eigene Konto unter "accounts.xml"

  • die Kontakte Buddies unter "blist.xml"

sowie weitere Einstellungen u.a. zu OTR.

Möchte man beispielsweise seine Mitschnitte auch unter Windows verfügbar haben, empfiehlt es sich, einen Link zu der zuvor in Ubuntu eingebundenen Windows-Partition einzurichten. Dazu gibt man in einem Terminal Folgendes ein:

ln -s /pfad/zu/pidgin/unter/windows/logs ~/.purple/ 

Dadurch schreibt dann Ubuntu auf die Windows-Partition, und man kann Pidgin plattformübergreifend nutzen.

Problembehebung

Pidgin findet keine Netzverbindung

Es kann es vorkommen, dass Pidgin startet, aber keine Netzwerkverbindung findet. Momentan hilft dann, das Konto zu de- und wieder zu aktivieren. Alternativ hilft, das Programm mittels

pidgin -f 

zu starten. Hinweis im Forum

Dateitransfer

Dem Dateitransfer in Pidgin stehen oft Hindernisse im Weg, die mit den folgenden Tipps ausgeräumt werden sollen.

Offener Port

Für den Dateitransfer über ein Protokoll etwa XMPP (Jabber) muss sichergestellt werden, dass, sofern vorhanden, in Router und Firewall ein Port offen ist. Im Fall des Routers geschieht dies im Regelfall über das Web-Interface des Routers. Weitere Informationen dazu liefert das Wiki unter Portweiterleitung. Es wird im Folgenden davon ausgegangen, dass am Router der Port 8010 freigegeben ist.

Dateien an Windows/ICQ6 senden

Sollte das Versenden von Dateien nur mit Windows/ICQ6 Buddys nicht funktionieren, hilft es, unter "Konten -> DEINE_NUMMER(ICQ) -> Konten verwalten -> Erweitert" ein Häkchen bei "Benutze immer den AIM/ICQ-Proxyserver für Dateiübertragungen ..." zu setzen.

Nutzung des richtigen Ports

Pidgin muss nun noch mitgeteilt werden, welcher Port für den Dateitransfer genutzt werden soll. Dazu ändert man in "Werkzeuge -> Einstellungen -> Netzwerk" den Punkt "Port-Bereich, auf dem gehört werden soll, manuell bestimmen" für Start- und End-Port auf 8010.

Nutzung der richtigen IP-Adresse

Ein weiterer Problempunkt kann die öffentliche IP-Adresse des Computers sein, die Pidgin beispielsweise durch einen Router standardmäßig nicht nutzt. Um dies zu ändern, muss unter "Werkzeuge -> Einstellungen -> Netzwerk" im Punkt "Öffentliche IP" überprüft werden, ob die korrekte IP-Adresse eingetragen ist. Welche Adresse in diesem Feld zu finden sein sollte, lässt sich etwa durch Aufruf der Internet-Seite wieistmeineip.de {de} herausfinden. Ist eine falsche oder keine Adresse zu sehen, so muss bei "STUN-Server" stunserver.org eingetragen werden. Nach einem Neustart von Pidgin und einiger Wartezeit sollte man erneut überprüfen, ob nun eine korrekte IP-Adresse eingetragen ist.

Dateiübertragung wird abgebrochen

Mit am LAN angeschlossenen Rechnern kann es mit Ubuntu 12.04 vorkommen, dass die Dateiübertragung mittels Bonjour abgebrochen wird. Um dies zu beheben, muss in der Datei /etc/avahi/avahi-daemon.conf die Einstellung von use-ipv6=yes auf use-ipv6=no geändert werden. Hierfür sind Rootrechte erforderlich [10].

Nutzung mit Tor

Achtung!

Die Entwickler von Tor warnen davor {en} Instant Messenger wie Pidgin mit Tor zu verwenden, weil nicht ausgeschlossen werden kann, dass die gewünschte Anonymität nicht durch Daten, die der Messenger überträgt, verraten wird.

Hinweis:

Es wird darauf hingewiesen {en}, dass Anonymität nicht gewährleistet werden kann, wenn zu dem selben Server sowohl eine Verbindung über Tor als auch eine Direktverbindung besteht. Es empfiehlt sich, Konten die über Tor genutzt werden sollen, als einziges Konto auf dem Server zu führen.

Falls man dennoch Pidgin mit Tor nutzen möchte, so ist unter Konten ->Bearbeiten -> Erweitert -> Proxy-Optionen "SOCKS5" auszuwählen, "Host" ist dann 127.0.0.1 und "Port" ist 9050.

Mehrere Dateien empfangen oder versenden

Leider kommt es zu Problemen, wenn man mehrere Dateien gleichzeitig empfangen möchte. Die einzige Lösung ist derzeit, die Dateien in ein Archiv zu packen (z.B. Zip) und dann zu versenden. Siehe: Link ins Forum.

"Pidgin zu alt" Meldung

Es kann vorkommen, dass Pidgin die Mitteilung ausgibt, dass man die aktuelle Version installieren soll. Dies ist meistens jedoch nicht notwendig, da es sich hierbei nicht um einen veralteten Client, sondern um ein veraltetes Protokoll handelt.

Man kann die aktuelle Version von den Paketquellen der Entwickler herunterladen oder das Protokoll per Hand installieren: Das Protokoll lässt sich nämlich durch Herunterladen aktualisieren, insbesondere durch Entpacken und Kopieren der Datei liboscar.so in den Ordner /usr/lib/purple-2. Die aktuelle Version der Datei liboscar.so kann man von hier {dl} herunterladen. Das Archiv muss man entpacken [3] und dann die Datei an die richtige Stelle kopieren [2] [8]:

sudo cp /usr/lib/purple-2/liboscar.so /usr/lib/purple-2/liboscar.so_bak
sudo cp liboscar.so /usr/lib/purple-2/liboscar.so 

Das einfachste ist aber zweifellos, lediglich wenige Tage abzuwarten. Da Pidgin in den Paketquellen liegt und die Entwickler nach solchen Protokolländerungen von ICQ fieberhaft an Aktualisierungen arbeiten, werden diese bald geliefert, und man hat sich einiges an Zeit und Ärger gespart.

Meldung "Warte auf Netzwerkverbindung"

Dieser Fehler tritt gelegentlich im Zusammenhang mit Mobilfunkverbindungen (UMTS oder GPRS) auf (Problem mit dem Netzwerkmanager ab Ubuntu 9.10?). Die Buddy-Liste wird dann nicht geladen. Ergänzt man den Programmaufruf pidgin um den Parameter -f, wird diese Meldung unterdrückt. Pidgin wartet dann nicht auf eine Antwort des Netzwerkmanagers und lädt die Buddy-Liste.

Captcha-Eingabe schlägt fehl (QQ Version 2010)

Trotz wiederholter korrekter Eingabe des Captcha schlägt die Anmeldung fehl. Dies liegt an dem neuen Protokoll QQ2010, das von Purple noch nicht unterstützt wird. Eine Lösung ist die Installation der Bibliothek libqq-pidgin via PPA.

Adresszeile zum Hinzufügen des PPAs:

  • ppa:lainme/libqq

Hinweis!

Zusätzliche Fremdquellen können das System gefährden.


Ein PPA unterstützt nicht zwangsläufig alle Ubuntu-Versionen. Weitere Informationen sind der Wiki/Vorlagen/PPA/ppa.png PPA-Beschreibung des Eigentümers/Teams lainme zu entnehmen.

Damit Pakete aus dem PPA genutzt werden können, müssen die Paketquellen neu eingelesen werden.

Nach dem Aktualisieren der Paketquellen installiert man das folgende Paket:

  • libqq-pidgin (ppa)

Wiki/Vorlagen/Installbutton/button.png mit apturl

Paketliste zum Kopieren:

sudo apt-get install libqq-pidgin 

sudo aptitude install libqq-pidgin 

Nach einem Neustart von Pidgin lässt sich QQ nun wieder nutzen.

Fehler beim Verbinden zum Facebook-Chat

Tritt folgende Fehlermeldung auf, kann es nötig sein, in Facebooks Einstellungen "Anwendungen erlauben" zu aktivieren.

XXXX.XXXX@chat.facebook.com/Pidgin abgemeldet
Undefinierte Bedingung

Diese Revision wurde am 23. April 2014 20:48 von ubot erstellt.
Die folgenden Schlagworte wurden dem Artikel zugewiesen: Kommunikation, Internet, jabber, icq, irc, msn, Instant Messenger, Spiele