ubuntuusers.de

Tipps

Dieser Artikel wurde für die folgenden Ubuntu-Versionen getestet:


Du möchtest den Artikel für eine weitere Ubuntu-Version testen? Mitarbeit im Wiki ist immer willkommen! Dazu sind die Hinweise zum Testen von Artikeln zu beachten.

Thunderbird/TB-logo-2018.png In diesem Artikel werden Tipps und Tricks zu Thunderbird zusammengefasst, die zu kurz für einen eigenen Artikel sind oder noch nicht an anderer Stelle Erwähnung finden.

E-Mails verschlüsseln

Um E-Mails zu verschlüsseln, haben sich zwei Varianten etabliert: zum einen das "Web of Trust" mit GnuPG als Basis, zum anderen der Einsatz von S/MIME-Zertifikaten. Für GnuPG gibt es mit Enigmail eine Erweiterung, die für das Signieren und/oder Verschlüsseln eine grafische Oberfläche bietet. Details sind im Artikel Thunderbird/Enigmail zu finden.

Verbindungen zum Mailserver verschlüsseln

Der sicherste Weg, E-Mails zu versenden, ist der verschlüsselte Transport zwischen Thunderbird (oder einem anderen E-Mail Client) und dem E-Mail-Provider, da sensible Anmelde-Daten im Klartext übertragen werden. Diese Fähigkeit ist allerdings vom jeweiligen E-Mail-Provider abhängig – nicht alle bieten einen verschlüsselten Zugriff an. Informationen darüber und welche Ports verwendet werden müssen, hält der Anbieter bereit.

Kriterien zur Auswahl eines passenden Anbieters sind:

  • Verschlüsselung über POP3/SMTP/IMAP

  • Verschlüsselung bei Übertragung des Kennwortes

Der Artikel Konfiguration des Mozilla Thunderbird mit SSL Verschlüsselung 🇩🇪 (archivierte Version von 2015) der Universität Bochum zeigt, wie das aussehen kann.

Einrichten

Für einen Account, bei dem die Mails via POP3 oder IMAP abgerufen werden, wählt man in unter EinstellungenKonten-EinstellungenServer-Einstellungen (falls vom Anbieter unterstützt) beim Punkt Verbindungssicherheit am besten "SSL/TLS" und beim Punkt Authentifizierungsmethode "Passwort, normal" aus.

Für das Senden via SMTP wählt man in den Konten-Einstellungen unter Postausgangs-Server (SMTP) den eingetragenen Server, öffnet mit einem linke Maustaste-Klick auf "Bearbeiten" die Einstellungen und aktiviert dort ebenfalls "SSL/TLS" und "Passwort, normal".

Sobald dies schon mal funktioniert, ist es mit der nächsthöheren Stufe kombinierbar:

Umleiten statt weiterleiten

In manchen Fällen müssen E-Mails zentral verteilt und an andere Empfänger weitergeschickt werden. Nutzt man dazu die klassische Weiterleitung, steht man vor dem Problem, dass beim Antworten nicht der Original-Absender, sondern der Weiterleiter als Empfänger eingesetzt wird. Hier wird also eine Umleitung und keine Weiterleitung benötigt. Das Add-On mailredirect 🇬🇧 rüstet eine entsprechende Funktion nach.

Benachrichtigungen, Popups und Tray-Icons

Sich über neu eingegangene Emails benachrichtigen zu lassen oder Thunderbird im Benachrichtigungsfeld als Tray-Icon anzuzeigen und auch dorthin zu minimieren, kann auf mehreren Wegen erreicht werden. Hier sollen nun einige Möglichkeiten vorgestellt werden.

Unabhängig von Thunderbird

Die folgenden Hilfsprogramme, sogenannte Mail Checker, zeigen Benachrichtigungen unabhängig von Thunderbird an. Dafür müssen jedoch für jeden E-Mail-Account und -Ordner sämtliche Zugangsdaten angegeben werden.

  • mail-notification

  • gnubiff (universe) - GNOME-Panel-Applet

  • xfce4-mailwatch-plugin (universe) - Xfce-Panel-Applet

Größtenteils für alle Versionen gültig

kdocker

kdocker 🇬🇧 funktioniert unter KDE besser als Firetray (keine Ränder, die nicht neu gezeichnet werden. Diese Fehler sind im Jan.2014 behoben.) und die Mail-Benachrichtigung erscheint trotzdem (wird durch New Mail Icon unterdrückt). Dazu muss das Paket

  • kdocker (universe)

Paketliste zum Kopieren:

sudo apt-get install kdocker 

Oder mit apturl installieren, Link: apt://kdocker

installiert werden. Zum praktischen Einsatz kann folgendes Shellscript verwendet werden:

1
2
3
4
#/bin/sh
/usr/bin/thunderbird & sleep 30 # Warten bis Thunderbird gestartet ist
winid=``xwininfo -root -children|grep '\-\ Thunderbird'|awk '{print $1}'``
kdocker -w $winid -i ~/icons/ff-tb/thunderbird-22.png &

Adressbuch mit Google Maps verknüpfen

Im Thunderbird Adressbuch kann man sich die jeweils gespeicherten Adressen mit dem Button "Karte anzeigen" per Mausklick im Browser auf einer Karte anzeigen lassen. Diese Funktion lässt sich konfigurieren, sodass auch andere Karten als in der Voreinstellung verwendet werden können. Qualitativ gutes Kartenmaterial mit schneller Darstellung liefert Google Maps 🇩🇪 . Eine Verknüpfung mit Google-Maps lässt sich folgendermaßen herstellen:

  1. In der Thunderbird-Software wird der Menüpunkt "Bearbeiten → Einstellungen → Erweitert → Allgemein" ausgewählt und dann der Button "Konfiguration bearbeiten..." angeklickt.

  2. Trägt man im Feld "Filter" den Ausdruck "mapit" ein, wird aus allen aufgelisteten Parametern, die sich ändern lassen, der für den Kartenzugriff relevante Parameter mail.addr_book.mapit_url.format ausgewählt.

  3. Ein Doppelklick auf die ausgewählte Zeile öffnet die Eingabemaske, mit der sich der Parameter verändern lässt.

  4. In die Eingabemaske wird folgender Ausdruck eingetragen und mit "OK" bestätigt:

     https://maps.google.de/maps?f=q&hl=de&ie=utf-8&t=m&q=@A1+@A2,+@ZI+@CI

Nach dieser Änderung sollte der Adresseintrag beim Kartenaufruf in Google Maps angezeigt werden. Falls nicht, sollte man kontrollieren, ob die Browser-Einstellungen in Thunderbird korrekt gesetzt sind: Thunderbird/Konfiguration

In der Abfrage bezeichnen die Größen "A1" und "A2" die Straße + Zusatz, "ZI" die Postleitzahl (ZIP Code) und "CI" den Ortsnamen (City) des Adresseintrags.

In ähnlicher Weise lassen sich natürlich auch Verknüpfungen zu anderen Karten im Internet, z.B. www.de.map24.com 🇩🇪, herstellen. Allerdings reicht es nicht aus, einfach die Web-Adresse auszutauschen, sondern es muss unbedingt auch die Syntax für den Kartenaufruf angepasst werden. Für openstreetmap 🇩🇪 lautet der Eintrag zum Beispiel:

https://nominatim.openstreetmap.org/search?q=@A1%2C%20@CI%20@ST%20@ZI%20@CO

Pflege der Mailbox

In Thunderbird gelöschte E-Mails werden nicht wirklich (physikalisch) gelöscht, sondern nur als gelöscht markiert und nicht mehr angezeigt. Daher ist es mit Hilfe der Erweiterung Recover Deleted Messages 🇩🇪 auch einfach möglich, gelöschte E-Mails wiederherzustellen.

Um gelöschte E-Mails endgültig aus der Mailbox zu entfernen, sollte zuerst aufgeräumt und anschließend der Papierkorb geleert werden. Nun kann man die Mailordner - insbesondere den Posteingang - in Thunderbird über das Kontextmenü (rechte Maustaste rechte Maustaste) "komprimieren". Wenn noch nie komprimiert wurde, kann dieser Vorgang etwas dauern. Anschließend sollte der Ordner ~/.thunderbird deutlich kleiner sein und Thunderbird - je nach Größe der ursprünglichen Mailbox - wieder zügiger reagieren. Siehe auch Warum werden die Dateien/Ordner in Thunderbirds Profil immer größer? 🇩🇪 im Thunderbird Wiki.

E-Mail-Archivierung im PDF-Format

Mit Hilfe des Add-ons ImportExportTools 🇬🇧 lässt sich in Zusammenarbeit mit dem Programm

  • htmldoc

Paketliste zum Kopieren:

sudo apt-get install htmldoc 

Oder mit apturl installieren, Link: apt://htmldoc

eine auch umfangreichere Archivierung und Auslagerung von E-Mails im PDF-Format realisieren. Das Add-on bietet zahlreiche Export- und Importmöglichkeiten wie z.B. die Formate EML und HTML (mit oder ohne Anhänge), Reintext, als Kalkulationstabelle (.csv), als Mbox-Datei und vieles mehr. Der hier beschriebenen Anwendungsfall macht sich die Exportfunktion als HTML-Datei zunutze.

Vorgehensweise:

  1. Markieren der zu exportierenden E-Mails in Thunderbird

  2. Nach einem Rechtsklick rechte Maustaste und der Auswahl von "Gewählte Nachrichten speichern → im HTML-Format" das Zielverzeichnis auswählen. Die markierten E-Mails werden als HTML-Dateien exportiert.

  3. Terminal im Zielordner öffnen und den Befehl:

htmldoc --webpage --charset iso-8859-1 -v -f ERGEBNIS.pdf *.html 

ausführen.

Die auf diese Weise erstellte Datei ERGEBNIS.pdf enthält alle zu sichernden E-Mails in fortlaufender Reihung inklusive der originalen Textformatierungen sowie einen praktischen Index.

Achtung!

Emails, welche in der Codierung UTF-8 statt ISO 8859-1 (westeuropäische und amerikanische Sprachen) vorliegen, werden von htmldoc in der Version 1.8.x nicht unterstützt, so dass es zu fehlerhafter Darstellung einzelner Sonderzeichen/-buchstaben kommen kann. Erst für htmldoc v.1.9.x ist eine grundlegende UTF-8-Unterstützung für "westliche" Sprachen vorgesehen.

Antwort-Header anpassen

Wenn man beim Antworten auf E-Mails die ursprüngliche Nachricht automatisch zitieren lässt, wird das Zitat standardmäßig mit den Worten "Am ... schrieb XY" eingeleitet. Die genauen Worte sind in den Variablen mailnews.reply_header_authorwroteondate, mailnews.reply_header_authorwrotesingle und mailnews.reply_header_ondateauthorwrote in about:config gespeichert ("Menü->Bearbeiten->Einstellungen->Erweitert->Konfiguration bearbeiten..."), die sich durch die Variable mailnews.reply_header_type auswählen lassen.

Beim Weiterleiten wird hingegen Header einer zitierter E-Mail im gewohnten Outlook- bzw. Lotus-Notes-Stil generiert. Warum es diesen Unterschied gibt, bleibt das Geheimnis der Thunderbird-Entwickler.

Diesen Antwort-Header kann man an den Outlook-Stil anpassen:

Von: Max Mustermann <max.muster@example.org>
An: Maxi Musterfrau <maximuuuuu@example.org>
Datum: Sonntag, 1. Dezember 2019, 13:38 MEZ
Betreff: Der Original-Betreff

Es gibt einige Add-ons, die solche Anpassungsmöglichkeiten anbieten, darunter auch ReplyWithHeader. Leider gibt es mit Thunderbird 68 wieder Änderungen am Add-on-System, sodass es zu erwarten ist, dass viele Add-ons zunächst wieder nicht für Thunderbird 68 verfügbar sein werden. Es liegt also erneut an den Autoren der Add-ons, wie lange man auf kompatible Versionen der Add-ons warten muss und ob es diese überhaupt wieder geben wird.

Zum Glück hat der Autor des ReplyWithHeader sein Add-on für Thunderbird 68 schon überarbeitet. Die kompatible Version (2.2.1-beta, Stand Dezember 2019) kann man noch nicht vom Repository direkt installieren, sondern von seiner Homepage herunterladen. Dort gibt es auch eine Installationsanleitung:

 1. Download and save the .xpi file to your hard disk
 2. In Mozilla Thunderbird, open Add-ons from the Tools menu
 3. From the options button next to the add-on search field, select Install Add-on From File... and locate the downloaded add-on from your hard disk
 4. Now RWH Add-on is ready to use!

Diese Revision wurde am 4. Mai 2021 19:46 von noisefloor erstellt.
Die folgenden Schlagworte wurden dem Artikel zugewiesen: Thunderbird, Internet