ubuntuusers.de

Step

Dieser Artikel wurde für die folgenden Ubuntu-Versionen getestet:

Zum Verständnis dieses Artikels sind folgende Seiten hilfreich:

step-logo.png Step 🇬🇧 ist eine interaktive Physiksimulationsanwendung von KDE und Teil des KDE-Bildungsprojekts 🇬🇧. Im Jahr 2007 wurde die Entwicklung der Anwendung begonnen und erstmals zusammen mit KDE 4.1 veröffentlicht. Es stehen eine Vielzahl von Körpern, Kräften, Motoren, Messgeräte, Federn etc. zur Verfügung, deren Eigenschaften individuell geändert werden können. Nachdem man eine Versuchsanordnung aufgebaut hat, kann man sich simulieren lassen, wie sich das Experiment nach den Gesetzen der Physik verhält.

Step verfügt u.a. über die folgenden Funktionen:

step.png
Step

Installation

Step kann über die Ubuntu-Paketquellen installiert[1] werden:

  • step

Paketliste zum Kopieren:

sudo apt-get install step 

Oder mit apturl installieren, Link: apt://step

Nach der Installation kann Step über das Menü "Lernprogramme → Verschiedenes → Step (Interaktiver Physiksimulator)" gestartet werden.

Bedienung

Die in "Palette" zur Verfügung stehenden Objekte lassen sich ganz einfach auf der Experimentierfläche platzieren. Hierzu klickt man linke Maustaste das gewünschte Objekt an, anschließend klickt man linke Maustaste auf der Experimentierfläche auf die gewünschte Stelle, an der das Objekt erscheinen soll. Nachdem man ein Objekt eingefügt hat, kann man bspw. auf den Körper eine Kraft einwirken lassen, indem man aus der "Palette" eine Kraft markiert und anschließend auf das Objekt klickt. Auf die gleiche Weise kann man beispielsweise auch die Position des Objektes fixieren, indem man den "Anker" auf ein Objekt anwendet. Zusätzlich kann man Diagramme, Messgeräte etc. auf der Experimentierfläche einfügen und mit einem Objekt verknüpfen, sodass während der Simulation vorher ausgewählte Messwerte dargestellt werden.

Hat man alle gewünschten Objekte auf der Experimentierfläche platziert, kann man, nachdem man eines markiert hat, dieses weiter anpassen. Im Bereich "Eigenschaften" können die angezeigten Parameter beliebig geändert werden. Hierzu genügt linke Maustaste auf die Eigenschaft, danach kann man den Wert ändern. Anschließend kann man durch linke Maustaste auf die Schaltfläche "Simulation starten" in der Werkzeugleiste schauen, wie sich der Versuchsaufbau verhält.

Tutorials und Beispiele

Für einen leichteren Einstieg enthält Step einige Beispielexperimente und Tutorials. Die Beispiele können über "Datei → Beispiele → Beispieldatei öffnen" aufgerufen werden.

Step enthält fünf Tutorials. Die Tutorial-Experimente können über "Datei → Anleitung öffnen" geöffnet werden. Zu diesen Experimenten gibt es im Handbuch von Step jeweils eine kurze Erklärung zur Verwendung der im Experiment integrierten Objekte. Das Handbuch ist unter "Hilfe → Handbuch zu Step" zu finden, die Tutorials befinden sich im Abschnitt "Einführung zu Step: Die Anleitungen".

Zusätzlich bietet Step die Möglichkeit, Experimente der Allgemeinheit zur Verfügung zu stellen. Über den Menüeintrag "Datei → Beispiele → Neue Experimente herunterladen" werden die von anderen Benutzern veröffentlichten Experimente aufgelistet. Durch linke Maustaste auf "Installieren" wird das ausgewählte Experiment heruntergeladen. Anschließend können über "Datei → Beispiele → Heruntergeladene Beispieldatei öffnen" die installierten Experimente geöffnet werden. Möchte man ein gerade geöffnetes Experiment der Öffentlichkeit zur Verfügung stellen, wählt man "Datei → Beispiele → Aktuelles Experiment bereitstellen".

Einstellungen

Die Konfigurationsmöglichkeiten von Step sind sehr überschaubar gehalten. Über den Menüeintrag "Simulation → Geschwindigkeit" kann man einstellen, wie schnell das Experiment simuliert werden soll. Mittels "Einstellungen → Felder" kann angepasst werden welche Bereiche ("Palette", "Eigenschaften", etc.) im Fenster von Step angezeigt werden sollen. Zusätzlich bietet "Einstellungen → Step einrichten" weitere Optionen, wie bspw. ein/ausblenden des Achsenkreuz oder die Anzeigegenauigkeit.

Diese Revision wurde am 4. Mai 2019 16:49 von Shakesbier erstellt.
Die folgenden Schlagworte wurden dem Artikel zugewiesen: Physik, Bildung, KDE, Edubuntu