ubuntuusers.de

mtPaint

Dieser Artikel wurde für die folgenden Ubuntu-Versionen getestet:

Zum Verständnis dieses Artikels sind folgende Seiten hilfreich:

./mtpaint.png mtPaint 🇬🇧 ist ein Bildbearbeitungsprogramm, welches auf GTK+ setzt und sich auch für ältere Hardware eignet. Das Programm kann sowohl mit indizierten als auch mit RGB-Bildern (24-Bit Farbtiefe) umgehen und bringt eine große Anzahl Pinsel, Masken und ein ansehnliches Sortiment an Grundmustern mit. Es ist vom Grundkonzept her ein Programm für pixelbasierte Bilder und eignet sich daher besonders für Pixel-Art.

Mtpaint beherrscht den Umgang mit Ebenen sowie Farbkanälen und eignet sich damit auch zur Bildbearbeitung. Es kann mit den Formaten JPEG, PNG, GIF, TIFF, BMP, XPM und XBM umgehen. Die Oberfläche ist größtenteils auf Deutsch, jedoch durchsetzt mit nicht übersetzten englischen Menüeinträgen und Funktionsbezeichnungen.

Eine Auswahl der wichtigsten Programmfunktionen:

main.png
mtPaint

Installation

Das Programm ist unter Lubuntu bereits vorinstalliert und übernimmt dort die Rolle des Standard-Zeichenprogramms. Zur Installation [1] wird bei anderen Ubuntu-Varianten folgendes Paket benötigt:

  • mtpaint (universe)

Paketliste zum Kopieren:

sudo apt-get install mtpaint 

Oder mit apturl installieren, Link: apt://mtpaint

Zum Erstellen von Animationen (animierte GIF-Dateien) ist zusätzlich das Paket gifsicle notwendig:

  • gifsicle (universe)

Paketliste zum Kopieren:

sudo apt-get install gifsicle 

Oder mit apturl installieren, Link: apt://gifsicle

Verwendung

Unter den verschiedenen Desktopoberflächen wird im Rahmen der Installation automatisch ein Startersymbol für mtPaint erzeugt, welches über die Suchfunktion oder über den Unterpunkt "Grafik → mtPaint" im jeweiligen Anwendungsmenü zugänglich ist.

Das Programm präsentiert sich in einer zunächst unscheinbar wirkenden, aufgeräumten und übersichtlichen Oberfläche, welche die überraschende Vielzahl an vorhandenen Programmfunktionen auf den ersten Blick verbirgt.

  • Im oberen Bereich des Programmfensters befindet sich die Menüleiste, welche Zugang zu den komplexeren Funktionen gewährt.

  • Darunter ist die Hauptleiste mit den wichtigsten Datei- und Ansichtsfunktionen zu sehen.

  • An dritter Stelle ist die Werkzeugleiste mit den Symbolen für die Basiswerkzeuge eingeblendet.

  • Links neben der Leinwand befindet sich die senkrecht angeordnete Farbpalette, welche im oberen Teil in einem gesonderten kleinen Feld Überblick über Vordergrund- und Hintergrundfarbe, die Pinselform sowie ein eventuelles Farbmuster bietet.

  • Die horizontal unter der Leinwand angeordnete Statusleiste zeigt die wichtigsten Bildinformationen an.

  • Separat erscheint bei Programmstart ein eigenes freischwebendes Fenster, welches Einstellungen anbietet.

Hinweis:

Die Sichtbarkeit der Leisten und Zusatzfenster lässt sich einzeln über das Menü "Ansicht" steuern. In diesem Menü stehen auch noch weitere hilfreiche Sonderfenster zum Einblenden zur Verfügung.

Die Bedienung stützt sich zwar prinzipiell auf intuitive Elemente (Werkzeugschaltflächen etc.), ist jedoch aufgrund reichhaltig gefüllter Programm-Menüs und unter der Oberfläche liegender, wenig intuitiver Funktionsabläufe für den Einsteiger zunächst schwer durchschaubar und erfordert eine gewisse Einarbeitungszeit. Eine Fülle an vorhandenen Maus- und Tastenkürzeln sollen den Benutzer bei der Verwendung unterstützen; diese können über das Menü "Hilfe > Über" oder mittels der Taste F1 eingesehen werden.

Zur noch tiefergehenden Einarbeitung in die Bedienung des Programms existiert ein umfangreiches englisches Handbuch 🇬🇧.

Funktionsübersicht

Allgemeine Grund- und Dateifunktionen

Übersicht über die allgemeinen Grund- und Dateifunktionen
Symbol Funktion Tastaturkürzel Erreichbarkeit über Menü Erläuterung
./xpm_new.png Neues Bild erstellen Strg + N "Datei → Neu"
./xpm_open.png Öffnen/Bild laden Strg + O "Datei → Öffnen"
./xpm_save.png Bild speichern Strg + S "Datei → Speichern" Das geöffnete Bild mit den angewendeten Bearbeitungen überschreiben.
Bild unter neuem Namen speichern "Datei → Speichern als..." Das geöffnete Bild unter neuem Namen speichern.
./xpm_undo.png Letzte Aktion rückgängig machen Strg + Z "Bearbeiten → Rückgängig" Letzte Aktion zurücknehmen; bis zu 1000 Schritte; Anzahl der Schritte im Menü "Bild → Einstellungen → Allgemein" (alternativ Strg + P ) festlegen.
./xpm_redo.png Letzte Aktion wiederherstellen Strg + R "Bearbeiten → Wiederherstellen" Letzte Aktion wiederherstellen.
Programmeinstellungen Strg + P "Bild → Einstellungen"
Hilfe F1 "Hilfe → Über"
Programm beenden Strg + Q "Datei → Beenden"

Weitere grundlegende Dateifunktionen sind über "Datei → Actions" erreichbar:

  • EXIF-Daten in Texteditor betrachten

  • Dateisystem-Daten im Terminal-Emulator betrachten

  • Bild in GIMP zum Bearbeiten öffnen

  • mit GQview betrachten

  • Bild drucken

  • Bild per Email versenden

  • Bild in Firefox-Internetbrowser anzeigen

  • Bild in OpenOffice/LibreOffice öffnen

  • Zwischenablage bearbeiten

  • Zeitverzögertes Bildschirmfoto

  • Bildinformationen anzeigen

Die vorgegebenen sowie noch etliche weitere "Aktionen", wie z.B. Konvertieren, Vorschaubilder erstellen, Umbenennen, Festlegen von Email- und Anzeigeprogrammen und mehr, können über "Datei → Aktionen → konfigurieren" umfangreich konfiguriert werden.

Ansichtsoptionen

Die Optionen zur Sichtbarkeit von Programmelementen sowie zur Darstellung des Bildes innerhalb des Programms lassen sich im Wesentlichen über das Menü "Ansicht" einstellen.

Übersicht über die Ansichtsoptionen
Funktion Tastaturkürzel Erreichbarkeit über Menü Erläuterung
Hauptleiste zeigen F5 "Ansicht → Hauptleiste zeigen"
Werkzeugleiste zeigen F6 "Ansicht → Werkzeugleiste zeigen"
Einstellungsleiste zeigen F7 "Ansicht → Einstellungsleiste zeigen"
Dock anzeigen F12 "Ansicht → Show Dock" Frei schwebende Einstellungsfenster als rechts integriertes Dock anzeigen (erst ab Raring)
Palette zeigen F8 "Ansicht → Palette zeigen"
Statusleiste mit Bildinformationen anzeigen "Ansicht → Statusleiste anzeigen"
Bildansicht umschalten Pos1 "Ansicht → Bildansicht umschalten" Verbergen aller Menüleisten und Werkzeuge.
Bild zentrieren "Ansicht → Bild zentrieren" Leinwand im Programmfenster zentriert anzeigen
Leinwand ein-/auszoomen + bzw. -
Voreingestellen Zoomwert anwählen (10-2000%) 1 bis 9
Zoomgitter zeigen "Ansicht → Zoomgitter zeigen" Ab Vergrößerungsgrad 800% ein Gitter zur leichteren Ansteuerung der Pixel anzeigen.
Zoomgitter konfigurieren "Ansicht → Configure Grid" Konfigurationsmöglichkeiten für Zoomgitter, wie Farbe und Tiling
Bild in verkleinerter Form abpausen (z.B. für Programmsymbolerstellung) "Ansicht → Tracing Image" Beispiel: Foto im Format 640x480 Pixel in 1/10 abpausen.
1. Fotovorlage laden
2. "Ansicht → Tracing Image"; Quelle: "Bild"; "Origin" (gewünschte Zieleinstellung in Pixel) = "64x48" oder "Relative Scale" (Skalierungsrelation) = "10"; "Display" abhaken → "OK"
3. "Datei → Neu" → Zielformat "64x48"
4. "Bild → Einstellungen" ( Strg + P ) → Reiter "Dateien"; "Transparenz-Index=0"
5. bei eingeschaltetem Zoomgitter nun ins Gitter zeichnen und Bild abkopieren.
Tipp: Verschieben der Vorlage mittels Strg +Wiki/Icons/pfeiltasten.png
Übersichtsfenster V "Ansicht → Ansichtsfenster"
Übersichtsfenster ein-/auszoomen + + bzw. + -
Horizontal teilen H "Ansicht → Horizontal Split" Programmfenster für Vorschau horizontal oder vertikal teilen
Ansichtsfenster fokussieren "Ansicht → Ansichtsfenster fokussieren"
Ausschnitt verschieben Ende "Ansicht → Ausschnitt verschieben" Bei nur ausschnittsweiser Darstellung des Bildes im Hauptfenster (z.B. bei hohem Zoomwert) lässt sich der Bildausschnitt in einem separaten kleinen Symbolfenster mithilfe der linke Maustaste-Maustaste leicht verschieben.
Tipp: Klick mit der rechte Maustaste-Maustaste auf das Symbolfenster schließt dieses.

Bildeinstellungen

Die Bildeinstellungen beziehen sich auf die technischen Attribute der Bilddatei/Leinwand und ihre Manipulation.

Übersicht über die Bildeinstellungen
Funktion Tastaturkürzel Erreichbarkeit über Menü
Bild skalieren Bild ↑ "Bild → Zeichenfläche anpassen"
Leinwandgröße ändern Bild ↓ "Bild → Größe der Zeichenfläche ändern"
Bildinformationen Strg + I "Bild → Information"
Scheren (in vier festgelegten Relationen) "Effekte → Isometrische Transformation"
Frei scheren (mit verschiedenen Einstellmöglichkeiten) "Bild → Skew"
Vertikal spiegeln "Bild → Vertikal spiegeln"
Horizontal spiegeln Strg + M "Bild → Horizontal spiegeln"
Im Uhrzeigersinn drehen (90°) "Bild → Im UZS drehen"
Gegen Uhrzeigersinn drehen (90°) "Bild → Gegen UZS drehen"
Frei drehen "Bild → Frei drehen"
Bild auf zuvor getätigte Auswahl zuschneiden + Strg + X oder Entf "Bild → Zuschneiden"

Mal- und Zeichenwerkzeuge

Teilweise bietet das Programm zu den Mal- und Zeichenwerkzeugen, welche auch bereits über die Werkzeugschaltflächen direkt erreichbar sind, praktische Tastenkürzel.

Übersicht über die Mal- und Zeichenwerkzeuge
Symbol Funktion Tastaturkürzel Erreichbarkeit über Menü Erläuterung
Pinselspitze wählen F3 "Bearbeiten → Pinsel wählen"
./xpm_paint.png Zum Malwerkzeug wechseln F4 In VG-Farbe mit der ausgewählten Pinselspitze malen.
Ausgewähltes Malwerkzeug anwenden linke Maustaste
Ausgewählte Malaktion beenden rechte Maustaste
Mauszeiger/Werkzeug pixelweise verschieben (Malmodus) ./arrow_keys.png
Mauszeiger/Werkzeug um vordefinierten Wert verschieben + ./arrow_keys.png Mauszeiger/Werkzeug um x Pixel verschieben; x ist definiert in den Einstellungen (Menü "Bild → Einstellungen" oder alternativ Strg + P ; Reiter "Interface"; "Auswahl Nudge-Pixel")
./xpm_shuffle.png Mischen Das Mischtool würfelt je nach ausgewählter Pinselspitze in zufälliger Weise Bildpunkte durcheinander und erzeugt so pixelige Texturen.
./xpm_flood.png Füllen Einstellungsdialog durch Rechtsklick auf Symbol ./xpm_flood.png.
./xpm_line.png Gerade Linie 1. Pinselspitze wählen
2. Schaltfläche ./xpm_line.png drücken
3. Startpunkt mit linke Maustaste-Maustaste anklicken
4. Maus zum Zielpunkt bewegen
5. Zielpunkt der Linie dort mit Klick auf linke Maustaste-Maustaste festlegen
6. weitere Linienelemente können angehängt oder die Aktion durch Klick auf rechte Maustaste-Maustaste abgeschlossen werden.
Tipp: offene Pfeilspitze am Linienende zeichnen durch Taste A , geschlossene durch Taste S ; Anhängen weiterer Pfeilelemente möglich oder Abschluss mit Klick auf linke Maustaste-Maustaste und rechte Maustaste-Maustaste.
./xpm_smudge.png Verschmieren 1. Größe der Pinselspitze einstellen
2. Schaltfläche ./xpm_smudge.png drücken
3. bei gehaltener linke Maustaste-Maustaste Bildbereiche verschmieren. (Nur bei RGB-Bildern verfügbar)
./xpm_clone.png Klonen 1. Pinselspitze wählen
2. Schaltfläche ./xpm_clone.png drücken
3. rotes Feld über zu kopierende Bildstelle platzieren
4. Strg drücken und weißes Feld in Zielposition bringen
5. Strg loslassen
6. mit linke Maustaste-Maustaste Klonvorgang durchführen.
./xpm_grad_place.png Gradient Farbverlauf von VG-Farbe zu HG-Farbe erzeugen; umfangreicher Einstellungsdialog durch Rechtsklick auf Symbol ./xpm_grad_place.png.
1. Startpunkt mit linke Maustaste-Maustaste anklicken
2. Zielpunkt mit linke Maustaste-Maustaste anklicken.
Tipp: Löschen mit rechte Maustaste-Maustaste.
./xpm_ellipse2.png Ellipse in Auswahl zeichnen Strg + L "Auswahl → Ellipsenumriss"
./xpm_ellipse.png Gefüllte Ellipse in Auswahl zeichnen + Strg + L "Auswahl → Ellipse füllen"
./xpm_rect1.png Umrissauswahl "Auswahl → Umrissauswahl"
./xpm_rect2.png Auswahl füllen "Auswahl → Auswahl füllen"
./xpm_text.png Text einfügen Strg + T "Bearbeiten → Text einfügen" 1. Erstellt einen Text in VG-Farbe; Rotationswinkel einstellbar.
2. Einfügen des Textes erfolgt mittels rechte Maustaste-Maustaste.
Tipp: Löschen/Entfernen des "Textstempels" mit Taste Esc .

Auswahlwerkzeuge

Mithilfe der Auswahlwerkzeuge lassen sich großflächige Bildmanipulationen vornehmen.

Übersicht über die Auswahlfunktionen
Symbol Funktion Tastaturkürzel Erreichbarkeit über Menü Erläuterung
./xpm_select.png Auswahlwerkzeug anwählen F9 Auswahl erzeugen mit linke Maustaste-Maustaste, Auswahl löschen mit Esc oder rechte Maustaste-Maustaste.
./xpm_polygon.png Polygonauswahl 1. Auswahl erzeugen mit linke Maustaste-Maustaste
2. Auswahl komplettieren mit rechte Maustaste-Maustaste
Tipp: Auswahl löschen mit Esc .
Ganzes Bild auswählen Strg + A "Auswahl → Alles auswählen"
Nichts auswählen + Strg + A oder Esc "Auswahl → Nichts auswählen"
./xpm_copy.png Kopieren Strg + C "Bearbeiten → Kopieren" Auswahl in Zwischenablage kopieren
./xpm_cut.png Ausschneiden Strg + X "Bearbeiten → Ausschneiden" Auswahl in Zwischenablage ausschneiden und aktuelles VG-Farbe/Farbmuster in den ausgewählten Bereich malen.
Mittig einfügen Strg + V "Bearbeiten → Mittig einfügen" Zwischenablage in der Mitte des Bildes anzeigen; dort Einfügeaktion mit rechte Maustaste-Maustaste durchführen ("Stempeln")
./xpm_paste.png Einfügen Strg + K "Bearbeiten → Einfügen" Zwischenablage an den Ort einfügen, aus dem sie kopiert wurde; dort Einfügeaktion mit rechte Maustaste-Maustaste durchführen ("Stempeln")
Einfügeaktion duchführen rechte Maustaste Einfügeaktionen werden nicht direkt durchgeführt, sondern in Art einer "Stempelfunktion" mit Hilfe der rechte Maustaste-Maustaste; d.h. das einzufügende Element wird auf diese Art in die Leinwand übernommen, bleibt jedoch für weitere Aktionen freischwebend verfügbar und muss am Ende per Taste Esc oder durch Auswahl eines neuen Werkzeugs gelöscht werden.
Auswahl löschen Esc Freischwebende Auswahl löschen.
./xpm_lasso.png Lassoauswahl "Auswahl → Lassoauswahl" Kopiert einen zuvor ausgewählten Ausschnitt automatisch als separates Element heraus, welches sich dann verschieben und an anderer Stelle mittels rechte Maustaste-Maustaste wieder einfügen ("stempeln") lässt.[BR]Tipp: Auswahl eines anderen Werkzeugs oder Verwendung der Taste Esc löscht den Auswahlstempel.
Lassoauswahl ausschneiden "Auswahl → Lassoauswahl ausschneiden" Auswahl herauskopieren und als separates Element bereitstellen, dabei den Ursprungsbereich mit VG-Farbe füllen.
./xpm_ellipse2.png Ellipsenumriss in Auswahl zeichnen Strg + L "Auswahl → Ellipsenumriss" 1. Viereckige Auswahl tätigen
2. mittels linke Maustaste-Klick auf Symbol ./xpm_ellipse2.png eine Ellipse in Linienstärke der aktuellen Pinselgröße und in VG-Farbe in die Auswahl zeichnen
./xpm_ellipse.png Gefüllte Ellipse in Auswahl zeichnen + Strg + L "Auswahl → Ellipse füllen" 1. Viereckige Auswahl tätigen
2. mittels linke Maustaste-Klick auf Symbol ./xpm_ellipse.png eine ausgefüllte Ellipse in VG-Farbe in die Auswahl zeichnen.
./xpm_rect1.png Umrissauswahl "Auswahl → Umrissauswahl" 1. Viereckige Auswahl tätigen bzw. Polygonauswahl tätigen und mit rechte Maustaste-Klick abschließen
2. mittels linke Maustaste-Klick auf Symbol ./xpm_rect1.png die Auswahl in aktueller Pinselstärke mit VG-Farbe nachzeichnen.
./xpm_rect2.png Auswahl füllen "Auswahl → Auswahl füllen" 1. Viereckige Auswahl tätigen bzw. Polygonauswahl tätigen und mit rechte Maustaste-Klick abschließen
2. mittels linke Maustaste-Klick auf Symbol ./xpm_rect2.png die gesamte Auswahl mit VG-Farbe füllen.
./xpm_flip_vs.png Auswahl vertikal spiegeln "Auswahl → Vertikal spiegeln" Per Lasso-Werkzeug oder per "Kopieren und Einfügen" separierte Auswahl an waagerechter Spiegelachse vertikal spiegeln.
./xpm_flip_hs.png Auswahl horizontal spiegeln "Auswahl → Horizontal spiegeln" Per Lasso-Werkzeug oder per "Kopieren und Einfügen" separierte Auswahl an senkrechter Spiegelachse horizontal spiegeln.
./xpm_rotate_cs.png Auswahl im Uhrzeigersinn drehen "Auswahl → Im UZS drehen" Per Lasso-Werkzeug oder per "Kopieren und Einfügen" separierte Auswahl 90° im Uhrzeigersinn drehen.
./xpm_rotate_as.png Auswahl gegen Uhrzeigersinn drehen "Auswahl → Gegen UZS drehen" Per Lasso-Werkzeug oder per "Kopieren und Einfügen" separierte Auswahl 90° gegen Uhrzeigersinn drehen.
Horizontal verschmieren "Auswahl → Horizontal Ramp" Ausgewählten Bereich horizontal verschmieren
Vertikal verschmieren "Auswahl → Vertical Ramp" Ausgewählten Bereich vertikal verschmieren
Auswahl oder eingefügte Auswahl pixelweise verschieben (Auswahlmodus) ./arrow_keys.png
Auswahl um vordefinierten Wert verschieben +./arrow_keys.png Auswahl/eingefügte Auswahl um x Pixel verschieben; x ist definiert in den Einstellungen (Menü "Bild → Einstellungen" oder alternativ Strg + P ; Reiter "Interface"; "Auswahl Nudge-Pixel")
Größe der Auswahl verändern Strg +./arrow_keys.png
Auf Auswahl zuschneiden + Strg + X oder Entf "Bild → Zuschneiden"

Farben

Die Farbeinstellungen lassen sich vielfältig beeinflussen.

Übersicht über die Farbwerkzeuge
Symbol Funktion Tastaturkürzel Erreichbarkeit über Menü
Palettendatei (Dateiformat .gpl oder .txt) öffnen "Palette → Öffnen..."
Palette in GPL- oder TXT-Datei speichern "Palette → Speichern als..."
Standardpalette laden "Palette → Standards laden"
Alles maskieren "Palette → Alles maskieren"
Nichts maskieren "Palette → Nichts maskieren"
VG- und HG-Farbe vertauschen X "Palette → A und B vertauschen"
VG- und HG-Farbe ändern Strg + E "Palette → Farben A und B ändern"
Paletteneditor anzeigen Strg + W "Palette → Paletteneditor"
Palettegröße festlegen (2-256 Farben) "Palette → Palettegröße festlegen"
Doppelte Farben aus Palette entfernen "Palette → Doppelte Farben vereinen"
Im Bild nicht benutze Farben aus Palette entfernen "Palette → Nicht benutze Farben entfernen"
Palettefarben nach verschiedenen Kriterien sortieren "Palette → Farben sortieren"
./xpm_brcosa.png Farbe transformieren (Gamma, Helligkeit, Kontrast, Sättigung, Tonwert, Farbreduktion; für Bild und/oder Palette) Einfg oder + Strg + C "Effekte → Farbe transformieren"
In Graustufen umwandeln Strg + G "Effekte → Graustufen"
In Graustufen umwandeln (Gammakorrektur) Strg + G "Effekte → Graustufen (Gamma korrigiert)"
VG-Farbe zur nächsten oder vorherigen Palettenfarbe ändern [ bzw. ]
HG-Farbe zur nächsten oder vorherigen Palettenfarbe ändern + [ bzw. + ]
VG- und HG-Farbanteil einer (z.B. per Lassowerkzeug) separierten Auswahl transparent maskieren "Auswahl → Farbe maskieren A,B"
Farbmaske entfernen "Auswahl → Farbmaske entfernen A,B"
Alle Farben maskieren "Auswahl → Alle Farben maskieren"
Maske entfernen "Auswahl → Maske entfernen"
Farbmuster wählen F2 "Bearbeiten → Muster wählen"
Bild in RGB umwandeln "Bild → In RGB umwandeln"
Bildfarben in Palettenfarben umwandeln "Bild → In Indexiert umwandeln"

Effekte

Die Effektwerkzeuge sind unter dem Menü "Effekte" zugänglich.

Übersicht über die Effektwerkzeuge
Effekt Erklärung
"Kanten finden" Der Kantenerkennungsfilter generiert einen Effekt ähnlich wie eine Schwarzweiß-Strichzeichnung; acht verschiedene Algorithmen vorhanden.
"Difference of Gaussians" "Differenz der Mittelwerte" extrahiert Kanten durch zweimalige Anwendung eines Gaußschen Weichzeichenfilters und Berechnung der Differenz. Es entsteht der Effekt einer zarten Bleistiftzeichnung.
"Schärfen" Unscharfe Bilder schärfen.
"Unsharp Mask" "Unscharf maskieren" erhöht die Bildschärfe durch Kontrastverstärkung kleinerer Helligkeitsunterschiede.
"Aufweichen" Diskret Weichzeichnen.
"Gaussian Blur" "Gaußscher Weichzeichner" mit Einstellungsmöglichkeiten.
"Kuwahara-Nagao Blur" Künstlerischer Mosaikeffekt.
"Relief" Kanten werden so manipuliert, daß sie wie Erhöhungen und Vertiefungen wirken. So wird ein dreidimensionaler, reliefartiger Eindruck generiert.
"Dilate" "Erweitern" verstärkt dunkle Bereiche des Bildes.
"Erode" "Erodieren" verstärkt helle Bereiche des Bildes.
"Bakterien" Der "Bakterieneffekt" fügt farbig-pixelige Strukturen in RGB- oder indexierte Bilder ein.

Ebenen

Die Ebeneneinstellungen finden sich im Wesentlichen unter Menü "Ebenen".

Übersicht über die Ebenenwerkzeuge
Funktion Tastaturkürzel Erreichbarkeit Erklärung
Ebenenübersicht anzeigen L "Ansicht → Ebenenfenster" Einstellungsmöglichkeiten:
- Ebenen hinzufügen
- Ebenen duplizieren
- Deckkraft/Transparenz
- Ebenenanzeige einzeln oder zusammen im Hauptfenster
- Positionierung.
Tipp: Ebenen können im Vorschaufenster mithilfe der Maus verschoben werden.
Neue Ebene "Ebenen → New Layer" Neue Ebene erstellen
Ebeneninformationen speichern + Strg + S "Ebenen → Speichern" 1. Alle Ebenen separat als Einzelbilder speichern ("Datei → Speichern als...")
2. Ebeneninformationen speichern ("Ebenen → Speichern"); die Ebeneninformationen werden als Textdokument gespeichert.
Tipp: Die Ebeneninformationen müssen im selben Ordner gespeichert werden, in welchem auch die einzelnen Ebenenbilder abgelegt sind.
Ebeneninformationen unter neuem Namen speichern "Ebenen → Speichern als..." -siehe oben-
Ebenen als zusammengefügtes Bild speichern "Ebenen → Kompositbild speichern"
Ebenen zusammenfügen zu neuer Ebene "Ebenen → Composite to New Layer"
Ebene pixelweise verschieben Strg +./arrow_keys.png Ebene pixelweise im Übersichtsfenster ("Ansicht → Ansichtsfenster" oder V ) verschieben
Ebene um vordefinierten Wert verschieben + Strg +./arrow_keys.png Ebene um x Pixel im Übersichtsfenster verschieben; x ist definiert in den Einstellungen (Menü "Bild → Einstellungen" oder alternativ Strg + P ; Reiter "Interface"; "Auswahl Nudge-Pixel")
Alle Ebenen entfernen "Ebenen → Alle Ebenen entfernen"

Animationen

Der Erstellungsweg von Animationen erschließt sich nicht ganz intuitiv, daher seien hier kurze Beispielanleitungen vorgestellt.

Übersicht über die Animationswerkzeuge
Funktion Erreichbarkeit
Animiertes GIF speichern "Datei → Animiertes GIF speichern"
Animation einstellen "Ebenen → Animation einstellen"
Animationsvorschau "Ebenen → Animationsvorschau"
Keyframe setzen "Ebenen → Setze Keyframe"
Alle Keyframes entfernen "Ebenen → Entferne alle Keyframes"
Palettenverschieber "Palette → Palette Shifter"

Animiertes GIF erstellen (Beispiel 1)

Zur Erstellung einer animierten GIF-Datei müssen zunächst die Einzelbilder erstellt und abgespeichert werden. Aus diesen Einzelbildern wird dann am Ende die Animation generiert. Wichtig: alle Einzelbilder müssen in einem gemeinsamen Ordner liegen. Die Einzelbilder müssen in der Farbeinstellung "indexierte Palette" vorliegen, nicht als RGB-Bilder.

  1. Menü "Datei → Neu"; Wichtig: Farbeinstellung "indexierte Palette"

  2. Menü "Datei → Speichern unter..."; Auswahl des gewünschten Ordners und abspeichern unter dem Namen frame-0001.gif

  3. Erstellung aller weiteren Einzelbiler und abspeichern unter den Namen frame-0002.gif, frame-0003.gif usw.

  4. Generierung der animierten GIF-Datei über Menü "Datei → Animiertes GIF speichern". Auswahl des Ordners, welcher die Einzelbilder enthält; Einstellen der "Animations-Verzögerung" (in Hundertstel-Sekunden); Eintrag des gewünschten Dateinamens, z.B. final.gif.

Animation mit Ebenen erstellen (Beispiel 2)

Das Verwenden von Ebenen kann beim Erstellen von Animationen viel Zeit und Mühe sparen. Anstatt die Animation pixelweise zu erstellen ist es so möglich, vorgefertigte Ebenen zu verwenden und die Animation allein über die Positionierung derselben zu generieren.

  1. Erstellung der Hintergrundebene mittels Menü "Datei → Neu", Festlegung der allgemeinen Bildparameter. Abspeichern im gewünschten Zielordner ("Datei → Speichern als...").

  2. Anlegen der weiteren erforderlichen Ebenen über das Ebenenwerkzeug ("Ansicht → Ebenenfenster", alternativ L ); Ebenen einzeln graphisch gestalten und jeweils als Bilddateien in den Zielordner speichern (Unsichtbarmachen der jeweils anderen Ebenen durch Entfernen der Haken im Ebenenfenster, dann "Datei → Speichern als...").

  3. Allgemeine Ebeneninformationen im Zielorder speichern über Menü "Ebenen → Speichern als...".

  4. Ansichtsfenster einblenden (Menü "Ansicht → Ansichtsfenster" oder V

  5. Ebenen nach Wunsch für 1. Frame positionieren.

  6. Ebenenpositionen für 1. Frame speichern unter "Ebenen → Setze Keyframe"; dort "1" eingeben.

  7. Für alle weitern Frames: Ebenen jeweils neu positionieren und Keyframe setzen; im Keyframe-Werkzeug fortlaufend nummerieren.

  8. Animation erstellen über "Ebenen → Animation einstellen"; Die Einstellung "End-Frame" bestimmt die Gesamtanzahl der erzeugten Frames; die Verzögerung zwischen den Frames beim Abspielen wird in Hundertstel-Sekunden angegeben.

  9. Zum Abschluss linke Maustaste-Mausklick auf "Erzeuge Frames"

Animation mittels Palette-Shifter erstellen (Beispiel 3)

Diese Technik funktioniert nur bei auf indexierter Palette basierenden Bildern und beruht auf der Vertauschung von Palettenfarben.

Der Palettenverschieber ist erreichbar über Menü "Palette → Palette Shifter". Jede Zeile des Paletten-Shifters legt eine Farbvertauschung fest, indem sie die Start- und Endfarbe auf der Palette definiert. Es sind über die verschiedenen Zeilen mehrere Farbvertauschungen innerhalb eines Bildes möglich. In der letzten Spalte wird die Zeitverzögerung bei den Farbvertauschungen festgelegt.

Hinweis:

Über Menü "Bild → In Indexiert umwandeln" können auch RGB-Bilder mit einer indexierten Palette versehen und anschließend für die Erzeugung von Animationen per Palette Shifter herangezogen werden.

Aus der auf diese Weise testweise generierten Animation wird nun eine animierte GIF-Datei erstellt:

  1. Das erstellte und zuvor abgespeicherte Bild noch einmal neu laden, um die "Rückgängig"-Historie zu löschen.

  2. Im Palette Shifter noch einmal die gewünschten Werte eintragen; Schaltfläche "Play" zur Vorschau verwenden.

  3. Schaltfläche "Erzeuge Frames" verwenden, um die Frame zu generieren.

  4. Einen Frame zurück gehen durch "Bearbeiten → Rückgängig" oder Strg + Z .

  5. Einzellbilder exportieren durch Menü "Datei → Undo-Bilder exportieren" im gewünschten Zielordner; Dateiname: out; Dateiformat: GIF.

  6. Das erste Einzelbild aus diesem Ordner noch einmal neu laden über "Datei → Öffnen"

  7. Animierte GIF-Datei erstellen über "Datei → Animiertes GIF speichern"; hierbei geeigneten Dateinamen und Zeitverzögerung auswählen.

Kanäle

Im Menü "Kanäle" stehen Werkzeuge zum Arbeiten an den Kanälen zur Verfügung.

ASCII-Art

Über Menü "Datei → ASCII-Art exportieren" lassen sich Bilder, welche maximal 16 Farben beinhalten, als sogenannte ASCII-Art in einer Textdatei speichern.

Konfiguration

Über "Bild → Einstellungen" oder Strg + P erreicht man das Einstellungsmenü. Dieses verteilt sich auf mehrere Reiter:

Konfiguration
ReiterKurzbeschreibung
"Allgemein"Grundeinstellungen: Undo, Gamma, Sprache ...
"Interface"Feineinstellungen an der Schnittstelle.
"Dateien"Grundeinstellungen zum Umgang mit Dateiformaten z.B. Qualitätsstufen einstellen.
"Paths"Grundeinstellungen wie Zwischenablage, verwendeter Browser und Handbuch anpassen.
"Statusleiste"Angezeigten Inhalt festlegen.
"Tablett"Grafiktabletts einrichten.

./Einstellungen.png

Handbuch

Das Handbuch kann entweder auf sourceforge.net 🇬🇧 oder lokal eingesehen werden. Für eine lokale Installation das aktuelle Handbuch 🇬🇧 ⮷ (ca.2,9 MiB) herunterladen, entpacken [2] und nach ~/Dokumente/ verschieben.

Im Reiter "Paths" den verwendeten Browser, z.B. firefox, und den Pfad zum englischsprachigen Handbuch hinterlegen: /home/BENUTZERNAME/Dokumente/mtpaint/docs/index.html.

Über "Hilfe → Dokumentation" kann nun das Handbuch aufgerufen werden.

Problembehebung

Manpage

Die Manual-Datei wird fälschlicherweise als /usr/share/man/man1/man1/mtpaint.1.gz statt als /usr/share/man/man1/mtpaint.1.gz gespeichert, wodurch der Terminalbefehl:

man mtpaint 

eine Fehlermeldung erzeugt (siehe auch 1189190). Mit dem Befehl:

sudo ln -s /usr/share/man/man1/man1/mtpaint.1.gz /usr/share/man/man1/mtpaint.1.gz 

wird der Fehler korrigiert. Die Übersetzung des Programms ist bislang noch unvollständig. Siehe auch Übersetzungsstatus 🇬🇧

Diese Revision wurde am 4. November 2018 21:02 von 2711christoph erstellt.
Die folgenden Schlagworte wurden dem Artikel zugewiesen: Bildbearbeitung, Grafiktablett, Screenshot, Grafik, LXDE, Xfce, GNOME