ubuntuusers.de

Die Wartung am E-Mail Dienst von Ubuntuusers dauert leider noch an.

FreePlane

Dieser Artikel wurde für die folgenden Ubuntu-Versionen getestet:


Du möchtest den Artikel für eine weitere Ubuntu-Version testen? Mitarbeit im Wiki ist immer willkommen! Dazu sind die Hinweise zum Testen von Artikeln zu beachten.

Zum Verständnis dieses Artikels sind folgende Seiten hilfreich:

FP10.png

Freeplane 🇬🇧 ist ein Open Source-Programm unter GNU General Public Licence (GPL) und dient zum Erstellen von individuell gestaltbaren Mindmaps. Hervorgegangen ist es als Fork aus FreeMind 🇬🇧. Mit FreeMind erzeugte Maps lassen sich auch mit Freeplane öffnen, umgekehrt nur im Einzelfall.

Freeplane nutzt Java, d.h. es ist auf jedem Betriebssystem, das Java installiert hat, lauffähig, auch lokal von einem USB-Laufwerk aus.

Installation

FPFkt.jpg Man kann Freeplane aus den Paketquellen oder als snap installieren. Die Version als snap ist neuer und hat den größeren Funktionsumfang.

aus den Paketquellen

Das Programm kann über das folgende Paket installiert werden:

  • freeplane (universe)

Befehl zum Installieren der Pakete:

sudo apt-get install freeplane 

Oder mit apturl installieren, Link: apt://freeplane

als snap

Das Programm lässt sich als snap wie folgt installieren:

sudo snap install freeplane-mindmapping 

Verwendung

FPovw.jpg Nach der Installation ist das Programm im Startmenü zu finden - hier am Beispiel von Xubuntu/Xfce erläutert im Whisker Menü - im Abschnitt Büro. Natürlich lässt sich Freeplane auch per Programmstarter starten, zum Beispiel aus der Xfce Taskleiste heraus. Die Einrichtung eines Starters hierfür ist im Xfce Panel beschrieben.

Die Bedienung von Freeplane ist weitgehend intuitiv, vergleichbar der anderer Mindmap-Programme und ermöglicht die Nutzung von Maus und Tastatur. Es lassen sich neben den gängigen Tastaturkür-Kürzeln (Drag & Drop, Copy & Paste, etc.) auch selbstdefinierte nutzen. Das Hilfe-Menü enthält u.a. ein Tutorial und die Dokumentation in Mindmap-Form.

Konfiguration

Pmm.png

Aus der Menüleiste lässt sich unter Werkzeuge das bei der Installation angelegte Benutzerverzeichnis öffnen. Unter "Werkzeuge → Einstellungen..." lassen sich zahlreiche Personalisierungen durchführen. Sowohl die jeweilige Mindmap, als auch eine daraus auf Knopfdruck erzeugbare Tabelle (inklusive verwendeter Icons) ist durchsuchbar.

Jede Mindmap lässt sich in jedem Detailzustand (eingeklappte/ausgeklappte Zweige) speichern. Das Einfügen von Bildern und relativen oder absoluten Links ist problemlos möglich. Form, Farbe, Inhalt und Gestalt von Zweigen, Text und Hintergrund lässt sich separat, lokal und/oder global festlegen. Einstellungen lassen sich sichern und wiederherstellen.

Die von Freeplane erzeugten Dateien des Typs .mm sind xml-Dateien, die sich mit jedem Editor bearbeiten lassen, wenn z.B. eine systemweite Änderung der Dateistruktur erfolgen soll, die Links in den Mindmaps, die auf andere Maps verweisen, aber erhalten bleiben sollen (Bsp.: /home/BENUTZER/FreePlaneFiles soll geändert werden zu /home/BENUTZER/FP_MMs).

Upgrade

Bei einem VersionsUpgrade werden Einstellungen & TastaturKürzel von der alten nicht in die neue Version übernommen. Es lassen sich jedoch mitunter die (vorher gesicherten) Einstellungen & Tastaturkürzel der alten Version in die neue Version laden. Hier exemplarisch erläutert für das Upgrade von Version 1.8.0 auf die Version 1.9.4 (mit Xubuntu 20.04.2 LTS) :

  • Einstellungen lassen sich bei FreePlane bei gestartetem Programm unter dem Menü "Werkzeuge → Einstellungen..." speichern & laden ; nach einem Upgrade empfiehlt es sich, zuerst die unveränderte Datei der neuen Version zu sichern - der Speicherort wird nach Auswahl der Schaltfläche "Speichern" angezeigt. Der Dateityp ist "freeplaneoptions". Nach Laden der zu übernehmenden Einstellungen, sollten im Reiter "HTML" die Startbefehle für Standard-Browser für andere Betriebssysteme & Mac in der Form geändert werden, daß der Zusatz " {0}" gelöscht wird ("xdg-open {0}""xdg-open").

  • Tastaturkürzel lassen sich bei FreePlane bei gestartetem Programm unter dem Menü "Werkzeuge → TastaturKürzel → Einstellungen → Sammlung..." speichern & laden; nach einem Upgrade empfiehlt es sich, zuerst die unveränderte Datei der neuen Version zu sichern - Tastaturkürzel werden im Unterordner "accelerators" des Einstellungsordners gespeichert, der Dateityp ist "properties".

Icon-Historie

Während das Programm-Icon von FreeMind nicht verändert wurde, bekamen neue Freeplaneversionen mitunter neue Programm-Icons.

Programm-Icons
FreeMind Freeplane, ursprünglich Freeplane, ab ca. V1.6 Freeplane, ab ca. V1.9
FM.png FPHum.png FP.png FP10.png

Diese Revision wurde am 17. Februar 2022 19:43 von noisefloor erstellt.
Die folgenden Schlagworte wurden dem Artikel zugewiesen: Büro