Apache OpenOffice/Installation

Dieser Artikel wurde für die folgenden Ubuntu-Versionen getestet:

Zum Verständnis dieses Artikels sind folgende Seiten hilfreich:

  1. Installation von Programmen

  2. Archive entpacken

  3. Ein einzelnes Paket installieren

  4. Ein Terminal öffnen

  5. Einen Editor verwenden

Inhaltsverzeichnis
  1. Installation
  2. Verwendung
  3. Problembehebung
  4. Links

Apache_OpenOffice/OpenOffice4Logo.png Apache OpenOffice wurde bei Ubuntu durch LibreOffice ersetzt und ist nicht mehr in den offiziellen Paketquellen vorhanden. Sofern explizit OpenOffice gewünscht wird, muss die Installation daher manuell vorgenommen werden.

Installation

Man hat die Auswahl zwischen Apache OpenOffice 4.x (ab 2014) oder dem älteren OpenOffice.org 3.4.x (2012).

Herunterladen der Pakete

Zuerst muss man sich OpenOffice von der Projektseite herunterladen. Je nachdem, welche Version man bevorzugt, ist die benötigte Archivdatei über ein Auswahl Menü auf der Download Seite herunterzuladen:

Die für Ubuntu relevante Datei verwendet das folgende Namensschema:

Die ARCHITEKTUR ist entweder x86 für 32-bit- oder x86-64 für 64-bit-Systeme. Die ebenfalls angebotenen RPM-Pakete sind für Ubuntu ungeeignet.

Prüfsummen kontrollieren

Optional, aber empfehlenswert bei der Version 4.x ist die Kontrolle der Prüfsumme des Downloads mit md5sum oder sha256 (siehe Hashfunktionen). Die jeweils gültigen Prüfsummen sind über die oben genannte Downloadseite verfügbar.

Paketinstallation

Hinweis!

Fremdpakete können das System gefährden.

Hinweis:

Bevor OpenOffice installiert werden kann, muss vorher LibreOffice oder eine andere version von OpenOffice deinstalliert werden, falls vorhanden.

Deinstallation von LibreOffice:

sudo apt-get remove libreoffice* 

Deinstallation von OpenOffice:

sudo apt-get remove openoffice* 

Die Archivdatei muss zuerst entpackt werden [2]. Die enthaltenen .deb-Dateien werden dann manuell installiert [3]. Die benötigten Dateien befinden sich nach dem Entpacken im Ordner DEBS (bei der Version 4.0.1 z.B. in ~/Downloads/de/DEBS) sowie im Ordner DEBS/desktop-integration, zu dem man jeweils vorher mit dem Befehl cd wechseln muss. Um die Pakete in der richtigen Reihenfolge installieren zu können, empfiehlt sich eine Installation mittels des Befehls [4]:

sudo dpkg -i *.deb 

Und nochmal im Ordner DEBS/desktop-integration

cd desktop-integration
sudo dpkg -i *.deb 

Verwendung

Wenn das Programm fehlerfrei installiert wurde, lässt es sich bei Ubuntu-Varianten mit einem Anwendungsmenü über "Büro -> Apache OpenOffice" starten. Alternativ lässt sich OpenOffice auch über Alt + F2 und durch Eingabe eines der folgenden Befehle starten:

ooffice
# oder gleich OpenOffice Draw öffnen
ooffice -draw 

Für Writer, Calc, Impress und Base wird das Argument dementsprechend abgeändert.

Start beschleunigen

Um den Start von OpenOffice zu beschleunigen, kann es helfen, unter "Extras -> Optionen -> OpenOffice -> Arbeitsspeicher" den Wert "Verwenden für OpenOffice" auf 128 MiB zu setzen, die "Anzahl der Schritte" auf 25 zu reduzieren und den Wert von "Speicher pro Objekt" auf 8 MiB setzen. Damit das Scrollen von Texten schnell funktioniert "Extras -> Optionen -> OpenOffice -> Ansicht -> Antialiasing" abschalten. Eine besonders hohe Geschwindigkeits-Steigerung ist über "Ansicht -> Raster -> sichtbar" abzustellen, so sind die Raster-Punkte zwar nicht mehr sichtbar, aber das "Fangen" im Raster kann so trotzdem aktiv sein. Diese Werte optimieren nicht nur den Start, sondern ermöglichen auch flüssiges Arbeiten mit OpenOffice.

Java

In der Standard-Installation von Ubuntu ist keine Java-Laufzeitumgebung (JRE) enthalten. Um den vollen Funktionsumfang von OpenOffice nutzen zu können, kann dies nachgeholt werden. Wenn ein JRE installiert wurde, muss man dies nach der Installation unter "Extras -> Optionen -> Java" einbinden.

Problembehebung

Unterstreichen

Prinzipiell sollte man mit der Tastenkombination Strg + + U markierten Text unterstreichen können, aber es funktioniert unter Umständen nur mit Strg + U . Hintergrund: unter GNOME 2 ist die Tastenkombination Strg + + U für die Eingabe von Unicode-Zeichen vorgesehen. Abhilfe schafft in einem Editor [5] das Einfügen der Zeile

GTK_IM_MODULE=xim

in die versteckte Datei ~/.profile im eigenen Homeverzeichnis.

Xfce

Falls diese Vorgehensweise unter Xfce nicht funktioniert, kann man hier die Datei ~/.config/xfce4/xfconf/xfce-perchannel-xml/xsettings.xml editieren und die Zeile mit

<property name="IMModule" type="string" value=""/>

in

<property name="IMModule" type="string" value="xim"/>

ändern.

Zur Aktivierung – egal, unter welcher Desktop-Umgebung – einmal ab- und wieder neu anmelden.

Hintergrundfarbe für markierten Text

Es kann in bestimmten Konstellation dazu kommen, dass die Hintergrundfarbe für markierten (oder bei einer Suche gefundenen) Text in OpenOffice sehr schlecht zu erkennen ist. Die Ursache dafür ist, dass OpenOffice die Markierungsfarbe aus den Einstellungen des Desktop-Designs holt und sie dann mit einer recht hohen Transparenz darstellt. OpenOffice bot (zumindest bis Version 3.2) keine Optionen, um die Markierungsfarbe oder deren Transparenz einzustellen. Es verwendet unter GNOME 2 die Farbe, die man unter "System -> Einstellungen -> Erscheinungsbild -> Anpassen -> Farben -> Gewählte Einträge" findet. Ein daraus resultierende Problem ist, dass sich eine Änderung dieser Farbe auf viele Bereiche des Desktop-Themas auswirkt (z.B. auch auf die Farbe der Knöpfe), was nicht unbedingt wünschenswert ist.