ubuntuusers.de

Apache OpenOffice

./OpenOffice4Logo.png/ Apache OpenOffice 🇩🇪 (früher OpenOffice.org) war die umfangreichste Office-Suite im Open Source-Bereich und demnach wenig verwunderlich auch bis einschließlich Ubuntu 10.10 das Standard-Office in Ubuntu. Seit Ubuntu 11.04 kommt stattdessen die freie Weiterentwicklung LibreOffice zum Einsatz. Aufgrund der Komplexität der Suiten gibt es thematisch abgegrenzte Artikel zu den diversen Komponenten und Einsatzbereichen.

Allgemein

OpenOffice.org und LibreOffice sind aus StarOffice entstanden. StarOffice wurde seit 1985 als Office-Paket in Deutschland von der Firma Star Division entwickelt. 1999 kaufte Sun Microsystems Star Division und machte in der Folge den Quellcode des Office-Pakets öffentlich verfügbar. Seither arbeiteten sowohl Mitarbeiter von Sun als auch zahlreiche freie Programmierer an der Weiterentwicklung. Mit dem Verkauf von Sun an Oracle wurde die Weiterführung der kommerziellen Variante "StarOffice" eingestellt.

Nachdem sich inzwischen fast alle ehemaligen Entwickler ausschließlich der Entwicklung von LibreOffice widmen, hat Oracle die Weiterentwicklung eingestellt und den Quellcode der Apache Foundation 🇬🇧 übergeben. Inwieweit OpenOffice.org noch eine Bedeutung hat, wird die Zukunft zeigen.

OpenOffice.org und LibreOffice unterschieden sich ursprünglich kaum. Inzwischen gibt es in einigen Bereichen deutliche Unterschiede: Werden mit OpenOffice Calc erstellte Tabellen mit LibreOffice geöffnet, kann es z.B. passieren, dass etliche Zellen unlesbar sind (Quelle 🇩🇪). Das liegt daran, dass LibreOffice die Normen der Rechenoperationen in der Tabellenkalkulation strenger umsetzt. Als Lösung bleibt entweder die saubere Programmierung des Arbeitsblatts für LibreOffice oder die Installation von Apache OpenOffice.

OpenOffice.org

Möchte man die letzte verfügbare Version nutzen, so muss man diese manuell installieren (siehe unten). Updates und Sicherheitsaktualisierungen werden über das Ubuntu Repository nicht mehr zur Verfügung gestellt.

LibreOffice

LibreOffice ist ein auf OpenOffice.org basierendes freies Office-Paket, welches von einer internationalen Entwicklergemeinschaft erstellt wird. Das Projekt ist im September 2010 entstanden, als nach dem Verkauf von Sun an Oracle ein Teil der bisherigen Entwickler die Gelegenheit ergriffen hat, ein bereits in der Vergangenheit lange diskutiertes, aber nie umgesetztes firmenunabhängiges Entwicklungsportal zu gründen: die Document Foundation.

Da auch die Namensrechte an Openoffice Oracle gehören, ist ein Name gewählt worden, der die neue Situation verdeutlichen soll. Obwohl Oracle eingeladen wurde, mit an LibreOffice zu arbeiten, hat man sich dort entschieden, OpenOffice.org separat weiterzuentwickeln bzw. letztlich einzustellen.

Komponenten

Die Komponenten von OpenOffice.org - Writer, Calc, Impress usw. - sind in einem eigenen Artikel beschrieben: Office Komponenten

OpenDocument Format

OpenOffice.org ab Version 2.0 und StarOffice ab Version 8 verwenden das OpenDocument-Format als Standardformat, welches 2006 offiziell als ISO-Standard veröffentlicht wurde. Die Notwendigkeit für OpenDocument wird darin gesehen, ein einheitliches, kompatibles Dokumentenformat einzuführen, dessen Zukunft nicht von einzelnen Anbietern abhängt und auf lange Zeit gesichert ist, um auch in Zukunft noch uneingeschränkt auf die Daten zugreifen zu können. Außerdem soll durch den offenen Standard mehr Wettbewerb ermöglicht werden.

Achtung!

Es sollten niemals Word-Dokumente unbekannter oder nicht vertrauenswürdiger Herkunft mit OpenOffice.org geöffnet werden. Nähere Informationen befinden sich im Artikel Archiv/Datenmigration/Word.

Dokumenten-Konverter

Archiv/OpenOffice.org_und_StarOffice/Dokumenten-Konverter.png Möchte man mehrere Dateien mit einem Arbeitsschritt in ein OpenDocument-Format konvertieren, so bietet OpenOffice.org einen Dokumenten-Konverter an. Unter "Datei → Assistenten → Dokumenten-Konverter" lassen sich alle gewünschten Dokumente am Stück konvertieren.

Dann muss nur noch der Ordner gewählt werden, in dem das Programm nach den Ausgangsdokumenten sucht und es muss der Ordner eingestellt werden, in dem die neuen OpenDocument-Dokumente gespeichert werden sollen. Office-Vorlagen werden dabei auch gleich als OpenOffice.org-Vorlagen im entsprechenden Ordner gespeichert. Der Dokumenten-Konverter kann auch auf der Kommandozeile genutzt werden (siehe unoconv).

Versteckte Informationen

Immer, wenn ein Dokument an eine Person oder Firma geschickt wird, sollte man darauf achten, dass der Empfänger nicht unnötigerweise Informationen erhält, die unter Umständen privater Natur sind (Informationen zur verwendeten Version, ursprünglicher Autor, ursprüngliche Bezeichnung etc.). Zum Beispiel möchte man es vermeiden, dass ein Unternehmen Informationen erhält, an welche weiteren Firmen Bewerbungen gesendet wurden. Solche "versteckten" Information können gelöscht werden, wenn man im Reiter "Datei → Eigenschaften → Allgemein" die Benutzerdaten löscht. In den weiteren Reitern wie "Beschreibung", "Benutzer", "Internet" und "Statistik" können weitere eventuell private Informationen enthalten sein.

Unter "Extras → Optionen → OpenOffice.org → Sicherheit → Optionen" können Einstellungen zum Speichern persönlicher Informationen vorgenommen werden.

Zu beachten ist auch, dass diese "versteckten" Informationen auch bei einem Format-Export wie z.B. in PDF erhalten bleiben.

OpenOffice.org-spezifische Artikel

Problembehebung

Diese Revision wurde am 7. September 2019 23:53 von ubot erstellt.
Die folgenden Schlagworte wurden dem Artikel zugewiesen: Präsentation, Büro