ubuntuusers.de

Kompilieren

Archivierte Anleitung

Dieser Artikel wurde archiviert. Das bedeutet, dass er nicht mehr auf Richtigkeit überprüft oder anderweitig gepflegt wird. Der Inhalt wurde für keine aktuell unterstützte Ubuntu-Version getestet. Wenn du Gründe für eine Wiederherstellung siehst, melde dich bitte in der Diskussion zum Artikel. Bis dahin bleibt die Seite für weitere Änderungen gesperrt.


Anmerkung: Die Entwicklung von Postler wurde eingestellt. Ein alternatives Programm mit vergleichbarem Funktionsumfang ist Geary.

Postler ist ein junges Programm, das aktiv entwickelt wird. Neben den von den Entwicklern in einem PPA zur Verfügung gestellten Paketen gibt es die Möglichkeit, Postler selbst zu kompilieren.

Abhängikeiten zum Bauen

Neben dem Vala-Compiler werden einige Bibliotheken und weitere Werkzeuge benötigt und Lynx wird zusätzlich für die Konvertierung von html-Seiten zu Text empfohlen. Die entsprechenden Pakete können aus den Paketquellen installiert [1] werden.

  • valac

  • libunique-dev

  • libssl-dev

  • libdb4.7-dev

  • libcanberra-dev

  • libnotify-dev

  • libwebkit-dev

  • libwebkit-1.0-common

  • libindicate-dev

  • librsvg2-bin

  • build-essential

  • intltool

  • msmtp (universe)

  • lynx-cur

Paketliste zum Kopieren:

sudo apt-get install valac libunique-dev libssl-dev libdb4.7-dev libcanberra-dev libnotify-dev libwebkit-dev libwebkit-1.0-common libindicate-dev librsvg2-bin build-essential intltool msmtp lynx-cur 

Oder mit apturl installieren, Link: apt://valac,libunique-dev,libssl-dev,libdb4.7-dev,libcanberra-dev,libnotify-dev,libwebkit-dev,libwebkit-1.0-common,libindicate-dev,librsvg2-bin,build-essential,intltool,msmtp,lynx-cur

Quellcode

Der Quellcode kann aus dem Git-Repository [2] oder von Launchpad [3] bezogen werden:

git clone git://git.xfce.org/apps/postler 

oder

bzr branch lp:postler 

Kompilieren und Installieren

Zum Kompilieren [4] und Installieren liegt ein Waf build script bei. Die Installation erfolgt in das Verzeichnis /usr/local, wozu Root-Rechte [5] benötigt werden.

cd postler
./waf configure
./waf build
sudo ./waf install 

Deinstallation

Das manuell installierte Postler lässt sich analog zur Installation aus dem Quellverzeichnis deinstallieren:

sudo ./waf uninstall 

Diese Revision wurde am 1. Mai 2019 21:05 von Beforge erstellt.
Die folgenden Schlagworte wurden dem Artikel zugewiesen: Internet, Kommunikation, Büro