Archiv/Beamer

Archivierte Anleitung

Dieser Artikel wurde archiviert. Das bedeutet, dass er nicht mehr auf Richtigkeit überprüft oder anderweitig gepflegt wird. Der Inhalt wurde für keine aktuell unterstützte Ubuntu-Version getestet. Wenn du Gründe für eine Wiederherstellung siehst, melde dich bitte in der Diskussion zum Artikel. Bis dahin bleibt die Seite für weitere Änderungen gesperrt.

Zum Verständnis dieses Artikels sind folgende Seiten hilfreich:

  1. Installation von Programmen

  2. Bearbeiten von Paketquellen

  3. Ein Terminal öffnen

  4. Einen Editor öffnen

Inhaltsverzeichnis
  1. Framebuffer
    1. Installation benötigter Softwarepakete
    2. Voraussetzungen für die Aktivierung des ...
    3. Ermitteln der Auflösung und Test
    4. Dauerhaftes Aktivieren des Framebuffers
  2. Alternativen

Grundsätzlich sollte man beim Bearbeiten dieses Problems einen externen Bildschirm bereitstehen haben (wenn man keinen Beamer (dt.: "Datenprojektor") besitzt), mit dem man die Funktionsweise des Video-Ausgangs am Laptop testen kann. Durch Nutzung der auch in Windows gültigen Umschalttasten (je nach Laptop Fn + F5 oder Fn + F2 oder ...) kann dann der Anschluss getestet werden. Sollte dies nicht funktionieren, dann ist weiter wie in RandR beschrieben zu verfahren.

Ansonsten gibt es sicherlich verschiedene Möglichkeiten, den Beamer-Ausgang in geeigneter Weise zu aktivieren. Daher wird am Ende des Artikels auf alternative Lösungen verwiesen.

Grundsätzlich ist es möglich, den Beamer über eine im Abschnitt Alternativen angegebene Möglichkeit, zum Beispiel Dualview, Grafikkarten/ATI, Thinkpad ACPI, zu konfigurieren. Der Artikel bezieht sich allerdings auf die Framebuffer-Lösung. Damit sollte der Beamer, wenn alles andere versagt, in jedem Fall in Betrieb genommen werden können.

Framebuffer

Normalerweise probiert man nach einer Neuinstallation oder nach einem Upgrade an einem Laptop, ob der Beamer-Ausgang noch funktioniert. Immer, wenn dies nicht der Fall ist, hilft es die Grafik auf den Frame-Buffer um zu stellen. Das hat schon oft zu einer funktionierenden Beamer-Ausgabe geführt. Die Grundzüge beschreibt der Artikel Booten. Im einzelnen sind dabei mehrere Schritte nötig:

Installation benötigter Softwarepakete

Folgende Pakete müssen installiert [1] werden:

Paketliste zum Kopieren:

sudo apt-get install fbset  hwinfo 

Oder mit apturl die Pakete installieren. Link: ,hwinfo

Voraussetzungen für die Aktivierung des Framebuffers im Kernel

Standardmäßig wird der Framebuffer nicht mehr im Kernel aktiviert. Deshalb müssen die entsprechenden Voraussetzungen für die Aktivierung geschaffen werden. Das geschieht durch den entsprechenden Aufbau der Initramfs. Dazu ist folgendes nötig:

Man öffnet die Datei /etc/initramfs-tools/modules mit einem Texteditor [4] mit Root-Rechten und fügt folgende Zeilen ein

fbcon
vesafb
vga16fb

Danach öffnet man die Datei /etc/modprobe.d/blacklist-framebuffer mit einem Editor [4] mit Root-Rechten kommentiert dort die zwei folgenden Einträge aus, indem man ein Raute-Zeichen # davor setzt:

# blacklist vesafb
# blacklist vga16fb

Jetzt muss man die Init-Ramfs neu erstellen, indem man in einem Terminal [3] folgenden Befehl eingibt:

sudo update-initramfs -u 

Nach einem Neustart des Rechners ist das System bereit, um den Framebuffer zu aktivieren.

Ermitteln der Auflösung und Test

Jeder Bildschirm besitzt eine optimale Auflösung, die der Beschreibung des Geräts entnommen werden kann. Dieser Auflösung entspricht ein bestimmter VGA Wert, den man mit folgendem Befehl im Terminal [3] erfahren kann:

sudo hwinfo --framebuffer 

Dabei könnte die zum Beispiel folgende Ausgabe entstehen:

02: None 00.0: 11001 VESA Framebuffer
  [Created at bios.447]
  Unique ID: rdCR.IlFc5RFYuVB
  Hardware Class: framebuffer
  Model: "NVidia NV17 () Board"
  Vendor: "NVidia Corporation"
  Device: "NV17 () Board"
  SubVendor: "NVidia"
  SubDevice:
  Revision: "Chip Rev A2"
  Memory Size: 32 MB
  Memory Range: 0xdc000000-0xddffffff (rw)
  Mode 0x0300: 640x400 (+640), 8 bits
  Mode 0x0301: 640x480 (+640), 8 bits
  Mode 0x0303: 800x600 (+800), 8 bits
  Mode 0x0305: 1024x768 (+1024), 8 bits
  Mode 0x030e: 320x200 (+640), 16 bits
  Mode 0x030f: 320x200 (+1280), 24 bits
  Mode 0x0311: 640x480 (+1280), 16 bits
  Mode 0x0312: 640x480 (+2560), 24 bits
  Mode 0x0314: 800x600 (+1600), 16 bits
  Mode 0x0315: 800x600 (+3200), 24 bits
  Mode 0x0317: 1024x768 (+2048), 16 bits
  Mode 0x0318: 1024x768 (+4096), 24 bits
  Mode 0x0330: 320x200 (+320), 8 bits
  Mode 0x0331: 320x400 (+320), 8 bits
  Mode 0x0332: 320x400 (+640), 16 bits
  Mode 0x0333: 320x400 (+1280), 24 bits
  Mode 0x0334: 320x240 (+320), 8 bits
  Mode 0x0335: 320x240 (+640), 16 bits
  Mode 0x0336: 320x240 (+1280), 24 bits
  Mode 0x033d: 640x400 (+1280), 16 bits
  Mode 0x033e: 640x400 (+2560), 24 bits
  Config Status: cfg=new, avail=yes, need=no, active=unknown

Der Ausdruck hinter 'Mode' entspricht dem VGA Wert für die folgende Auflösung. Nun muss dies noch getestet werden.

Der Test erfolgt mit Hilfe eines Neustarts ("reboot"), wobei man die Boot-Parameter des Kernels mit Hilfe der Grub-Shell modifiziert. Dies geht wie folgt:

Dauerhaftes Aktivieren des Framebuffers

Jetzt muss diese Änderung noch dauerhaft gemacht werden, wenn es funktioniert hat. Dafür öffnet man mit einem Texteditor [4] mit Root-Rechten /boot/grub/menu.lst und passt sie wie folgt an:

# defoptions=vga=0x317 fb=true

Dieser verändert die Boot Optionen dauerhaft. Zum Abschluss muss man nun noch Grub aktualisieren, indem man im Terminal [3] folgenden Befehl eingibt:

sudo update-grub 

Danach sollten diese Optionen für die Kernel-Zeilen eingetragen sein und ab dem nächsten Boot dauerhaft wirksam sein.

Achtung!

Bei XEN gibt es aktuell ein Problem mit dem Kernel-Paket linux-image-2.6.22-14-xen (bzw. linux-image-2.6.22-14-generic). Deshalb sollte das Kernel-Paket xen-image-2.6.19-4-server benutzt werden. Mit diesem Paket ist es aber generell nicht nötig, die Initramfs neu zu bilden. Die Schritte 2 und 3 können dann entfallen. Mit Ubuntu 8.04 ist allerdings X11 mit einer Intel GM965/GL960 nicht lauffähig, weder mit Framebuffer noch ohne. Das Paket xen-image-2.6.19-4-server steht daher für 8.04 per default nicht mehr zur Verfügung.

Alternativen