SQLite Database Browser

Dieser Artikel wurde für die folgenden Ubuntu-Versionen getestet:

Zum Verständnis dieses Artikels sind folgende Seiten hilfreich:

  1. Installation von Programmen

  2. Starten von Programmen

Inhaltsverzeichnis
  1. Installation
  2. Bedienung
  3. Links

./sqlitebrowser_logo.png Der SQLite Database Browser 🇬🇧 ist ein einfaches, Qt-basiertes grafisches Werkzeug zum Umgang mit SQLite-3.x-Datenbanken. Das Programm unterstützt das Anlegen, Lesen, Bearbeiten und Löschen von Datenbanken und Datensätzen sowie den Im- und Export von CSV-Dateien.

Installation

Der SQLite Database Browser ist in den offiziellen Paketquellen enthalten und kann über das folgende Paket installiert werden [1]:

Paketliste zum Kopieren:

sudo apt-get install sqlitebrowser 

Oder mit apturl die Pakete installieren. Link: apt://sqlitebrowser

PPA

Möchte man mit den aktuellsten Versionen versorgt werden, so gibt es eine Paketquelle, die für diese Zwecke offiziell von den Entwicklern von SQLite Database Browser empfohlen 🇬🇧 wird:

Adresszeile zum Hinzufügen des PPAs:

Hinweis!

Zusätzliche Fremdquellen können das System gefährden.


Ein PPA unterstützt nicht zwangsläufig alle Ubuntu-Versionen. Weitere Informationen sind der Wiki/Vorlagen/PPA/ppa.png PPA-Beschreibung des Eigentümers/Teams linuxgndu zu entnehmen.

Damit Pakete aus dem PPA genutzt werden können, müssen die Paketquellen neu eingelesen werden.

Nach der Aktualisierung der Paketquellen erfolgt die Installation wie oben angegeben.

Bedienung

Das Programm kann bei Ubuntu-Varianten mit einem Anwendungsmenü über den Eintrag "Zubehör -> DB Browser for SQLite" gestartet werden [2]. Wer das Programm über die Kommandozeile starten möchte, der nutzt den Befehl sqlitebrowser.

Nach dem Start steht eine übersichtliche Oberfläche zur Verfügung, welche aus einer Menüleiste und drei oder vier Reitern (Tabs) besteht. Das Menü erlaubt das Öffnen und Anlegen von Datenbanken sowie Operationen innerhalb der Datenbank. Im Tab "Datenbankstruktur" wird die Struktur der Datenbank angezeigt, der Tab "Daten durchsuchen" zeigt den Inhalt einer Tabelle in der Datenbank an. Außerdem können hier Datensätze angelegt, bearbeitet oder gelöscht werden. Im Tab namens "SQL ausführen" können beliebige SQL-Queries ausgeführt werden, das Ergebnis wird im unteren Teil des Fensters angezeigt.

Wurden Änderungen an der Datenbank vorgenommen oder wird eine neue angelegt, so wird diese nicht automatisch gespeichert. Zum Speichern muss explizit der Menüpunkt "Datei -> Write Changes" ausgewählt bzw. das entsprechende Symbol angeklickt werden.

Datenbank laden und bearbeiten

Über den Menüpunkt "Datei -> Open Database" bzw. einen Klick auf das entsprechende Symbol kann man eine bestehende SQLite-Datenbank öffnen. Diese kann anschließend auch editiert werden.

Zum Editieren der Tabellenstruktur bzw. dem Hinzufügen oder Löschen von Tabellen stehen diverse Auswahlmöglichkeiten im Menü "Bearbeiten" bereit. Um bestehende Daten in einer Tabelle zu ändern, klickt man zuerst auf den Reiter "Daten durchsuchen", um zur Tabellenansicht zu gelangen. Nachdem man im Auswahlmenü "Tabelle" die richtige Tabelle ausgewählt hat, kann man eine Zelle durch einen Doppelklick darauf editieren. Es erscheint ein neues Fenster mit dem aktuellen Wert der Zelle. Diesen kann man ändern und über "Write Changes" in die Tabelle zurück schreiben.

Hat man versehentlich Daten geändert, die gar nicht geändert werden sollten, so lassen sich alle Änderung bis zum letzten Speichern über "Datei -> Revert Changes" rückgängig machen.

Datenbank anlegen

Mit Hilfe des Programms lassen sich auch Datenbanken komplett neu anlegen. Dazu wählt man "Datei -> New Database" und legt einen Datenbanknamen fest. Anschließend erscheint ein neues Fenster namens "Create Table", in dem man oben den Tabellenname festlegen kann und über einen Klick auf "Add" der Tabelle neue Spalten hinzufügt. Bei den Spalten kann der Name frei festgelegt werden, die möglichen Datentype der Spalte werden in einem Auswahlmenü angezeigt.

Ist man fertig, so muss die Datenbank manuell gespeichert werden.