Cinelerra-GG Infinity

Dieser Artikel wurde für die folgenden Ubuntu-Versionen getestet:

Zum Verständnis dieses Artikels sind folgende Seiten hilfreich:

  1. Installation von Programmen

  2. Starten von Programmen

  3. Archive entpacken

  4. Rechte von Dateien ändern

  5. Ein Terminal öffnen

Inhaltsverzeichnis
  1. Installation
    1. Installation aus den Cinelerra-GG eigene...
    2. Installation eines Einzelbenutzer-Builds...
    3. Installation aus dem Quellcode
    4. Sprachunterstützung
  2. Bedienung
    1. Programmaufruf
    2. Hauptfenster
    3. Ressourcen-Fenster
    4. Viewer-Fenster
    5. Compositor-Fenster
    6. Rendern
    7. Anleitungen
    8. Umgang mit Codecs
  3. Problembehebung
  4. Links

./Cinfinity_logo_3D_black_300px.png Cinelerra-GG Infinity 🇩🇪 ist ein freies, nichtlineares Videobearbeitungsprogramm für das Betriebssystem GNU/Linux und Unix. Es wird von der Cinelerra-GG Community und dem Hauptentwickler W. P. Morrow alias Good Guy, Kurzform GG, entwickelt und steht unter der GNU General Public License.

Die Hauptfunktionen der Software sind:

Das Programm unterstützt u.a. 8K-Videos und 64-Bit-Audio. Cinelerra-GG Infinity ist enorm leistungsfähig und wegen der Komplexität eher für den erfahrenen Anwender geeignet. Wer ein Programm mit einfacher Bedienung sucht, wird sicher unter Videobearbeitung fündig.

Cinelerra-GG Infinity, auch Cin genannt, ist eine Vereinigung und fortgeschrittene Weiterentwicklung von Cinelerra-HV, Cinelerra-CV, der eigener Version vom Entwickler Good Guy und anderen Entwicklern. Der Namenszusatz "Infinity" ist die Versionsbezeichnung und ist aufgrund der permanenten monatlichen Ausgabe neuer Versionen nach dem "Rolling Release" Prinzip entstanden. Die "Community Version", auch "CV" genannt, wird nicht mehr weiterentwickelt. Infolge dessen wurde die alte Cinelerra-CV Domain auf die Cinelerra-GG Infinity Webseite umgeleitet. Die Cinelerra-HV Version ist eine weniger gewartete Version, die vom Erfinder von Cinelerra überwiegend für private Zwecke genutzt wird.

Ursprünglich als Überarbeitung gedacht, dann als eigenständiges Projekt ist die Abspaltung Lumiera 🇬🇧 zu nennen, das aber noch nicht den Alpha-Status erreicht hat.

Darüber hinaus ist der Fork des Entwicklers Einar Rünkaru zu erwähnen, der basierend auf Cinelerra-CV eine eigene Version von Cinelerra weiterentwickelt, die auch Cinelerra-CVE genannt wird. Diese Version befindet sich in der Entwicklungsphase.

./cinelerra-gg_infinity_startfenster.png

Hinweis:

Die nachfolgende Installationsanleitung bezieht sich auf Cinelerra-GG Infinity.

Installation

Installation aus den Cinelerra-GG eigenen Paketquellen

Cinelerra-GG Infinity befindet sich nicht in den offiziellen Paketquellen, kann aber aus den Cinelerra-GG eigenen Paketquellen bezogen werden. Das Programm ist für Ubuntu 18.04 und 16.04 verfügbar.

Hinweis!

Fremdsoftware kann das System gefährden.

Für die Installation werden einige Pakete aus den offiziellen Paketquellen benötigt. Um diese hinzuzufügen, gibt man im Terminal folgendes ein:

sudo apt install software-properties-common apt-transport-https 

Danach fügt man die Cinelerra-GG Paketquellen hinzu. Der folgende Befehl bezieht sich auf Ubuntu 18.04. Für die Installation für Ubuntu 16.04 ändert man die Zahl 18 in 16 um.:

sudo apt-add-repository https://cinelerra-gg.org/download/pkgs/ub18 

Im Anschluss editiert man die Datei /etc/apt/sources.list, um sicherzustellen, dass die hinzugefügte Zeile [trusted=yes] enthält, wie unten gezeigt:

1
deb [trusted=yes] https://cinelerra-gg.org/download/pkgs/ub18 bionic main

Für die Installation des Programms führt man folgende Befehle aus:

sudo apt update
sudo apt install cin 

Um eine frühere Installation zu aktualisieren, führt man Folgendes aus:

sudo apt update
sudo apt upgrade cin 

Installation eines Einzelbenutzer-Builds

Alternativ kann man das Programm über ein Einzelbenutzer-Build installieren, dazu lädt man von der Projektseite 🇩🇪 ⮷ das passende Archiv, zum Beispiel cinelerra-5.1-ub18.04-20190630.x86_64-static.txz herunter, entpackt [3] es und macht die Datei ausführbar [4].

Hinweis!

Fremdsoftware kann das System gefährden.

Im Anschluss kann das Programm gestartet werden [2].

Installation aus dem Quellcode

Wer es vorzieht, Cinelerra aus dem Quellcode zu installieren, kann die Anleitung How to Build Cinelerra-GG from Developer's Git Repository 🇬🇧 aus dem Benutzerhandbuch nutzen.

Sprachunterstützung

Um Cinelerra in deutsch starten zu lassen, muss mit dem Befehl [5]:

sudo locale-gen de_DE 

die passende Sprachdatei erzeugt werden. Im Anschluss startet Cinelerra auf Deutsch (sofern ein Begriff übersetzt wurde).

Wer Cinelerra-GG Infinity unabhängig von der Umgebungssprache in einer anderen Sprache starten will, kann durch Nutzung der Variable LANGUAGE in der Konsole die Spracheinstellungen für die aktuelle Sitzung ändern. Durch ausführen des folgenden Befehls wird Cinelerra in englischer Sprache gestartet:

LANGUAGE=en cin 

Bedienung

Programmaufruf

Es empfiehlt sich, Cinelerra in einem Terminal zu starten:

cin  

Auf diese Weise lassen sich in Problemfällen oft wichtige Fehlermeldungen entnehmen. cinelerra-gg_windows.jpg

Cinelerra startet mit vier separaten Fenstern:

Unter dem Menüpunkt "Fenster" kann man auswählen, welche dieser Fenster man angezeigt haben möchte. Es gibt noch "Overlays" und "Level". Und außerdem eine Funktion, alle Fenster wieder an den Standardplatz zurückzuschieben: "Standard-Positionen". Darüber hinaus lassen sich eigene Fensteranordnungen unter dem Menüpunkt "Fenster" und "Layout speichern" speichern.

Hauptfenster

Das Herzstück des Programmes enthält standardmäßig:

cinelerra-gg-fenster.jpg

Die Symbolleiste besteht aus mehreren durch "|" getrennten Abschnitten:

Es können weitere Audio- und/oder Videospuren hinzugefügt werden.

Dateien aus "Media" im Ressourcen-Fenster können mit der Maus nach Belieben auf die passende Ton- oder Videospur im Programmfenster gezogen werden, ebenso gewünschte Effekte per Drag'n'Drop.

Projekte werden mit "Datei -> Speichern" oder "Datei -> Sichern" gespeichert, wobei ein Projekt lediglich eine Arbeitsliste darstellt, Mediendateien selbst werden nicht touchiert.

Erst durch "Rendern" wird eine neue Ausgabedatei erzeugt. Dieser Vorgang ist rechenintensiv.

Ressourcen-Fenster

Hier werden alle für das aktuelle Projekt eingeladenen Audio- und Videodateien angezeigt.

Im Hauptfenster wählt man unter "Datei -> Dateien laden" die gewünschten Dateien aus (mehrere mit Strg gedrückt gehalten) und klickt auf das Häkchen (atypischerweise immer links, während das Kreuz für "Verwerfen" immer rechts zu finden ist).

Wichtig: "Erzeuge neue Ressourcen" auswählen! Standard ist "Ersetze aktuelles Projekt", was alle bereits eingeladenen Dateien wieder entfernen würde.

Die eingeladenen Dateien finden sich dann im Ressourcen-Fenster. Dieses enthält links folgende Liste:

Im linken Bereich des Ressourcenfenster lassen sich per Rechtsklick und dem Benutzerordner-Kontextmenü eigene Ordner für Video-, Audio- und Bild-Dateien anlegen. Dieses Feature verfügt über ein mächtiges Filtersystem, welches dem Benutzer erlaubt, beliebige Inhalte nach Suchkriterien zu filtern, wie zum Beispiel Videodateien mit einem bestimmten Namen, Erstellungsdatum, Videolänge oder Erstellungsdatum und vieles mehr. Dadurch lassen sich Inhalte einfach und schnell filtern und ordnen. cinelerra-gg-infinity-neue-ordner.jpg

Es werden eine Vielzahl von Video- und Audio-Effekten und Softwareerweiterungen unterstützt. Nennenswert sind die Plugins von FFmpeg und die Einbindung der LV2 Schnittstelle und dadurch die Nutzbarkeit der Audioplugins von Calf Studio Gear 🇬🇧. Die Audioplugin-Sammlung von Calf Studio Gear muss eigenständig installiert werden, damit man es in Cinelerra nutzen kann. cinelerra-gg-calfstudiogear-support.jpg

Viewer-Fenster

Dieses Fenster erlaubt es, eingeladene Dateien anzuschauen, ohne dass sie in das Projekt im Hauptfenster eingeladen sein müssen.

Compositor-Fenster

In diesem Fenster kann man die Wirkung eingestellter Effekte oder Übergange sich anzeigen lassen und Änderungen/Anpassungen vornehmen.

Rendern

Mit Rendern ist gemeint, das projektierte Video tatsächlich zu erzeugen und als Datei zu speichern. Zuerst sollte man unter "Einstellungen -> Format" überprüfen, ob die Voreinstellungen für die Ausgabe passend sind. Eingestellt sind:

Hier kann man außerdem ein Häkchen bei "Auto" setzen, um sich dem Quellformat anzupassen.

Dann geht man auf "Datei -> Rendern", gibt den gewünschten Dateinamen ein, wählt unter "Dateiformat" "FFmpeg" und "mp4" und setzt Häkchen sowohl bei "Video" als auch bei "Audio". Schließlich noch bei der Einfügestrategie "Füge nichts ein" auswählen.

Anleitungen

Ausführliche Anleitungen zu Cinelerra-GG Infinity und verschiedene Video-Anleitungen, Tutorials und Einsteiger-Videos sind auf cinelerra-gg.org 🇬🇧 zu finden.

Umgang mit Codecs

Empfehlenswerte Einstellungen für Ausgabecontainer und Codecs sind:

Details finden sich im Cinelerra-GG Benutzerhandbuch 🇬🇧 (PDF).

Problembehebung

Sollte das Programm immer wieder beim Starten abstürzen, so kann es an den vorherigen Einstellungen liegen, die mit einer neueren Version nicht mehr kompatibel sind. Hierbei hilft es, den Konfigurationsordner .bcast5/ im Homeverzeichnis umzubenennen, dadurch gehen allerdings die bisherigen Einstellungen verloren. Beim Neustart des Programms wird eine neuer .bcast5/ Ordner angelegt.