ubuntuusers.de

Benutzung

Archivierte Anleitung

Dieser Artikel wurde archiviert. Das bedeutet, dass er nicht mehr auf Richtigkeit überprüft oder anderweitig gepflegt wird. Der Inhalt wurde für keine aktuell unterstützte Ubuntu-Version getestet. Wenn du Gründe für eine Wiederherstellung siehst, melde dich bitte in der Diskussion zum Artikel. Bis dahin bleibt die Seite für weitere Änderungen gesperrt.

Achtung!

Von der Verwendung von xorg-edit ab Ubuntu 8.04 Hardy Heron wird dringend abgeraten! Im schlimmsten Fall erhält man nach Verwendung von xorg-edit eine Konfiguration, mit der der XServer nicht mehr startet!

Diese Seite beschäftigt sich mit der Benutzung des Programmes xorg-edit und wie man damit den XServer grafisch einrichtet.

xorg-edit Grundlagen

Oberfläche

Die Benutzung des Programmes ist eigentlich recht intuitiv. Die einzelnen Sektionen der xorg.conf für Anzeigegerät (Device), Monitor, Eingabegerät (Input Device), Schirm (Screen), Server (Server Layout und Server Flags) und andere Optionen (Extensions, Module und Files) werden als Tabs am oberen Rand aufgelistet.

Per Drop-Down-Feld kann man in den meisten Fällen Einträge und Optionen auswählen, hinzufügen, löschen oder kopieren. Optionen, Module, Erweiterungen und Dateipfade haben die Besonderheit, dass man sie aktivieren und deaktivieren kann, was einer Auskommentierung in der xorg.conf gleich kommt.

Per F5 oder über "Extras → Vorschau" kann man sich die aktuellen Änderungen anschauen, bevor man diese speichert.

Optionen verwalten

Bei den Anzeige- und Eingabegeräten findet man in den Optionen zusätzlich den Punkt "Optionen verwalten...". Mit dessen Hilfe kann man leicht neue Optionen hinzufügen, wenn es für den aktuell gewählten Treiber eine zugehörige xml-Datei mit Treiberoptionen gibt. Weitere Erklärungen dazu im Hauptartikel Archiv/xorg-edit.

Modeline-Generator

Der Modeline-Generator befindet sich unten im "Monitor"-Tab. Man trägt bei "X" und "Y" die jeweilige Auflösung ein und bei der Frequenz die gewünschte Wiederholrate. Ein Klick auf "Erstellen" erstellt dann in den Feldern darunter die zugehörige Modeline, die man so einfach oben per Copy&Paste hinzufügen kann. Alternativ kann man auch per "Hinzufügen" die Modeline direkt beim aktuellen Monitor anfügen.

Hinweis:

Zum Erstellen der Modelines wird das Tool gtf benutzt. Es kann keine Garantie gegeben werden, dass die erstellten Modeslines auch einwandfrei funktionieren!

Monitordaten auslesen

Im "Monitor"-Tab gibt es einen Knopf "Berechne Frequenz", der per ddcprobe versucht die Monitordaten auszulesen. Dieser Part erfordert zwingend Root-Rechte, xorg-edit muss also als Root gestartet werden, wenn man diese Funktion nutzen möchte.

Hinweis:

Nicht jeder Monitor bzw. Anschlussart unterstützt das Auslesen per ddcprobe. So erhält man bei Monitoren mit DVI-Anschluss oder bei Laptop-Bildschirm kein Ergebnis!

Im gleichen Tab befindet sich auch noch ein Knopf, der die Anzeigegröße (DisplaySize) berechnet. Dies sind eigentlich nur die reale Breite und Höhe des Bildschirms. Hier wird einfach die Ausgabe von xdpyinfo genommen und ausgewertet. In dieser sind die Monitorwerte in mm angegeben.

Achtung!

Bei Laptops kann es zu falschen Ergebnis der Auflösung kommen, da xpdyinfo nicht mit den großen Auflösungen zurecht kommt. Sollte nach dem Berechnen die erstellte Werte nicht in etwa passen, sollte man sie auch nicht nutzen!

Konfiguration testen

Vor dem Speichern und unter "Extras → Test" kann man testen, ob die aktuellen Einstellungen korrekt sind. Es wird dann versucht einen zweiten XServer mit den angegebenen Daten zu starten. Sollte dies fehlschlagen, würde nach einem Neustart keine grafische Oberfläche mehr erscheinen. Ein Speicherung ist in dem Fall nicht empfohlen!

Speichern

Beim Speichern werden im Arbeitsverzeichnis (normalerweise ist dies /etc/X11) Sicherungskopien der alten xorg.conf angelegt. Diese tragen danach den Namen xorg.conf_DATUM_UHRZEIT, wobei aber jede Nichtzahl (also Punkte, Striche, etc.) aus dem String entfernt werden. Die Sicherungsdateien können später geladen und/oder zurückgespielt werden.

Achtung!

Nach einer Änderung ist immer ein Neustart des XServers notwendig. Entweder durch Abmelden und Strg + Alt + oder durch einen PC-Neustart!

Sicherungskopie zurückspielen

per GUI

Hat man einen Fehler bei der Konfiguration gemacht, hat aber noch eine grafische Oberfläche, startet man xorg-edit erneut. Jetzt wählt man "Datei → Laden" und öffnet die letzte Sicherungsdatei (erkennbar an Datum und Uhrzeit). Danach wählt man "Datei → Speicher untern" und gibt als Dateiname /etc/X11/xorg.conf an. Jetzt ist die alte Konfigurationsdatei wieder gesichert!

per Konsole

Hat man keine grafische Oberfläche mehr, kann man entweder die Sicherungsdatei mit

cd /etc/X11
sudo cp xorg.conf_DATUM_UHRZEIT xorg.conf 

zurückkopieren oder man richtet den XServer komplett neu ein.

Anleitungen

Wacom-Einträge entfernen

Seit Ubuntu Dapper 6.06 werden in der XServer-Konfigurationsdatei xorg.conf standardmäßig folgende Wacom-Geräte eingetragen:

Section "InputDevice"
  Driver        "wacom"
  Identifier    "stylus"
  Option        "Device"        "/dev/wacom"          # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "stylus"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "eraser"
  Option        "Device"        "/dev/wacom"          # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "eraser"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "cursor"
  Option        "Device"        "/dev/wacom"          # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "cursor"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

In den meisten Fällen hat der Benutzer aber keine solchen Geräte und so erscheint im Logfile beim XServer-Start mehrfach die Fehlermeldung

(**) Option "Device" "/dev/wacom"
(EE) xf86OpenSerial: Cannot open device /dev/wacom
        No such file or directory.
Error opening /dev/wacom : No such file or directory

oder beim Öffnen von Programmen aus dem Terminal heraus

X Error: BadDevice, invalid or uninitialized input device 166
  Major opcode:  145
  Minor opcode:  3
  Resource id:  0x0
Failed to open device

Dies lässt sich einfach lösen, indem man nacheinander im Reiter "Eingabegeräte" die Einträge für "stylus", "eraser" und "cursor" per Dropdownmenü auswählt und jeweils "Eingabegerät löschen" wählt. Die Abfrage, ob die Referenz ebenfalls gelöscht werden soll, wird mit "Ja" beantwortet.

Alternativ kann man die Einträge auch manuell in der xorg.conf löschen, darf aber nicht die Referenzen im ServerLayout: vergessen, denn dann startet der XServer nicht mehr.

Dualmonitor konfigurieren

Hinweis:

Es wird bei der Anleitung von einer Standard-Konfigurationsdatei ausgegangen, in der nur ein Ausgabegerät, ein Monitor und ein Schirm angegeben sind. Sollte es bereits mehrfache Einträge geben, müssen diese entsprechend angepasst oder einfach ignoriert werden.

Oft möchte man an einer Grafikkarte zwei Monitor oder einen Monitor und einen Fernseher anschließen. Hier gibt es eine einfache Möglichkeit dies zu realisieren, welche auch die meisten Grafiktreiber unterstützen.

Anzeigegerät einstellen

  1. Im "Anzeigegeräte"-Tab wählt man die Grafikkarte aus, an der die Monitore später hängen werden. Bei "Schirmnummer" trägt man eine 0 ein.

  2. Jetzt wählt man im DropDown-Menü "Anzeigegerät kopieren"; dieses erhält den Zusatz "(Kopie)" bei der Bezeichnung.

  3. In diesem neuen Gerät trägt man bei "Schirmnummer" eine 1 ein.

Monitore einstellen

Hat man bereits beide Monitore eingerichtet, kann man diese Schritte überspringen.

  1. Ansonsten wählt man im "Monitor"-Tab im Drowdown-Feld den Eintrag "Monitor hinzufügen" aus.

  2. Die "Bezeichnung" "Default Monitor 2" kann man ändern, wenn man mag.

  3. Wichtig sind meist die Angaben zu "Hor.Sync." und "VertRefresh", siehe auch Bildschirmauflösung. Wichtig: Der Knopf "Berechne Frequenz" gilt nur für den ersten Monitor!

Achtung!

Es ist nicht empfohlen den ersten Monitor einfach zu kopieren. Und wenn doch, sollte man zwingend die richtigen Frequenzen oder zur Not gar keine eintragen. Ansonsten startet der XServer ggf. nicht mehr.

Schirm einstellen

  1. Im "Schirm"-Tab wählt man den ersten Schirm aus und wählt im DropDown-Menü die Option "Schirm kopieren".

  2. Bei "Anzeigegerät" wählt man die Kopie des Anzeigegerätes aus und bei "Monitor" den neuen Monitor.

  3. Wichtig: Ggf. muss man noch die "Standardtiefe" oder die Auflösungen bei der "Anzeigetiefe" ändern.

Server Layout einstellen

  1. Im "Server"-Tab sollte bereits der erste Schirm als "Schirm 0" eingestellt werden. Bei "Nummer" trägt man nur noch eine 0 ein.

  2. Nun wählt man in dem kleinen DropDown-Feld "Schirm hinzufügen"; es wird ein "Schirm 1" erstellt und automatisch die zuvor erstellt Kopie ausgewählt.

  3. Bei "Nummer" trägt man jetzt eine 1 ein.

  4. Optional: Bei der Position gibt man eine der Möglichkeiten LeftOf, RightOf, Above oder Below ein. Danach wird das DropDown-Feld dahinter anwählbar und hier wählt man den ersten Schirm aus.

Änderungen übernehmen

Mit F5 kann man in der Vorschau überprüfen, ob alles korrekt eingetragen wurde. Das Server Layout sollte dann z.B. in etwa so aussehen:

Section "ServerLayout"
        Identifier "Default Layout"
        Screen 0 "Default Screen"
        Screen 1 "Default Screen (Kopie)" Below "Default Screen"
        InputDevice "Generic Keyboard"
        InputDevice "Configured Mouse"
EndSection

Danach die Datei speichern mit Strg + S und nach einem XServer-Neustart sollte alles klappen.

Hinweis:

Wer das Bild nicht nur Clonen will, sondern einen übergreifenden Desktop nutzen möchte, sollte bei "Server Flags" noch die Option "Xinerama" "true" eintragen. Achtung: Danach funktioniert die 3D-Beschleunigung wahrscheinlich nicht mehr!

Diese Revision wurde am 10. Februar 2020 22:45 von Heinrich_Schwietering erstellt.
Die folgenden Schlagworte wurden dem Artikel zugewiesen: System, xorg, xserver