jNetMap

Dieser Artikel wurde für die folgenden Ubuntu-Versionen getestet:

Zum Verständnis dieses Artikels sind folgende Seiten hilfreich:

  1. Ein einzelnes Paket installieren

  2. Ein Terminal öffnen

  3. Einen Programmstarter erstellen

  4. Root-Rechte erlangen

Inhaltsverzeichnis
  1. Voraussetzungen
  2. Installation
  3. Verwendung
  4. Konfiguration
  5. Problembehandlung
  6. Links

./jnetmap_logo.png jNetMap 🇬🇧 ist ein plattformübergreifendes Programm zur Dokumentation von Netzwerkstrukturen, insbesondere der Netzwerk-Topologie. Darüber hinaus kann anhand der erstellten Übersichtskarten die vorhandene Infrastruktur in regelmäßigen Abständen auf Erreichbarkeit geprüft werden. Diverse Erweiterungen (Plugins) erweitern die Funktionalität um Benachrichtigungsmechanismen oder Wartungszugänge.

Trotz seiner Monitoring-Fähigkeit ist jNetMap aber nur begrenzt als Werkzeug zur Netzwerk-Analyse bzw. zum Netzwerk-Audit einsetzbar. Besser geeignete Programme sind im Artikel Netzwerk-Monitoring beschrieben.

jNetMap-main.png
jNetMap

Voraussetzungen

jNetMap basiert auf Java. Die Installation einer Laufzeit-Umgebung (JRE) in der Version 6 oder höher ist daher zwingend Voraussetzung zur Nutzung des Programms. Ab Version 0.5.3 wird Java 7 oder neuer benötigt.

Installation

Das Programm ist nicht in den Paketquellen enthalten (486885).

Fremdpaket

Über die Downloadseite 🇬🇧 ⮷ kann ein Fremdpaket heruntergeladen und manuell installiert [1] werden.

Hinweis!

Fremdpakete können das System gefährden.

Manuell

Über die oben genannte Downloadseite kann auch eine .jar-Datei ("Others") heruntergeladen werden. Diese lässt sich direkt starten [2]:

java -jar jNetMap-0.x.y.jar 

Einen Programmstarter [3] muss man bei Bedarf selbst erstellen. Beispiel (Benutzername, Pfade und Dateinamen anpassen!):

[Desktop Entry]
Encoding=UTF-8
Name=jNetMap
Comment=Netzwerk-Dokumentation und -Monitoring
Exec=java -jar /home/BENUTZERNAME/bin/jNetMap-0.x.y.jar
Icon=/home/BENUTZERNAME/Bilder/icons/jnetmap_logo.png
Terminal=false
Type=Application
Categories=Network;
StartupNotify=false

Verwendung

./jnetmap_lanmap.png Nach der Installation ist das Programm bei Ubuntu-Varianten mit einem Anwendungsmenü unter "Internet -> jNetMap" zu finden. Die allgemeine Vorgehensweise:

  1. "Neue Karte erstellen"

  2. Netzwerk scannen mit "Werkzeuge -> Netzwerkscanner"

  3. Karte nach Bedarf ändern, ergänzen usw.

  4. Karte speichern

  5. Karte bei Bedarf als Bild exportieren (so kann man eine Karte auch drucken)

Geräte

Prinzipiell wird zwischen Geräten (devices) und Verbindungen (connections) unterschieden. Über die rechte Maustaste rechte Maustaste bzw. das Kontextmenü lassen sich die Eigenschaften eines markierten Geräts bearbeiten oder ein neues Gerät hinzufügen.

Geräte können mehrere Schnittstellen (interfaces) besitzen, die man verschiedenen Verbindungen zuordnen kann.

Wiki/Icons/Oxygen/preferences-system-network.png

Verbindungen

Im Gegensatz zu reinen Diagrammen, die sich z.B. mit Dia erstellen lassen, sind Verbindungen in jNetMap "interaktiv", d.h. sie können ihren Zustand farblich wiedergeben:

Zum (nachträglichen) Hinzufügen einer Verbindung wechselt man vom Auswahlmodus ./jnetmap_mode_select.png in den Bearbeitungsmodus ./jnetmap_mode_edit.png. Erst jetzt kann man eine Verbindung zwischen zwei Geräten erstellen. Zur Kontrolle der Verbindung dienen weitere Parameter wie Verbindungstyp, IP-Konfiguration, MAC-Adressen der beteiligten Netzwerkkarten etc.

Hinweis:

Die Anzeige des Verbindungs-Status funktioniert nicht immer zuverlässig. So werden beispielsweise Verbindungen zu Geräten außerhalb des eigenen Netzwerks als grün markiert, obwohl sie nicht aus dem LAN zu erreichen sind. Dies gilt auch für Verbindungen zu Geräten wie z.B. Druckern, die gar keine Netzwerkschnittstelle besitzen.

Karten

Alle Informationen lassen sich gemeinsam als Karte im speziellen Format .jnm speichern. Da die Programmoberfläche mit Reitern (Tabs) arbeitet, lassen sich auch mehrere Karten öffnen bzw. bearbeiten. Über "Datei -> Eigenschaften" stellt man das Aktualisierungsintervall der Verbindungen und eine evtl. Status-Benachrichtigung (siehe Benachrichtigungs-Plugins) ein. Auf Wunsch lässt sich der aktuelle Zustand auch als Bild im PNG-Format exportieren.

Konfiguration

Wiki/Icons/settings.png Die Konfiguration des Programms ist über "Bearbeiten -> Einstellungen" ("Edit -> Preferences") oder die ungewöhnliche Tastenkombination Strg + P zugänglich. Dazu zählen beispielsweise die Spracheinstellungen, das Aussehen der Benutzeroberfläche, der Linien-Stil der Verbindungen und die Verwaltung der Erweiterungen. Manche Einstellungen erfordern einen Neustart des Programms, damit sie wirksam werden.

Konfigurationsdaten werden im Ordner ~/.jNetMap/ im Homeverzeichnis gespeichert. In diesem Verzeichnis befindet sich auch die engl. Bedienungsanleitung guide.pdf, die sich innerhalb des Programms über "Hilfe -> Dokumentation" aufrufen lässt.

Erweiterungen

Folgende Erweiterungen 🇬🇧 sind vorhanden und (mit Ausnahme von Wireshark) bereits in das Programm integriert:

./jnetmap_wireless.png

Netzwerksymbole

Die im Programm enthaltenen Netzwerksymbole befinden sich im Ordner ~/.jNetMap/cisco/ und können auch ausgetauscht werden, wenn man den Dateinamen und das Bildformat beibehält. Allerdings sind die enthaltenen Symbole aufgrund der freizügigen Lizenz der Fa. Cisco weit verbreitet und ein Quasi-Standard.

Problembehandlung

Beim Fremdpaket in der Version 0.5.2 von der Downloadseite 🇬🇧 lässt sich jNetMap nicht starten, da die Zugriffsrechte nicht stimmen. Lösen kann man das Problem mit dem Befehl [4]:

sudo chmod 755 /usr/share/jnetmap 

Unter Bionic (18.04) soll OpenJDK8 verwendet werden, siehe Forum; dort ist (für eine andere Anwendung) auch beschrieben, wie man bei mehreren installierten JAVA-Versionen eine bestimmte Version erzwingen kann.