ubuntuusers.de

Eclipse

Dieser Artikel wurde für die folgenden Ubuntu-Versionen getestet:

eclipse_logo.png Eclipse 🇬🇧 ist eine Plattform für Entwicklungsumgebungen. Vom Grundumfang her ist Eclipse geeignet um Java-Programme zu schreiben. In diesem Wiki soll erklärt werden, wie man Eclipse installiert und lokalisiert.

Installation

Eclipse befindet sich in allen Ubuntu-Versionen in den offiziellen Paketquellen, so dass nur das Paket

  • eclipse (universe)

Paketliste zum Kopieren:

sudo apt-get install eclipse 

Oder mit apturl die Pakete installieren. Link: apt://eclipse

installiert [1] werden muss.

Um ein auf diese Weise installiertes Eclipse zu lokalisieren, muss man weitestgehend den Schritten unter Lokalisierung folgen. Allerdings muss der Inhalt des Sprachpaketes nach /usr/lib anstatt nach /opt entpackt werden.

Hinweis:

Die Eclipse-Version, die sich in den offiziellen Paketquellen befindet, ist nicht (immer) aktuell. Wer auf neue Funktionen angewiesen ist, sollte eine manuelle Installation in Betracht ziehen.

Manuelle Installation

Vorbereitung

Installation von Java:

  • default-jre

Paketliste zum Kopieren:

sudo apt-get install default-jre 

Oder mit apturl die Pakete installieren. Link: apt://default-jre

Herunterladen

Um eine Version von Eclipse zu installieren, lädt man die gewünschte Eclipse-IDE für Linux von einem der (am besten deutschen) Mirror auf der Eclipse-Homepage 🇬🇧. Danach entpackt [4] man das Paket mit Root-Rechten [6] nach /opt. Alternativ lädt man sich das passende Package von http://ehub.yatta.de?packages 🇬🇧 herunter.

Hinweis:

Eclipse ist in der Standard-Distribution nicht für die Verwendung mit mehreren Benutzern vorgesehen, da Plugins und Aktualisierungen auf das Programmverzeichnis schreiben und auch Einstellungen dort gespeichert werden. Wer seine Plugins und Aktualisierungen im Team teilen will kann den das entsprechende Profil über http://ehub.yatta.de?packages 🇬🇧 installieren und deren Update Mechanismus benutzen.

Installieren

Nach dem Entpacken müssen die Datei- und Verzeichnisbesitzer des Eclipse-Verzeichnisses auf den Benutzer geändert werden [5]:

sudo chown -R $USER:$USER /opt/eclipse 

Um Eclipse dann einfacher starten zu können, kann ein Start-Skript geschrieben werden. Dazu einen Editor [3] mit Root-Rechten [6] öffnen und eine Datei mit folgendem Inhalt anlegen:

1
2
3
4
#!/bin/bash
export MOZILLA_FIVE_HOME="/usr/lib/firefox/"
export ECLIPSE_HOME="/opt/eclipse"
/opt/eclipse/eclipse "$@"

Diese Datei speichert man als /usr/local/bin/eclipse und setzt die Ausführrechte [5] entsprechend. Bei Ubuntu 9.10 und Eclipse 3.5 gibt es Probleme mit einigen Buttons. In diesem Fall fügt zusätzlich folgenden Export ein:

export GDK_NATIVE_WINDOWS=1 

Gestartet wird Eclipse dann über das Start-Skript mit dem Befehl

eclipse 

Sollte man beim Start eine Fehlermeldung "Problems opening page" erhalten, dann muss man die beiden export-Zeilen oben im Skript entfernen.

Eclipse 4.x (Juno) kann normalerweise auch direkt (ohne ein Start-Skript) gestartet werden über die ausführbare Datei in /opt/eclipse/eclipse.

Launcher-Symbol einrichten

Um in Ubuntu 11.04 oder neuer ein Symbole im Launcher zu erhalten, empfiehlt es sich, eine .desktop-Datei anzulegen und das Eclipse-Symbol von /opt/eclipse/icon.xpm auszuwählen (siehe Programmstarter).

Beispiel für eine funktionierende Desktop-Datei ab Ubuntu 12.04 (zur Installation einfach in eine Datei namens eclipse.desktop im Verzeichnis ~/.local/share/applications kopieren:

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
[Desktop Entry]
Name=Eclipse 
Type=Application
Exec=/opt/eclipse/eclipse
Terminal=false
Icon=/opt/eclipse/icon.xpm
Comment=Integrated Development Environment
NoDisplay=false
Categories=Development;IDE
Name[en]=Eclipse

Lokalisierung

Für die neueren Versionen von Eclipse (offiz. Übersicht über Eclipse-Versionen 🇬🇧, Übersicht) existiert keine deutsche Lokalisierung als Komplettpaket. Vielmehr bietet das Eclipse Babel Projekt 🇬🇧 eine Vielzahl von Sprachpaketen an, die einzelne Module von Eclipse (zumindest großteils) übersetzen.

Für ältere Eclipse-Versionen kann man sich die Sprachpakete 🇬🇧 ⮷ herunterladen.

Automatische Installationsvariante der Lokalisierungspakete

Unter Downloads 🇬🇧 findet man Links, die man unter Berücksichtigung der entsprechenden Version, wie im Abschnitt Erweiterungen beschrieben, einbindet und installieren kann. Für die automatische Installation kopiert man also den Link der Quelle. Dabei ist darauf zu achten, dass die Links, die den Ausdruck update-site beinhalten, als Quelle auszuwählen sind (hier ein Beispiel für Version 3.7/Indigo):

http://download.eclipse.org/technology/babel/update-site/R0.10.0/indigo

Manuelle Vorgehensweise der Lokalisierung

Für eine manuelle Lokalisierung können .zip-Pakete (wiederum am Beispiel Indigo) heruntergeladen 🇬🇧 ⮷ werden.

Eventuelle Endanpassungen für das Starten in gewünschten Sprache

Falls Eclipse dann nicht schon automatisch in Deutsch gestartet wird, kann man folgenden Aufruf verwenden:

eclipse -nl de_DE 

Der Parameter muss gegebenenfalls auch im Startskript hinzugefügt werden. Danach wird Eclipse über den vorhin im Menü angelegten Eintrag neu gestartet. Die hier beschriebene Prozedur ist nur die Grundinstallation von Eclipse. Diese kann durch zahlreiche Plugins noch in jeder Hinsicht stark erweitert werden.

Lokalisierung der Rechtschreibprüfung

Eclipse wird nur mit englischem Wörterbuch (BE/AE) ausgeliefert. Um eine Lokalisierung der Rechtschreibprüfung zu erreichen, muss das entsprechende aspell-Sprachpaket installiert werden. Eine Liste aller aspell-Sprachpakete befinden sich im Artikel Rechtschreibkorrektur. Eclipse akzeptiert das Wörterbuch nur im Format mit einem Wort pro Zeile. Ein deutsches Wörterbuch im entsprechenden Format kann durch Eingabe von folgendem Befehl im Terminal [2] erreicht werden:

aspell dump master de_DE > de_DE.dict 

Mittlerweile komprimiert aspell bei der Ausgabe die Wörter. Mit dieser Kompression können andere Programme wie z.B. die Eclipse-IDE nichts anfangen, da sie ein "richtiges" Wort in jeder Zeile erwarten! Mit folgender Befehlsfolge können die Wörter expandiert werden, wobei jedes expandierte Wort in eine separate Zeile geschrieben wird:

aspell -l de_DE dump master | aspell -l de expand | tr ' ' '\n' > de_DE.dict 

Der Befehl muss für andere Sprachen (hier: "'de_DE'", reformierte deutsche Rechtschreibung) angepasst werden. Der Name der Ausgabedatei (hier: "'de_DE.dict'") kann frei gewählt werden. In Eclipse muss nun folgendes Menü geöffnet werden:

  1. "Window → Preferences"

  2. "General → Editors → Text Editors → Spelling"

  3. In "Select spelling engine to use" die entsprechende Programmiersprache auswählen

  4. Unter "User defined dictionary" auf "Browse..." klicken und das entsprechende Wörterbuch auswählen und dann "OK"

  5. Eclipse-IDE neu starten

Alternatives Gesamtpaket

Profiles for Eclipse

Profiles for Eclipse bietet eine Plattform mit einer großen Auswahl an bereits eingerichteten Eclipse Profilen aus der Community. Beim Herunterladen eines Profils erhält man ein funktionierendes Eclipse, das man auch selbst noch weiter anpassen kann. Profile können dabei plattformunabhängig eingesetzt werden und laufen sowohl auf Linux als auch auf Windows und MacOS-X.

Mit der Installation erhält man einen Launcher, über den man seine Eclipse Installationen starten kann. Auch die standardisierten Eclipse Packages lassen sich über den Launcher herunterladen und installieren.

Zusätzlich dazu lassen sich die eigenen Eclipse Installationen per Knopfdruck exportieren und mit anderen teilen.

Erweiterungen (Plugins)

Die Installation erfolgt einfach durch das Entpacken der Ordner in das Verzeichnis, in das Eclipse installiert wurde. Bei der Installation aus den Quellen ist das /usr/lib/eclipse. Es ist immer ein Feature- und ein plugin-Ordner vorhanden. Normalerweise sollte Eclipse dann bei einem Neustart die Erweiterungen automatisch erkennen, und man kann sie verwenden.

Manuelle Installation

Bei einer manuellen Installation können Erweiterungen auch über die "Update"-Funktion von Eclipse installiert werden, welches dafür aber einmalig mit Root-Rechten [6] gestartet werden muss, wenn es vorher wie oben nach /opt installiert wurde. Das folgende Beispiel bezieht sich auf das PHP-Plugin für Eclipse, für andere Erweiterungen ist die URL entsprechend anzupassen. URLs zu den jeweiligen Projekt-Aktualisierungsseiten findet man über gängige Suchmaschinen.

Man navigiert nun wie folgt durch das Eclipse-Menü:

  1. "Help → Software Updates → Find/Install"

  2. "Search for new features to install"

  3. "New Remote Site" auswählen und folgende URL eingeben: http://update.phpeclipse.net/update/stable/1.2.x 🇬🇧 (stable)

  4. "Finish" wählen und aus der Liste die Erweiterung aussuchen

  5. "Next"

Hinweis:

Die Installationsroutine verursacht evtl. Probleme, wenn 512 MB RAM oder weniger zur Verfügung stehen.

Nach der Installation einer Erweiterung über die Eclipse-Funktion müssen die Datei- und Verzeichnisrechte in /opt/eclipse (siehe Manuelle Installation) angepasst werden. Die neuen Plugin-Verzeichnisse müssen für jeden Benutzer navigierbar sein, und die Dateien müssen von jedem Benutzer gelesen werden können [5]:

sudo find /opt/eclipse/ -type d -exec chmod o+rx {} \;
sudo find /opt/eclipse/ -type f -exec chmod o+r {} \; 

Aptana

Aptana 🇬🇧 ist eine Erweiterung für Webentwicklung mit Eclipse. Aptana assistiert beim Erstellen des Quellcodes und kann PHP, HTML und Javascript.

Installation

Aptana kann als Eclipse-Plugin installiert werden, indem der Downloadserver

http://www.aptana.com/downloads/start#

zu den Eclipse-Quellen hinzugefügt wird. Dazu muss unter "Hilfe → Neue Software installieren" der Downloadserver

http://download.aptana.com/studio3/plugin/install

hinzugefügt werden. Danach kann durch Auswählen der Checkbox Aptana3 installiert werden.

CDT

CDT 🇬🇧 ist eine Erweiterung für die C/C++ Entwicklung. Es gibt vier Möglichkeiten, CDT zu installieren.

Installation

CDT kann aus den Ubuntu-Quellen installiert [1] werden.

  • eclipse

  • eclipse-cdt (universe)

  • g++

Paketliste zum Kopieren:

sudo apt-get install eclipse eclipse-cdt g++ 

Oder mit apturl die Pakete installieren. Link: apt://eclipse,eclipse-cdt,g++

Profiles for Eclipse

Man ruft die Seite http://profiles.yatta.de/epp.package.cpp auf und installiert sich das C++ Profil über den Install Button. Alternativ benutzt man ein Profil aus der C++ Community: http://profiles.yatta.de/AA0U

Manuell

Man lädt sich das aktuelle Komplett-CDT-Paket herunter und speichert es auf dem Rechner. http://download.eclipse.org/tools/cdt/builds/

  • Eclipse starten und folgenden Punkt wählen: "Help → Install New Software → Add"

  • Als Name "CDT" eintragen, dann "Archive" linke Maustaste-klicken und die heruntergeladene Datei auswählen.

Oder man lässt Eclipse nur die nötigen Teile herunterladen:

  • Eclipse starten und folgenden Punkt wählen: "Help → Install New Software → Add"

  • Als Name "CDT" und als Ort http://download.eclipse.org/tools/cdt/releases/galileo (nur für Eclipse 3.5) eintragen und auf "OK" linke Maustaste-klicken

In beiden Fällen geht es wie folgt weiter:

  • Mindestens folgende Teile wählen: "Eclipse C/C++ Development Tools" aus "CDT Main Features" und "CDT GNU Toolchain Build Support", "CDT GNU Toolchain Debug Support", "CDT Utilities" und "Eclipse C/C++ Development Platform" aus "CDT Optional Features"

  • Auf "weiter" linke Maustaste-klicken, die Lizenz akzeptieren und zu guter Letzt Eclipse neu starten.

Eine Anleitung mit Bildern findet sich bei: max.berger.name 🇬🇧

Eclipse Update Manager

Die folgende Pakete müssen installiert [1] sein:

  • eclipse

  • g++

Paketliste zum Kopieren:

sudo apt-get install eclipse g++ 

Oder mit apturl die Pakete installieren. Link: apt://eclipse,g++

Danach wird Eclipse gestartet. Dort wird in "Window → Preferences" das Untermenü "Install/Update → Available Software" aufgerufen. Hier werden dann neue Softwarequellen eintragen, per linke Maustaste-Klick "Add..." aufrufen und folgende Quelle eintragen, der Name ist frei wählbar.

http://download.eclipse.org/tools/cdt/releases/mars

Das Popup-Fenster wird geschlossen und in "Help → Install New Software..." bei "work with:" die soeben hinzugefügte Quelle ausgewählt. Nun kann "CDT Main Features" ausgewählt und durch Drücken auf "next" die Installation erfolgen.

PDT

PDT 🇬🇧 ist eine Erweiterung für die PHP-Entwicklung.

Die Erweiterung kann über die interne Installation über "Help → Install New Software..." installiert werden.

phpeclipse

Für Entwickler der Sprache PHP gibt es noch die Erweiterung phpeclipse 🇬🇧, die mit dem optionalen Debugger DBG 🇬🇧 zusammenarbeitet.

Hinweis:

Falls es dabei regelmäßig zu Programmabstürzen kommt, sollte Eclipse direkt über die .jar-Datei gestartet werden.

java -jar /usr/lib/eclipse/startup.jar 

ecletex/texlipse

ecletex 🇬🇧 und texlipse 🇬🇧 sind Erweiterungen für die Arbeit mit LaTeX. Sie erweitern die Funktionalität des Editors um die Fähigkeit, LaTeX-Dateien zu bearbeiten. Die jeweilige Erweiterung gibt es auf der verlinkten Homepage.

PyDev

Für alle Python-Programmierer ist PyDev 🇬🇧 die Erweiterung für Eclipse. PyDev ist leider nicht mehr in den Ubuntu-Quellen enthalten. Es kann aber über Eclipse-Pluginverwaltung installiert werden.

Dazu öffnet man "Help → Install New Software ..." und klickt auf "Add ...". Dann trägt man unter "Name" etwa PyDev ein und gibt als "Location" http://pydev.org/updates ein. Schließt man nun das Fenster, werden die verfügbaren Erweiterungen angezeigt, und PyDev kann installiert werden.

Subclipse

Mit Hilfe von Subclipse 🇬🇧 kann man direkt Subversion-Quellen in Eclipse nutzen.

Das Paket eclipse-subclipse lässt sich aus den offiziellen Paketquellen installieren, was u. a. Probleme mit Abhängigkeiten und Konfiguration erspart.

  • eclipse-subclipse (universe)

Paketliste zum Kopieren:

sudo apt-get install eclipse-subclipse 

Oder mit apturl die Pakete installieren. Link: apt://eclipse-subclipse

Hinweis:

Sollte Subclipse im Menüpunkt "Preferences" mit einem Fehler starten, müssen die benötigten Bibliotheken von Hand installiert und ins Eclipse-Verzeichnis kopiert werden.

Das Paket

  • libsvn-java

Paketliste zum Kopieren:

sudo apt-get install libsvn-java 

Oder mit apturl die Pakete installieren. Link: apt://libsvn-java

installieren. Dann libsvnjavah-1.so kopieren:

sudo cp /usr/lib/i386-linux-gnu/jni/libsvnjavahl-1.so [Eclipse-Verzeichnis]/jre/lib/i386/libsvnjavahl-1.so
# oder
sudo cp /usr/lib/jni/libsvnjavahl-1.so [Eclipse-Verzeichnis]/jre/lib/i386/libsvnjavahl-1.so  

Hinweis:

Auf 64-bit-Systemen mit installierten 64-bit-svn-Laufzeitbibliotheken ("libraries") ist der Pfad anzupassen; es kann auch einer der Default-JavaLib-Pfade wie /usr/java/packages/lib/amd64 verwendet werden (muss evtl. noch erstellt werden). Aus Java heraus kann man sich die aktuell verwendeten Pfade ausgeben lassen per System.out.println(System.getProperty("java.library.path"));.

Sollte die Fehlermeldung "Unable to load default SVN Client" auftauchen, muss sichergestellt werden, dass das Paket libsvn-java installiert ist, und gegebenenfalls muss noch die eclipse.ini angepasst werden.

Folgende Zeilen bei Bedarf in der eclipse.ini hinzufügen, falls obige Fehlermeldung auftaucht:

1
2
   -Djava.library.path=/usr/share/java/
   -Djava.library.path=/usr/lib/jni/

Povclipse

Mit Hilfe von Povclipse 🇬🇧 kann man POVray-Dateien in Eclipse komfortabel bearbeiten.

Java-Versionen

Java VM für Eclipse

Eclipse selbst ist in Java programmiert und benötigt deshalb eine Virtuelle Java-Maschine (JVM = "java virtual machine"). Standardmäßig startet Eclipse mit dem GIJ 🇬🇧. Wer zum Beispiel Suns JDK installiert hat, möchte vielleicht auch lieber, dass Eclipse auf Suns virtueller Maschine läuft. Um dies zu erreichen, gibt es folgende Möglichkeiten:

  • Dediziertes Setzen der zu verwendenden Java-VM über die "eclipse.ini"-Datei, wie im Eclipse-Wiki beschrieben. 🇬🇧

  • Beim Aufruf von Eclipse die JVM als Parameter übergeben, Beispiel:

    /usr/bin/eclipse -vm /usr/lib/jvm/java-1.5.0-sun-1.5.0.06/bin/java 
  • Die Datei /etc/eclipse/java_home ändern [3]. In der Datei ist eine Liste der kompatiblen VMs und es wird die erste genommen, die auch auf dem System vorhanden ist. Es reicht also, einfach die Reihenfolge zu ändern, so dass die favorisierte VM oben steht. Für Sun Java 6 kann z.B. der Eintrag /usr/lib/jvm/java-6-sun hinzugefügt werden.

Java Runtime Environment (JRE) für Projekte

Aus Eclipse gestartete Programme verwenden standardmäßig GIJ mit den GNU-Classpath-Bibliotheken. Möchte man stattdessen Sun Java verwenden, muss dies unter "Window → Preferences... → Java → Installed JREs" hinzugefügt werden. Als "JRE home directory" muss "/usr/lib/jvm/java-1.5.0-sun-1.5.0.06" (Version muss angepasst werden) angegeben werden. Außerdem sollten hier unter "JRE system libraries" die benötigten Sun-Java-Bibliotheken eingestellt sein, die unter /usr/lib/jvm/java-1.5.0-sun-1.5.0.06/jre/lib (Version muss angepasst werden) zu finden sind.

Junit4 nutzen

Um Junit4 in Verbindung mit Eclipse zu verwenden, muss man es zuerst installieren [1]:

  • junit4 (universe)

Paketliste zum Kopieren:

sudo apt-get install junit4 

Oder mit apturl die Pakete installieren. Link: apt://junit4

Da Eclipse standardmäßig aber Junit3 verwendet, trägt man Junit4 anschließend in die Liste der zu verwendenden Bibliotheken des jeweiligen Projekts ein:

Rechtsklick auf das Projekt → "Properties" → "Java Build Path" → Reiter "Libraries" → "Add Library" → "JUnit" → "Next" → JUnit library version: "JUnit4" → "Finish"

Anschließend kann man seine Test-Suites mit JUnit4 schreiben und beim ausführen der Tests öffnet sich der JUnit-Reiter mit der Ausgabe der Ergebnisse.

Junit ist in der über die Quellen verfügbare Version nur in der Version 4 enthalten. Muss man Junit 3 nutzen, hilft die manuelle Installation.

Kompatibilität mit Windows

Beim Umzug seiner Eclipseprojekte von Windows auf Ubuntu steht man vor dem Problem, dass sich die Kodierung der Quelltexte ändert und somit z.B. Umlaute nicht mehr korrekt angezeigt werden. Um das zu verhindern, sollte bereits in Eclipse unter Windows die Textkodierung standardmäßig von Cp1252 auf UTF-8 geändert werden, um alle neuen Projekte mit dieser Textkodierung zu erstellen. Dadurch ist eine hundertprozentige Windows-Ubuntu-Kompatibiliät in Eclipse gewährleistet.

Die passende Einstellung findet man in Eclipse über das Eclipsehauptmenü "Window → Preferences" unter "General->Workspace" in der Box "File encoding". Dort stellt man die Textkodierung von Cp1252 auf UTF-8 um.

Hinweis:

Dies funktioniert nur, bevor man ein neues Projekt erstellt. Bereits erstellte Projekte zeigen mit UTF-8 auch unter Windows Umlaute falsch an.

Falls schon Projekte mit der Textkodierung Cp1252 existieren, kann mit "iconv" oder "recode" die Kodierung nachträglich in UTF-8 geändert werden. Der Befehl für "iconv" lautet:

iconv --from-code=WINDOWS-1252 --to-code=UTF8  xxx.java 

Problembehebung

Unter der Ubuntu-Theme "Ambiance" kann es mit unter zu Darstellungsproblemen mit den Tooltipps im Editor kommen. Hierbei ist der Hintergrund schwarz und die Schrift blau. Dieser Fehler liegt in der gtkrc Datei. Um dies zu beheben muss die Datei wie folgt geändert werden.

gtkrc öffnen:

sudo vi /usr/share/themes/Ambiance/gtk-2.0/gtkrc 

Hier müssen die Farbeinstellungen wie folgt geändert werden:

tooltip_fg_color:#000000

tooltip_bg_color:#f5f5c5 Die beiden Einstellungen sind in der gtkrc-Datei in den ersten Zeilen zu finden.

Diese Revision wurde am 26. April 2019 08:24 von ubot erstellt.
Die folgenden Schlagworte wurden dem Artikel zugewiesen: Programmierung, Editor, Java