Bibus

Dieser Artikel wurde für die folgenden Ubuntu-Versionen getestet:

Zum Verständnis dieses Artikels sind folgende Seiten hilfreich:

  1. Installation von Programmen

  2. Bearbeiten von Paketquellen

  3. Ein Terminal öffnen

  4. Programme starten

  5. Einen Editor öffnen

Inhaltsverzeichnis
  1. Installation
  2. Wahl der Datenbank
    1. SQLite-Datenbank erstellen
    2. MySQL-Datenbank erstellen
  3. Bibus starten
  4. Tipps zum Arbeiten mit Bibus
    1. Formatierung
    2. Zitatverweise suchen
    3. Datensatz Import
    4. Löschen von Datensätzen
    5. Sprache einstellen
  5. Bibus und OpenOffice3
  6. Bibus und LibreOffice 3.3
  7. Links

./bibus_logo.png Bibus 🇬🇧 ist eine Software zur Verwaltung von Literatur und arbeitet mit Writer von LibreOffice/OpenOffice.org) zusammen. Darüber hinaus können direkt aus dem Programm Suchanfragen an PubMED 🇬🇧 gesendet werden. Bibus ist insbesondere für wissenschaftliche Arbeiten gut geeignet und speichert seine Literaturdaten in einer SQLite- oder MySQL-Datenbank ab. Zitatverweise können direkt in das Textdokument eingefügt werden, Bibus erstellt, ergänzt und aktualisiert automatisch eine Literaturliste am Ende des Dokuments. Der Stil der Zitate kann flexibel formatiert werden, aktuell sind bereits 20 Zitierrichtlinien verschiedener Zeitschriften (u.a. Nature, PNAS, PLoS, Cell) im Programm vorhanden, einige weitere können über die Bibus-Webseite heruntergeladen werden. Das Programm hat eine deutschsprachige Oberfläche.

Eine Übersicht über weitere Literaturverwaltungsprogramme gibt es im Artikel Literaturverwaltung.

Installation

Das Programm ist in den Paketquellen enthalten, es muss

Paketliste zum Kopieren:

sudo apt-get install bibus bibus-doc-en 

Oder mit apturl die Pakete installieren. Link: apt://bibus,bibus-doc-en

installiert [1] und gestartet werden. [4]

Die Dokumentation ist nach der Installation lokal unter /usr/share/doc/bibus/html/en/index.html zu finden.

Wahl der Datenbank

Bibus kann seine Literaturverweise in einer SQLite - oder einer MySQL-Datenbank speichern. Wird die Software nur lokal verwendet, um eine persönliche Literaturdatenbank zu verwalten, ist die SQLite-Datenbank ausreichend und einfacher einzurichten. Die Verwendung einer MySQL-Datenbank ist für Fälle gedacht, bei denen mehrere Nutzer auf dieselbe Datenbank zugreifen und bietet Grundfunktionen der MySQL-Benutzerverwaltung. Im Folgenden wird die Einrichtung beider Datenbanken beschrieben.

SQLite-Datenbank erstellen

Die Einrichtung der SQLite-Datenbank ist denkbar einfach. Bibus fragt lediglich nach einem Dateinamen, sollte er schon existieren wird die Datei verwendet, in der Annahme es handelt sich um eine Bibusdatenbank. Existiert die Datei nicht, erstellt Bibus eine neue SQLite-Datenbank mit dem angegebenen Nutzernamen. Standardmäßig werden die Datenbanken im Verzeichnis /home/BENUTZERNAME/.bibus/Databases erstellt.

MySQL-Datenbank erstellen

Während die Pakete zur Benutzung der SQLite-Datenbank bei der Installation von Bibus automatisch mit installiert werden, müssen zur Nutzung der MySQL-Datenbank folgende Pakete zusätzlich installiert werden [1]:

Paketliste zum Kopieren:

sudo apt-get install mysql-client  mysql-server  python-mysqldb 

Oder mit apturl die Pakete installieren. Link: ,mysql-server ,python-mysqldb

Die Bibus-Installation stellt ein vorgefertigtes SQL-Skript mysql.sql zur Verfügung, mit dessen Hilfe die benötigte Datenbank eingerichtet werden kann. Zunächst muss über das Terminal [3] ein MySQL-Zugriff mit Root-Rechten erfolgen:

mysql -u root -p 

Man befindet sich nun im MySQL-Kommandozeilen-Modus. Dort soll nun eine neue Datenbank namens LitDatenBank erzeugt werden (der Name ist frei wählbar):

create database LitDatenBank; 

Nun kann die MySQL-Kommandozeile wieder verlassen werden:

exit 

Jetzt wechselt man in das Verzeichnis, welches das SQL-Skript zur Einrichtung der Datenbank enthält:

cd /usr/share/bibus/db_models 

Die SQL-Befehle des Skripts werden folgendermaßen an die Datenbank übergeben:

mysql -u root -p LitDatenBank < mysql.sql 

Nun existiert die vollständig für die Nutzung mit Bibus eingerichtete MySQL-Datenbank "LitDatenBank".

Bibus starten

Beim ersten Start von Bibus [4] wird der sogenannte "Verbindungsassistent" gestartet, bei dem man sich für einen der beiden Datenbankentypen entscheidet und der die Anbindung zum Writer mit Hilfe eines Makros einrichtet.

Bei der Standard-Installation von LibreOffice/OpenOffice.org ist eventuell die Makrosicherheit zu hoch eingestellt und verhindert die Funktion des Makros ohne Benachrichtigung. In einem geöffneten Textdokument kann man im Menü "Extras" den "Optionen..."-Dialog starten und unter "LibreOffice/OpenOffice.org -> Sicherheit" die Makrosicherheit auf "mittel" setzen. Eine englische Schritt-für-Schritt Anleitung findet sich unter First connection wizard 🇬🇧 der SourceForge-Seite.

Wird eine MySQL-Datenbank verwendet, muss man sich beim Start bei der Datenbank anmelden. Im Normalfall merkt sich Bibus die letzte verwendete Verbindung und fragt nur nach dem Passwort des MySQL-Servers. Sollte man mehrere Datenbanken verwenden, kann man sich mit folgenden Einstellungen an eine Datenbank auf dem eigenen Computer verbinden.

Hinweis:

Der Benutzer muss hinreichende Rechte auf die Datenbank "bibus" haben. Dieses sind im Einzelnen die Rechte SELECT, INSERT, DELETE, UPDATE und CREATE TEMPORARY TABLES.

Tipps zum Arbeiten mit Bibus

Die Bibus-Dokumentation ist bereits etwas älter (aus 2009). Im Folgenden werden einige Kurz-Tipps gegeben, um sich schneller zurechtzufinden.

Formatierung

Unter "Zitierrichtlinien" können neue Formatierungen erstellt und bestehende geändert werden. Die Formatierung teilt sich in die Formatierung der Kurzverweise im Text und die der Literaturliste. Unter dem Reiter "Literaturverzeichnis" wird gewählt, ob die Kurzverweise im Text nummeriert oder als Text aus einem der Datenbankfelder erscheinen sollen. Dem entsprechend ergeben sich die Möglichkeiten, die Literaturliste am Ende des Dokuments nach Erscheinen im Text bzw. alphanumerisch zu sortieren. "Formatierung der Felder" und "Sortierung der Felder" beziehen sich auf die Formatierung der Literaturliste am Ende des Dokuments, während "Literaturkurzverweise" sich auf die Verweise im Text bezieht. Die Möglichkeiten, die unter letzterem zur Verfügung stehen, werden von der Auswahl bestimmt, die man unter dem Reiter "Literaturverzeichnis" getroffen hat.

Format von Zitatverweisen im Dokument ändern

Zitatverweise (z.B. "Meier1981"), die über Bibus eingefügt worden sind, werden im OOo-Dokument zunächst als Autorenkurzname angezeigt, der dem Identifier in der Bibus-Datenbank entspricht. D.h. wenn man in der Datenbank eine Literaturangabe mit dem Identifier "Meier1981" speichert, erscheint auch "Meier1981" als Zitatverweis im Text. Dies ist nicht das endgültige Format, in dem das Zitat eingefügt ist, sondern lediglich der Identifier, über den Bibus weiß, welches Zitat an welcher Stellen eingefügt wurde und wie möglicherweise die Reihenfolge der Zitate in der Literaturliste aussehen muss. Das endgültige Format erhält man, indem unter dem Menüeintrag "OpenOffice.org -> Dokument fertigstellen" gewählt wird.

Auf keinen Fall sollte der Identifier der Datenbank geändert werde, um ein bestimmtes Format im Dokument zu erhalten. Dies bewirkt, dass die Referenz, sollte sie bereits vorher eingefügt worden sein, von Bibus nicht mehr erkannt wird. Generell ist davon abzuraten, den Identifier zu ändern, da dieser als "unique key" in der Datenbank dient, auf den Stil des Dokuments jedoch keinen Einfluss hat.

Zitatverweise suchen

Solange die Literaturverweise im Dokument in der Identifierform vorliegen, können sie nicht über die OpenOffice Suche gefunden werden. Sollte man einen Verweis nicht wiederfinden können, kann man über "Openoffice.org -> Dokument fertigstellen" die Verweise in Text umwandeln, der sich mit der Suchfunktion finden lässt.

Datensatz Import

Der Import von "MEDLINE"- sowie "ISI/Web of Knowledge"-Datensätzen ist problemlos über Textdateien oder kopieren und einfügen in ein Textfeld möglich. Der Import von Refer-, RIS- und BibTeX-Datensätzen ist ebenfalls möglich, funktioniert aber nicht immer.

Wenn das Importieren einzelner Referenzen im RIS-Format nicht funktioniert, kann folgender Trick helfen: Öffnen der RIS-Datei mit einem Editor [5] und Einfügen der Zeile

ER  - 

am Ende der Datei. Anschließend die Datei über "Datei -> Importieren -> RIS" im Latin_1-Format importieren.

Löschen von Datensätzen

Bibus ist konsequent als Mehrbenutzersystem angelegt. Ein Löschen von Datensätzen ist nicht vorgesehen, um zu Vermeiden, dass eine von einem anderen Nutzer verwendete Referenz ungültig wird. Wie man trotzdem löschen kann, wird auf der Proojektseite 🇬🇧 beschrieben.

Sprache einstellen

Um das Programm in englischer Sprache zu verwenden, muss die Datei /usr/share/bibus/bibus.cfg editiert [5] werden:

[LANG]
# uncomment to force language
language = en_US

Insbesondere beim Arbeiten mit englischer Literatur sind die Literaturtypen (JOURNAL, INPROCEEDINGS, ...) so intuitiver.

Bibus und OpenOffice3

Seit OpenOffice 3.1.1 und Bibus 1.5.1 harmoniert das Zusammenspiel wieder, KDE-Nutzer sollten bei Absturz der Funktion "Finalize" auf OpenOffice 3.2.0.5-1.1 upgraden. OpenOffice Versionen um 3.0 sollten vermieden werden, da hier die von Bibus benötigte "pyuno-bridge" relativ viele Fehler hatte.

Bibus und LibreOffice 3.3

Bibus 1.5.1 kann ebenso per "Pipe" mit LibreOffice 3.3 zusammenarbeiten wie mit OpenOffice 3.2. Sollte dies nicht funktionieren und beim Einfügen eines Zitates die Fehlermeldung "Verbindung zu OpenOffice.org nicht möglich" erscheinen, können folgende Arbeitsschritte für LibreOffice 3.3 und analog für OpenOffice helfen:

In Bibus ist der Verbindungsassistent unter "Extras->Verbindungsassistent" zu starten. Hier ist "OpenOffice.org Writer" als Textverarbeitung auszuwählen und unter "Erweiterte Einstellungen" sollte "Eine Pipe benutzen" und als Pipe "OOo_pipe" aktiviert sein. Mit "Next" geht es weiter zur Auswahl der "SQLite" Datenbank-Engine. Weiter mit "Next" gelangt man zur Auswahl der SQLite Datenbank, die nötigen Arbeitsschritte sind dort beschrieben. Die Einstellungen werden mit "Finish" abgeschlossen, der Verbindungsassistent schließt sich.

Nun kann LibreOffice gestartet werden. Hier ist es zunächst nötig die Makro-Sicherheit herabzusetzen. Dies ist unter "Extras -> Optionen LibreOffice -> Sicherheit" möglich. Mit dem Button "Makrosicherheit" öffnet man das Einstellungsfenster, wählt hier die Stufe "Mittel" aus und bestätigt mit "OK". Dann kann das Optionen-Fenster mit "OK" geschlossen werden.

Als nächsten Schritt öffnet man den "UnoConnectionListener" von Bibus. Dies ist ein OpenOffice-Draw Dokument, welches sich unter /usr/share/bibus/Setup befindet. Dort ist die Datei UnoConnectionListener.odg mit LibreOffice Draw zu öffnen. Die erscheinende Makro-Sicherheitswarnung ist mit "Makros aktivieren" zu bestätigen. In dem Dokument kann mit dem Button "Get current uno connection status" überprüft werden, ob eine Verbindung zwischen Bibus und LibreOffice aktiviert ist. Ist dies nicht der Fall, dann ist "Use a Pipe" und als Pipe name "OOo_pipe" zu wählen. Die Einstellungen sind mit klicken auf den Button "Accept UNO connections" zu bestätigen und somit die Verbindung zu aktivieren. Ist der Button nicht sichtbar (hier kann ein Anzeige-Fehler vorliegen), kann er durch eine Mouse-Bewegung von "Pipe name" zum Button "Do NOT accept UNO connections" sichtbar gemacht werden.

Danach ist LibreOffice komplett neu zu starten. Es kann das Dokument dann erneut geladen und mit dem Button "Get current uno connection status" überprüft werden ob die Verbindung aktiviert ist. Ist dies der Fall, sollte es nun möglich sein, ein Zitat von Bibus in LibreOffice einzufügen.