Archiv/Nautilus bis 11.04

Archivierte Anleitung

Dieser Artikel wurde archiviert. Das bedeutet, dass er nicht mehr auf Richtigkeit überprüft oder anderweitig gepflegt wird. Der Inhalt wurde für keine aktuell unterstützte Ubuntu-Version getestet. Wenn du Gründe für eine Wiederherstellung siehst, melde dich bitte in der Diskussion zum Artikel. Bis dahin bleibt die Seite für weitere Änderungen gesperrt.


Anmerkung: Dieser Artikel beschreibt die Nautilus-Versionen, die bis einschließlich Ubuntu 11.04 zum Einsatz kamen. Für neuere Ubuntu-Versionen gilt der Artikel Nautilus.

Zum Verständnis dieses Artikels sind folgende Seiten hilfreich:

  1. Installation von Programmen

  2. Bearbeiten von Paketquellen

  3. Einen Editor öffnen

  4. Den Konfigurationseditor starten

  5. Ein Terminal öffnen

Inhaltsverzeichnis
  1. Start
  2. Ansichten
  3. Verknüpfungen mit Programmen
  4. Aussehen der Ordner
  5. Datei-Vorschau
  6. Suchfunktion
  7. Root-Rechte
  8. Kopie einer CD/DVD anfertigen
  9. Entfernte Dateisysteme
  10. Virtuelle Ordner
  11. Dokument anlegen erweitern
  12. Nautilus neu starten
  13. Funktionalität erweitern
  14. Erweiterte Einstellungen
  15. Tastenkürzel
  16. Mausaktionen
  17. Werkzeugleiste anpassen
  18. Chronik/Historie nicht anzeigen
  19. Probleme und Lösungen
  20. Links

./nautilus_logo.png Nautilus 🇬🇧 ist der Dateimanager der Desktop-Umgebung GNOME. Nautilus soll die Handhabung von Dateien leicht machen. Er bietet Voransichten für diverse Dateitypen, kann Webseiten darstellen, auf entfernte Freigaben zugreifen usw. Man bezeichnet Nautilus auch als grafische "Shell", er lässt sich durch zusätzliche Skripte in seinen Funktionen leicht erweitern.

Nautilus wird intern auch zur Verwaltung des Desktop verwendet (siehe auch Desktop-Symbole).

Start

Den Dateimanager startet man bis Ubuntu 10.10, indem man beispielsweise im GNOME Panel auf einen der unter "Orte" aufgeführten Einträge wie beispielsweise "Persönlicher Ordner" auswählt. Dies öffnet dann in diesem Fall Nautilus mit dem eigenen Homeverzeichnis. Wer von Windows gewohnt ist, einen Dateimanager über Windows + E zu starten, der kann für Nautilus eine entsprechende Tastenkombination einrichten.

Ab Ubuntu 11.04 wird Nautilus am einfachsten durch einen Klick auf das Ordner-Symbol ganz oben im Unity Startmenü gestartet.

Ansichten

Ansichtsmodus

Nautilus kennt drei verschiedene Ansichtsmodi:

In jedem der drei Ansichtsmodi lässt sich mit der Tastenkombination Strg + T ein neuer Reiter öffnen, sodass eine Ansicht mit mehreren Reitern entsteht. Mit F9 kann die Seitenleiste ein- und ausgeblendet werden.

Adressleiste anstatt Navigationsknöpfe anzeigen

Zur Adressleiste mit Tastenkombination umschalten

Als Standardeinstellung wird die Adresse in Form von Navigationsknöpfen angezeigt. Wer Adressen lieber direkt eintippen will, schaltet mittels Strg + L zu einem Textfeld um, wo Pfade direkt eingeben werden können. Zur Vervollständigung von Pfaden dient die Tab ⇆ Taste. Mit Esc kommt man wieder zurück zu den Navigationsknöpfen.

./nautilus_locationbar.png
Adressleiste ist eingeschaltet

Adressleiste dauerhaft anzeigen

Mit der Tastenkombination Strg + L kann man erreichen, dass die Adresszeile im Nautilus-Fenster permanent angezeigt wird.

Seitenleiste

./nautilus_seitenleiste.png

Die Seitenleiste lässt sich mit F9 bzw. im Menü "Ansicht → Seitenleiste" aktivieren. Klickt man auf den Button "Ordner", öffnet sich ein Dropdown-Menü, aus dem man alternative Informationsanzeigen wählen kann. Zur Verfügung stehen:

Einträge in Anzeige "Orte" hinzufügen/entfernen

Im oberen Abschnitt

Um hier angezeigte Datenträger aus der Liste zu entfernen, muss man eine udev-Regel erstellen. Dazu wird eine Regeldatei, z.B. 99-partitionen-verstecken.rules genannt, mit einem Editor[3] mit Root-Rechten erstellt und im Ordner /etc/udev/rules.d/ gespeichert.

Mit der eindeutigen Datenträger-Bezeichnung UUID trägt man

ENV{ID_FS_UUID}=="00000000-0000-0000-0000-000000000000", ENV{UDISKS_PRESENTATION_HIDE}="1"

in die Regeldatei ein, wobei "00000000-0000-0000-0000-000000000000" mit der UUID des gewählten, aus der Liste zu entfernenden Datenträgers zu ersetzen ist.

Falls es mit dem UUID-Eintrag nicht funktionieren sollte, kann man auch den Datenträger mit Hilfe seines Gerätenamens aus der Liste entfernen. Dann trägt man statt des obigen Eintrags

KERNEL=="sda1", ENV{UDISKS_PRESENTATION_HIDE}="1" 

ein, wobei hier "sda1" für den Gerätenamen des zu versteckenden Datenträgers steht. Bei mehreren Datenträgern kann man auch statt mehreren Einträgen mit verschiedenen Nummern im Namen ein Fragezeichen an deren Stelle setzen. Näheres dazu findet man im udev-Artikel.

Bei beiden Arten steht ENV{UDISKS_PRESENTATION_HIDE}="1" dafür, dass der jeweilige Datenträger versteckt wird. Nun muss noch im Terminal [4] der Befehl

sudo udevadm trigger 

ausgeführt werden, um die neuen Einstellungen zu erkennen und die Datenträger sollten aus der Liste verschwunden sein. Andernfalls treten sie erst beim Neustart in Kraft.

Im unteren Abschnitt

Hier werden die Lesezeichen angezeigt.

Lesezeichen

Um ein Lesezeichen hinzuzufügen, gibt es verschiedene Möglichkeiten:

Ab sofort ist der Eintrag als Lesezeichen dort schnell anwählbar und nun auch u.a. im Dateiauswahl-Dialog der Anwendungen erreichbar.

Unter "Orte" sind bereits ein paar Ordner zu finden, nämlich "Dokumente, Bilder, Musik, Videos". Ein Lesezeichen wird in Nautilus entfernt entweder

erstellt. Die Lesezeicheneinträge werden in der versteckten Datei .gtk-bookmarks im Homeverzeichnis gespeichert.

Verknüpfungen mit Programmen

Nautilus öffnet bekannte Dateitypen (z.B. .pdf, .avi oder .png) immer mit einem bestimmten Programm. Diese Verknüpfung kann man auch innerhalb von Nautilus ändern. Üblicherweise verknüpft Nautilus Dateitypen mit den GNOME-eigenen Programmen wie Evince, Totem usw. Möchte man eine Datei mit einem anderen Programm öffnen, so kann dies einmalig erfolgen oder die Verknüpfung permanent geändert werden.

Einmalig

./oeffnenmit_temp.png

Jedes installierte Programm übermittelt dem System, mit welchen Dateitypen es arbeiten möchte. Möchte man ein Dateityp nur einmalig mit einer anderen Anwendung öffnen als die üblicherweise verknüpfte Anwendung, so klickt man mit der rechten Maustaste auf die Datei und findet unter "Öffnen mit" alle Programme, die mit diesem Dateityp etwas anfangen können.

Sollte man die Datei mit einem ganz anderen Programm öffnen wollen, so findet man am Ende der Liste den Eintrag "Mit anderer Anwendung öffnen..." Wählt man diesen aus, so bekommt man eine Liste aller Anwendungen des Systems. So kann man eine Datei mit einer beliebigen Anwendung starten. Alternativ lassen sich über "Benutzerdefinierten Befehl benutzen" spezielle Start-Befehle und -Optionen festlegen.

Permanent

./oeffnenmit_permanent.png

Um einen Dateityp permanent mit einer bestimmten Anwendung zu öffnen, muss man einen etwas anderen Weg gehen.

Wählt man nun eine Datei des Typs .png aus (durch einfachen Klick bzw. Doppelklick, je nach Einstellung von Nautilus), wird diese ab sofort mit dem eingestellten Programm geöffnet.

Aussehen der Ordner

Man kann das Aussehen der einzelnen Ordner individuell gestalten. Zum Beispiel könnte der Dokumente-Ordner grün gefärbt sein und der Downloads-Ordner eine Weltkugel als Hintergrund haben.

Datei-Vorschau

Nautilus erstellt für verschiedene Datei-Typen eine Vorschau.

Vorschau für Videodateien wiederherstellen

Falls der Mediaplayer Totem deinstalliert wurde, zeigt Nautilus keine Thumbnails von Videodateien mehr an. Nachdem das Paket

Paketliste zum Kopieren:

sudo apt-get install totem 

Oder mit apturl die Pakete installieren. Link: apt://totem

wieder installiert [1] wurde, erzeugt Nautilus spätestens nach dem nächsten Neustart wieder Vorschaubilder. Erweiterte Einstellungen - wie alle Vorschaubilder ausschalten - kann man über den Konfigurationseditor [4] unter "/desktop/gnome/thumbnailers" vornehmen. Wichtig ist auch, dass die nötigen Codecs installiert sind.

nautilusaudiovorschau.png

Audio-Vorschau aktivieren

Nautilus kann Audiodateien abspielen, wenn der Mauszeiger in der Symbolansicht über eine Audiodatei schwebt oder eine Datei über die Cursortasten der Tastatur ausgewählt wurde. Nach einem kurzen Moment wird die Audio-Vorschau automatisch aktiv. In der Listenansicht ist diese Funktionalität nicht vorhanden. Unter "Bearbeiten -> Einstellungen -> Vorschau" kann man die Vorschau für Audio-Dateien bei Bedarf auch deaktivieren.

Lautstärke der Audio-Vorschau einstellen

Um die Lautstärke der Audio-Vorschau zu verändern, startet man zuerst Nautilus und dann die Audio-Einstellungen und navigiert dort zum Reiter "Anwendungen". Jetzt legt man den Mauszeiger auf eine Audiodatei und navigiert mit der Tab ⇆ Taste zum Lautstärkeregler der Audio-Vorschau. Nun kann man mit den Tasten oder die Lautstärke der Audio-Vorschau verändern.

Vorschau von OpenDocument-Dateien

Nautilus kann mit Hilfe von OpenDocument Thumbnails auch Thumbnails von OpenOffice-Dokumenten anzeigen.

Vorschau von svgz-Dateien

Nautilus kann mit Hilfe von svgz Thumbnails auch Thumbnails von .svgz-Dokumenten anzeigen.

Vorschau von Raw-Dateien (Fotografie)

Das Aktivieren der Vorschau für verschiedene RAW-Dateiformate (CRW, NEF, RAW, etc.) wird im Artikel RAW-Fotografie (Abschnitt „Nautilus-zeigt-keine-Vorschaubilder-an“) beschrieben.

Suchfunktion

Nautilus bietet die Möglichkeit, Suchen zu speichern. Diese gespeicherten Suchen erscheinen wie ein Ordner, dessen Inhalt beim Aufrufen jeweils neu berechnet wird. Ist Archiv/Beagle oder Tracker installiert, bedient sich Nautilus dessen Suchtechnik, so dass auch der Inhalt von Dokumenten durchsucht wird und die stets aktuellen Suchergebnisse deutlich schneller zur Verfügung stehen.

Root-Rechte

./nautilus_gksu.png Nicht ohne Grund arbeitet man unter Linux selten mit Root-Rechten. Ganz besonders mit einer graphischen Oberfläche besteht das Risiko, Fehler zu machen, oder dass eine Schwachstelle in einer Software Sicherheitslecks aufreißt! Trotzdem ist es manchmal einfacher, einen Dateimanager mit vollen Rechten zur Hand zu haben. Dazu startet man Nautilus kurzerhand aus einem Terminal oder über Alt + F2 mittels des Befehls gksudo nautilus. Nach der Eingabe des Passwortes öffnet sich ein Nautilus-Fenster mit Root-Rechten. Alternativ kann das Paket

Paketliste zum Kopieren:

sudo apt-get install nautilus-gksu 

Oder mit apturl die Pakete installieren. Link: apt://nautilus-gksu

installiert [1] werden. Nach der Installation des Paketes und einem Neustart von Nautilus erscheint im Kontextmenü einer Datei die neue Option "Als Administrator öffnen".

Kopie einer CD/DVD anfertigen

Nautilus gestattet es, Kopien von einer CD/DVD anzufertigen. Das Vorgehen ist in CD-Images (Abschnitt „GNOME-Ubuntu-Brasero“) und Video-DVD kopieren (Abschnitt „Nautilus“) beschrieben.

Entfernte Dateisysteme

Nautilus kann auch mit Dateien auf entfernten Computern umgehen. Diese Dateien werden wie lokale Dateien in einem Ordner dargestellt. Dazu öffnet man in Nautilus die Adresszeile und verwendet die folgenden Angaben. Wie man erkennen kann, ist es möglich, gleich Zugangsdaten und Pfade entfernter Dateisysteme mit anzugeben.

nautilusentferntedateisysteme.png

Entfernte Dateisysteme
Protokoll Beispiel Beschreibung
Samba smb://rechnername/freigabe Samba ist das Linux-Pendant zur Windows-Dateifreigabe. Über Samba kann man auf Freigaben anderen Windows- und Linuxrechner zugreifen.
FTP ftp://192.168.0.1 FTP ist ein beliebtes Protokoll, um Dateien zu transferieren, üblicherweise bekommt man die Möglichkeit, per FTP Dateien auf einem Webserver abzulegen.
WebDAV dav://login@example.com/ordner WebDAV ist ein Protokoll, um Dateien über das Internet bereitzustellen. Beispiele hierfür sind Apples iDisk und das GMX Mediacenter, was allerdings mit Nautilus aufgrund eines Bugs seitens GMX nicht funktioniert.
WebDAV davs://login:passwort@example.com Identisch zu "dav://" allerdings wird die Verbindung verschlüsselt.
SSH ssh://benutzer@server:port/pfad/ordner Die Angabe der Portnummer ist nur erforderlich, wenn dieser vom Standardport 22 abweicht. SSH File-Transfer-Protokoll zur sicheren und unkomplizierten Datenübertragung zwischen Linux/Unix-Systemen.
SFTP sftp://benutzer:passwort@server:port Identisch zu "ssh://"

Alle im System per Nautilus eingehängten Dateisysteme werden als ~/.gvfs/DATEISYSTEMBEZEICHNUNG abgebildet. Dies ist z.B. für Programme interessant, auf die eingehängten Dateisysteme nicht direkt zugreifen können. Da manche Programme mit versteckten Ordnern ebenfalls nicht klarkommen, kann es hilfreich sein, zusätzlich eine Verknüpfung anzulegen:

ln -s ~/.gvfs ~/BELIEBIGER_ORDNERNAME 

Virtuelle Ordner

Nautilus kann bestimmte Verzeichnisse und Dateien zusammenfassen und als virtuelle Ordner darstellen. Diese lassen sich über folgende Adressen direkt aufrufen:

Virtuelle Ordner
Ordner Beschreibung
burn:/// Die Daten, welche für das Brennen auf CD/DVD vorgemerkt sind
network:/// Zeigt die Netzwerkumgebung an
trash:/// Der Mülleimer
computer:/// Übersicht der eingehängten Dateisysteme

Dokument anlegen erweitern

Nautilus bietet eine Funktion, um im geöffneten Ordner eine Datei anzulegen. Diese erreicht man über "Datei -> Dokument anlegen" oder "rechte Maustaste-Klick -> Dokument anlegen". Standardmäßig wird hier nur der Eintrag "Leere Datei" angeboten, mit dem man ein leeres Textdokument erstellen kann.

Um weitere Vorlagen zur Verfügung zu haben, kann man beliebige Dateien in den Ordner Templates (in der englischen Ubuntu-Version) bzw. Vorlagen (in der deutschen Ubuntu-Version) im Homeverzeichnis ablegen.

Falls dieser Ordner noch nicht existiert, muss man ihn erstellen und Nautilus sagen, wo sich der Vorlagen-Ordner befindet. Dafür muss man die Datei ~/.config/user-dirs.dirs in einem Editor[3] öffnen und anschließend die folgende Zeile von:

XDG_TEMPLATES_DIR="$HOME/"

ändern in:

XDG_TEMPLATES_DIR="$HOME/Vorlagen"

Damit die Einstellung des neuen Vorlagen-Ordners in Nautilus übernommen wird, muss Nautilus neu gestartet werden.

In diesen Ordner können dann z.B. OpenOffice-Dateien abgelegt werden, welche als Vorlagen dienen. Auch für Quelltexte ist dies nützlich: So kann man beispielsweise LaTeX-Dateien, die für verschiedene Zwecke ein Grundgerüst enthalten, dort ablegen.

Nautilus neu starten

Manche Einstellungen sowie neu installierte Erweiterungen sind erst nach einem Neustart von Nautilus verfügbar. Da Nautilus als Hintergrundprozess läuft, reicht es nicht, alle offenen Fenster von Nautilus zu schließen. Ein kompletter Neustart des Systems oder Ab- und Anmelden erreichen das Gewünschte, es gibt aber auch einen schnelleren Weg über folgende Eingabe im Terminal:

nautilus --quit 

Gleichwertig ist

nautilus -q 

Achtung!

Das beendet Nautilus komplett und führt dazu, dass alle Dateimanager-Fenster geschlossen werden. Man sollte also nicht gerade nebenbei zum Beispiel irgendwelche Kopieroperationen am Laufen haben!

Neu gestartet wird Nautilus meist automatisch. Sollte dies nicht der Fall sein, kann Nautilus über die Eingabe nautilus im Terminal wieder aufgerufen werden.

Funktionalität erweitern

Nautilus ermöglicht die Verwendung von Skripten als Erweiterung im Kontextmenü. Diese Skripte sind einfache ausführbare Dateien. Die Skripte müssen im Verzeichnis ~/.gnome2/nautilus-scripts/ gespeichert werden.

Nautilus-Terminal

Nautilus-Terminal integriert ein Terminal in Nautilus. Das integrierte Terminal wechselt durch Verwendung von cd immer in das gleiche Verzeichnis, in dem man sich mit Nautilus selbst befindet, somit ist es möglich, im entsprechenden Verzeichnis beliebige Befehle ausführen.

./nautilus-terminal.png

Für die Erweiterung steht ein PPA zur Verfügung:

Adresszeile zum Hinzufügen des PPAs:

Hinweis!

Zusätzliche Fremdquellen können das System gefährden.


Ein PPA unterstützt nicht zwangsläufig alle Ubuntu-Versionen. Weitere Informationen sind der Wiki/Vorlagen/PPA/ppa.png PPA-Beschreibung des Eigentümers/Teams flozz zu entnehmen.

Damit Pakete aus dem PPA genutzt werden können, müssen die Paketquellen neu eingelesen werden.

Nach dem Aktualisieren der Paketquellen kann das folgende Paket installiert werden:

Paketliste zum Kopieren:

sudo apt-get install nautilus-terminal 

Oder mit apturl die Pakete installieren. Link: apt://nautilus-terminal

Weitere Erweiterungen

Weitere Erweiterungen sind:

Damit die installierten Erweiterungen verfügbar sind, muss Nautilus neu gestartet werden.

Erweiterte Einstellungen

Neben den Einstellungen im Menü unter "Bearbeiten -> Einstellungen" kann vieles auch mit dem Konfigurationseditor [4] unterhalb "/apps/nautilus" eingestellt werden. Manche Optionen sind nur so erreichbar.

Zugriffsrechte-Dialog

Im Dialog für die Einstellung der Zugriffsrechte (zu erreichen über die Eigenschaften einer Datei/eines Verzeichnisses ) kann anstelle der DropDown-Boxen eine Matrix mit CheckBoxen dargestellt werden, in der sich die Zugriffsrechte für Lesen, Schreiben und Ausführen einzeln für jede Benutzergruppe einstellen lassen (besonders interessant für jemanden, der mit der 3fachen "rwx"-Schreibweise vertraut ist). Hierzu muss man den Konfigurationseditor [4] starten und /apps/nautilus/preferences/show_advanced_permissions auf true setzen.

Dateien und Verzeichnisse verstecken

Möchte man einige Dateien oder Ordner permanent verstecken, so ist (in dem jeweiligen Verzeichnis, in dem sich die zu versteckenden Einträge befinden) eine Datei .hidden zu erstellen [3], in der die gewünschten Dateien und Verzeichnisse aufgelistet werden.

Datei1
Verzeichnis1
Datei2

Tastenkürzel

Tastenkürzel
Kürzel Bedeutung
Strg + L Adresszeile anzeigen ( Esc schaltet wieder zurück)
Strg + H Versteckte Dateien anzeigen
Strg + W Schließt den Eltern-Ordner (in der Einzel-Ansicht)
Strg + + W Schließt alle Ordner, außer den aktuellen (in der Einzel-Ansicht)
Strg + 1 Symbol-Ansicht
Strg + 2 Listen-Ansicht
Strg + + Voransicht vergrößern
Strg + - Voransicht verkleinern
Strg + 0 Voreingestellte Größe anzeigen
F9 Öffnet oder schließt die Seitenleiste
Entf Verschiebt eine Datei/Verzeichnis in den Müll
+ Entf Löscht eine Datei/Verzeichnis sofort (und verschiebt sie nicht in den Müll)
+ Strg + N Neues Verzeichnis anlegen
Strg + M Verknüpfung erzeugen
Strg + A alle Dateien auswählen
Strg + S Nach Suchmuster auswählen
F2 Ausgewählte Datei/Verzeichnis umbenennen
F5 aktuelle Ansicht neu laden (refresh)
Strg + T Neuen Reiter öffnen
Strg + W Aktuellen Reiter schließen, wenn nur ein Reiter vorhanden ist, wird das komplette Nautilus-Fenster geschlossen
Tab ⇆ Wechselt den Fokus zwischen Dateibereich, Dateipfad und Seitenleiste
Alt + Einen Schritt zurück in der Historie
Alt + Einen Schritt vor in der Historie
Alt + oder Öffnet den übergeordneten Ordner
Alt + oder Öffnet den ausgewählten Ordner

Mausaktionen

./Nautilus_mittlere_Maustaste.png

Mausaktionen
Aktion Wirkung
linke Maustaste + Strg Dateien immer kopieren
linke Maustaste + Dateien immer verschieben
linke Maustaste Strg + Verknüpfung erstellen
linke Maustaste + Alt oder mittlere Maustaste Nach einer Aktion (Kopieren, Verschieben, Verlinken) gefragt werden

Werkzeugleiste anpassen

Möchte man bestimmte Icons/Funktion in der Werkzeugleiste nicht mehr angezeigt bekommen, so muss man die entsprechende Funktion in einer XML-Datei kommentieren oder löschen. Diese befindet sich unter /usr/share/nautilus/ui/nautilus-navigation-window-ui.xml und muss mit Root-Rechten editiert werden.

Dort findet man unten unter

<toolbar name="Toolbar">

die entsprechenden Einträge, z.B. für "Zurück" die Zeile

<toolitem name="Back" action="Back"/>

welche, wenn man den Eintrag für "Zurück" in der Werkzeugleiste nicht mehr sehen möchte, kommentiert werden muss.

Chronik/Historie nicht anzeigen

Über "Gehe zu" zeigt Nautilus zehn der zuletzt geöffneten Ordner an. Aus Gründen der Privatsphäre lässt sich dies abschalten, indem man die GUI-Einstellungen bearbeitet. Zuerst legt man ein Backup der Datei an:

sudo cp /usr/share/nautilus/ui/nautilus-navigation-window-ui.xml /usr/share/nautilus/ui/nautilus-navigation-window-ui.xml.bak 

Dann öffnet man die Datei /usr/share/nautilus/ui/nautilus-navigation-window-ui.xml in einem Editor mit Root-Rechten, löscht die folgenden vier Zeilen

<separator/>
<menuitem name="Clear History" action="Clear History"/>
<separator/>
<placeholder name="History Placeholder"/>

und startet Nautilus neu. Ein Aus- und wieder Einloggen des Benutzers oder Neustart des Systems bewirken das Gleiche.

Achtung: Zuletzt geöffnete Ordner werden weiterhin gespeichert, nur nicht mehr angezeigt.

Probleme und Lösungen

Persönliche Orte öffnen sich nicht mit Nautilus

Teilweise kommt es vor, dass der Aufruf von "Orte -> Persönliche Orte" im GNOME-Menü Rhythmbox (oder VLC, Archiv/F-Spot, Shotwell oder ein weiteres, bisher nicht genanntes Programm) statt Nautilus öffnet. Die naheliegendste Lösung, mit Nautilus selbst – rechte Maustaste und dann "Öffnen mit" – wurde mit Ubuntu 9.04 entfernt (366963 🇬🇧). Das Problem muss daher folgendermaßen behoben werden:

Nautilus wechselt auf einmal die Sprache

Durch die Anzeige der Eigenschaften eines Ordners oder einer Datei kann es passieren, dass sich die Sprache von Nautilus ändert. Dies wird durch Erweiterungen für Nautilus wie etwa "rabbitvcs-nautilus" verursacht. Temporär lässt sich die Ausgangssprache dadurch wiederherstellen, dass Nautilus über

sudo killall nautilus 

geschlossen und anschließend neu gestartet wird. Um das Problem dauerhaft zu vermeiden, muss die Erweiterung, die die Sprachverwirrung erzeugt, deinstalliert werden.

Meldung "*-Orte können nicht verwendet werden"

Sollte diese Meldung beim Aufrufen von "Netzwerk" oder beim Einbinden eines entfernten Datei-Systems über ftp, sftp etc. erscheinen, dann kann die (Neu-)Installation des Pakets gvfs-backends Abhilfe schaffen.

Partitionen doppelt angezeigt

Wenn Partitionen über die Datei /etc/fstab per UUID eingebunden werden, kann es vorkommen, dass sie von Nautilus doppelt angezeigt werden. Dies kann man leicht verhindern, ohne auf den Komfort der UUIDs verzichten zu müssen. Anstatt die Partitionen wie bisher so einzubinden:

UUID=UUID_DER_PARTITION /media/EINHÄNGEPUNKT     ext4 defaults  0  2

schreibt man Folgendes in die Datei /etc/fstab:

/dev/disk/by-uuid/UUID_DER_PARTITION /media/EINHÄNGEPUNKT     ext4 defaults  0  2

Link zum Thema im Forum

Partitionen vor Nautilus verstecken

Möchte man ungenutzte Partitionen in Nautilus nicht anzeigen, kann man in der fstab die Partition mit dem Parameter noauto eintragen. Das System hängt die Partition also nicht automatisch ein und Nautilus zeigt die Partition auch nicht mehr an. Dazu ein Verzeichnis erstellen, an der die Partition eingehängt würde, z.B. mit:

mkdir -p /mnt/unused/partition1 

und in der fstab die entsprechende Partition mit dem noauto-flag versehen.

UUID=UUID_DER_PARTITION  /mnt/unused/partition1          ext4    defaults,noauto           0       2

Ubuntu öffnet beim Start viele "Starte File Manager"

Siehe Forendiskussion.

XFCE und Nautilus

Nautilus lässt sich problemlos unter Xfce / Xubuntu verwenden. Da Nautilus standardmäßig den Desktop verwaltet, kommt es unter XFCE zu Problemen bei der Anzeige desselben. Man kann Nautilus aber mit einer Option starten, die dies vermeidet:

nautilus --no-desktop 

Um nicht jedes Mal den kompletten Befehl angeben zu müssen empfiehlt es sich unter XFCE einen Alias anzulegen. Dazu öffnet man die Datei ~/.bashrc und fügt nach der Zeile # some more aliases Folgendes ein:

1
alias nautilus = 'nautilus --no-desktop'