Archiv/Duden-Bibliothek

Archivierte Anleitung

Dieser Artikel wurde archiviert. Das bedeutet, dass er nicht mehr auf Richtigkeit überprüft oder anderweitig gepflegt wird. Der Inhalt wurde für keine aktuell unterstützte Ubuntu-Version getestet. Wenn du Gründe für eine Wiederherstellung siehst, melde dich bitte in der Diskussion zum Artikel. Bis dahin bleibt die Seite für weitere Änderungen gesperrt.

Zum Verständnis dieses Artikels sind folgende Seiten hilfreich:

  1. Ein einzelnes Paket installieren

  2. Ein Programm ohne Menüeintrag starten

  3. Einen Editor öffnen

Inhaltsverzeichnis
  1. Installation
    1. Bedienung
      1. Buch installieren
      2. Buch deinstallieren
      3. Benutzerwörterbuch
    2. Konfiguration
      1. GNOME
    3. Problemlösungen
      1. Stichwortsuche
  2. Duden Korrektor
    1. Installation
      1. Vorbereitung
      2. Installation der Duden-Rechtschreibprü...
      3. Nachbereitung
  3. Handbücher
  4. Links

DUDEN - Die Rechtschreibprüfung

./officebib_64x64.png
Genre::Bildung
Sprache::🇩🇪
Veröffentlichung::2012 (Korrektor 8.0)
Publisher::Bibliographisches Institut GmbH
Systemvoraussetzungen::-
Medien::DVD (1)
Strichcode / EAN / GTIN::9783411112845
Läuft mit::nativ
Installation:deb-Paket zum Download

logo.png Die Duden-Bibliothek (ehem. Office-Bibliothek) ist ein plattformübergreifendes Programm, das vielen elektronischen Nachschlagewerken (u.a. Brockhaus, Duden, Langenscheid und Meyer) zugrunde liegt. Es kann verschiedene digitale Nachschlagewerke anzeigen.

Die Software an sich ist Freeware, die einzelnen Wörterbücher müssen käuflich erworben werden.

Duden-Bibliothek.jpg Buch.jpg
Duden-Bibliothek Neues Buch installieren

Installation

Die aktualisierte Software der Duden-Bibliothek wird auf der Herstellerseite zum Download 🇩🇪 ⮷ angeboten. Das .deb-Paket herunterladen und installieren [1].

Hinweis!

Fremdpakete können das System gefährden.

Nach der Installation findet man den Eintrag im Menü unter "Anwendungen -> Sonstiges -> Duden-Bibliothek". Alternativ kann es über den Befehl dudenbib gestartet [2] werden.

Bedienung

Im Folgenden werden lediglich einige Grundfunktionen zur Bedienung und Konfiguration aufgezeigt.

Buch installieren

Im Programmfenster die Schaltfläche "Buch installieren" anwählen und im sich öffnenden Fenster über "Durchsuchen…" die Installationsdatei pc_bib.inf oder pc-bib.inf auf dem Medium auswählen und über "Weiter" fortfahren. Nachdem man über "Annehmen" den Lizenzvereinbarungen zugestimmt hat wird das Produkt auf dem Computer installiert.

Hinweis:

Die Schreibweise der Installationsdatei kann variieren.

Buch deinstallieren

Um ein Lexikon aus dem Bestand zu entfernen startet man über "Datei -> Buch entfernen..." den entsprechenden Dialog. Durch einen linke Maustaste Linksklick das Produkt auswählen und mit "Entfernen" wird es aus der Liste gelöscht. Sollen mehrere Bücher entfernt werden arbeitet man zusätzlich noch mit Strg .

Benutzerwörterbuch

Mit dem Programm können Benutzerwörterbücher angelegt und mit der Import-/Exportfunktion ausgetauscht werden. Ein Wörterbuch legt man unter "Datei -> Neu... -> Benutzerwörterbuch..." an. Nach Vergabe des Titels wird dies unter den installierten Büchern angezeigt. Mit "Datei -> Neu... -> Eintrag..." kann dies mit Informationen gefüttert werden.

Mit "Datei -> Exportieren... -> Benutzerwörterbuch" bzw. "Datei -> Importieren... -> Benutzerwörterbuch" können die Daten verteilt werden z.B. für ein Linux-Lexikon.

Einstellungen.jpg
Einstellungen

Konfiguration

Über "Bibliothek -> Einstellungen..." gelangt man zum Einstellungsmenü. Hier können neben allgemeinen Einstellungen zum Verhalten die Schriftart, Schriftgröße, der verwendete Brwoser und das Programm zur Audiowiedergabe angepasst werden.

GNOME

Da es sich um ein Qt-Programm handelt, passt die Duden-Bibliothek optisch nicht so gut ins Bild der GNOME-Desktopumgebung. Abhilfe schaffen ggf. Lösungen aus dem Artikel KDE-Anwendungen unter GNOME.

Problemlösungen

Stichwortsuche

Die Stichwortsuche der Duden-Bibliothek bringt ein etwas merkwürdiges Verhalten mit sich. In vielen Fällen führt die Suche nicht direkt zum gewünschten Begriff, sondern löst eine erneute Volltextsuche aus. Der erste Treffer dieser Volltextsuche wird anschließend automatisch geöffnet. Oft jedoch handelt es sich hierbei nicht um das gewünschte Stichwort. Es muss erneut unter den Ergebnissen der gesuchte Begriff ausgewählt werden. Um dieses Verhalten zu ändern mus in der Konfigurationsdatei ~/.config/BDNM/office-bibliothek.ini der Eintrag

DefaultOptions\ImplicitMaxIncremental=4

angepasst [3] werden.

Ersetzt man die 4 durch eine zweistellige Zahl (z.B. 40) erfolgt die Volltextsuche erst ab einer Eingabe von 40 Buchstaben und mehr. Die Suche über den Lupenbutton bleibt davon unberührt.

Duden Korrektor

Die Duden-Rechtschreibprüfung für OpenOffice und LibreOffice, Korrektor ist eine kommerzielle Rechtschreib-, Grammatik- und Worttrennungsprüfung für die Textverarbeitung Writer und eine Wortprüfung für die Tabellenkalkulation Calc und die Präsentationssoftware Impress. Zusätzlich enthalten ist das Nachschlagewerk Duden – Die deutsche Rechtschreibung.

Die aktuelle Version 8.0 ist bei Duden 🇩🇪 für 19,95€ als CD oder Download erhältlich.

Alternativ zur nachfolgenden Anleitung kann auch das Docker-Image ypid/libreoffice_duden 🇬🇧 verwendet werden.

Installation

Vorbereitung

Folgende Grundpakete (inkl. Abhängigkeiten) sowie das Paket für die verwendete Textverarbeitung sind Voraussetzung zur Installation des Korrektors [1]:

Vorbereitung der Installation
GrundpaketeOpenOffice.org Libre Office
  • openjdk-6-jre (siehe Artikel Java)

Paketliste zum Kopieren:

sudo apt-get install openjdk-6-jre 

Oder mit apturl die Pakete installieren. Link: apt://openjdk-6-jre

  • openoffice.org-java-common (bis Version 12.04)

Paketliste zum Kopieren:

sudo apt-get install openoffice.org-java-common 

Oder mit apturl die Pakete installieren. Link: apt://openoffice.org-java-common

  • openoffice-java-common (ab Version 12.10)

Paketliste zum Kopieren:

sudo apt-get install openoffice-java-common 

Oder mit apturl die Pakete installieren. Link: apt://openoffice-java-common

  • libreoffice.org-java-common (bis Version 12.04)

Paketliste zum Kopieren:

sudo apt-get install libreoffice.org-java-common 

Oder mit apturl die Pakete installieren. Link: apt://libreoffice.org-java-common

  • libreoffice-java-common (ab Version 12.10)

Paketliste zum Kopieren:

sudo apt-get install libreoffice-java-common 

Oder mit apturl die Pakete installieren. Link: apt://libreoffice-java-common

  • libstlport4.6-dev (ab Version 8.0)

Paketliste zum Kopieren:

sudo apt-get install libstlport4.6-dev 

Oder mit apturl die Pakete installieren. Link: apt://libstlport4.6-dev

Installation der Duden-Rechtschreibprüfung

Die Duden-Rechtschreibprüfung wird als Erweiterung in OpenOffice eingebunden. Dazu startet man in OpenOffice unter "Extras" den "Extension Manager…". Hier wählt man über die "Hinzufügen…"-Schaltfläche die Datei duden-korrektor-openoffice.oxt aus, welche sich in dem Ordner linux auf dem Installationsmedium befindet.

Ist die Erweiterung installiert, muss die Textverarbeitung beendet und neu gestartet werden.

Nachbereitung

Nach der Installation der Duden-Rechtschreibprüfung muss man die alte Rechtschreibprüfung deaktivieren. Dazu öffnet man unter "Extras -> Optionen… -> Spracheinstellungen" das Menü "Linguistik" und deaktiviert unter "Verfügbare Sprachmodule" alle Einträge außer "Duden Korrektor" und "OpenOffice.org New Thesaurus".

Anschließend klickt man rechts daneben auf "Bearbeiten…". Hier muss unter "Rechtschreibung", "Grammatik" und "Silbentrennung" der "Duden Korrektor" und unter Thesaurus "OpenOffice.org New Thesaurus" ausgewählt sein - alle anderen Einträge bleiben deaktiviert.

Handbücher

Die Handbücher zu den jeweiligen Nachschlagewerken sind auf den Installationsmedien im PDF-Format hinterlegt. Diese beschreiben ausführlich und anschaulich die einzelnen Funktionen.