Archiv/Datenmigration/Excel

Archivierte Anleitung

Dieser Artikel wurde archiviert. Das bedeutet, dass er nicht mehr auf Richtigkeit überprüft oder anderweitig gepflegt wird. Der Inhalt wurde für keine aktuell unterstützte Ubuntu-Version getestet. Wenn du Gründe für eine Wiederherstellung siehst, melde dich bitte in der Diskussion zum Artikel. Bis dahin bleibt die Seite für weitere Änderungen gesperrt.

Hinweis:

Die Anleitung gilt für Microsoft Office 97 bis 2003. Office Open XML Dateien (.xlsx) von Microsoft Office 2007 oder neuer lassen sich ggf. nur eingeschränkt bearbeiten oder anschauen.

Inhaltsverzeichnis
  1. Generelles zu Microsoft Excel Dateien
  2. Dokumentenversand per E-Mail
    1. PDF-Format
  3. Dokumente öffnen und speichern im Microsof...
  4. Datenübernahme
    1. Allgemein
    2. Konvertieren nach OpenDocument Tabellend...
  5. Links

Es gibt verschiedene Büroprogramme, die zum Anzeigen bzw. zur Bearbeitung von Excel-Dateien geeignet sind. Unter Ubuntu und Kubuntu wird ab 11.04 standardmäßig LibreOffice installiert. Xubuntu und Lubuntu setzen hingegen auf Gnumeric. Eine dritte Variante ist Calligra/KOffice.

Auf Grund der Tatsache, dass es sich bei Microsoft Excel-Dateien (.xls) um ein proprietäres Format handelt - welches somit nicht öffentlich dokumentiert ist - können die Export- und Import-Funktionen von allen Programmen unter Ubuntu fehlerhaft sein. Anzumerken sei an dieser Stelle, dass Makros (VBA) aus Microsoft Excel nicht unter den oben genannten Programmen funktionieren und folglich auch nicht importiert werden.

Generelles zu Microsoft Excel Dateien

Sollten Excel-Dokumente evtl. OLE Dateien enthalten, so wird der Inhalt von diesen OLE-Dokumenten unter Ubuntu nicht korrekt dargestellt. Das Kürzel OLE steht dabei für "Object Linking and Embedding", eine aus der Windows-Welt stammende Technik zum Einbinden von Objekten. Die Objekte fungieren dabei als Container, die sowohl die Daten des betreffenden Objekts (z.B. eine Präsentation) als auch dessen Funktionalität (sprich die Funktionen der Präsentationssoftware) zur Bearbeitung dieser Daten bereitstellen. Da Linux OLE nicht unterstützt, stehen einem dort nur die in LibreOffice intern implementierten Objekttypen zur Verfügung. Unter Windows kann man hingegen auf alle Objekte (also sämtliche Objekte aus Microsoft Office) zurückgreifen, die von den im Betriebssystem registrierten OLE-Servern bereitgestellt werden.

Zwar sind gerade in den letzten Programmversionen große Verbesserungen an den Import- und Export-Funktionen spürbar, so dass man bei gängigen Formeln keine Schwierigkeiten mehr hat, dennoch sollte man das Ergebnis bzw. die Funktionsweise seiner Tabelle immer kontrollieren. Da nicht alle Formeln - insbesondere speziellere Formeln - in Microsoft Excel andere Bezeichnungen tragen als z.B. in LibreOffice, kann es durchaus auch zu einigen händischen Nacharbeitungen kommen.

Dokumentenversand per E-Mail

Für gewöhnlich sendet man Dateien in dem Format, das einem die jeweilige Anwendung vorgibt. Da Microsoft Excel häufig (im Bereich der Tabellenkalkulation) eingesetzt wird, hat man daher auch des öfteren mit diesem Format zu tun. Beim Versand an andere Mitmenschen, darf man sicherlich das als international anerkannter Industrie Standard (ISO Standard ISO/IEC 26300 🇩🇪) geltende OpenDocument-Format versenden. Muss sich aber im klaren sein, dass man dieses Format als Nutzer von Microsoft Excel nicht einfach öffnen kann. Bislang bietet Microsoft Excel standardmäßig keine Möglichkeit dazu. Abhilfe könnte hier ein Addon für Microsoft Excel darstellen, welches aber auch nicht immer auf dem Rechner des Empfängers eingerichtet sein wird. Als Absender sollte man daher - falls man darüber informiert wurde bzw. es ausdrücklich so gewünscht wird - auf den Export-Filter seiner eigenen Anwendung zurückgreifen, um das Dokument im Microsoft Excel-Format zu speichern und zu versenden.

Hierbei sollte man nicht vergessen, dass die Import- und Export-Funktionen - wie oben erwähnt - Fehler verursachen können.

PDF-Format

Wenn das Dokument beim Empfänger genau so aussehen soll wie beim Ersteller, und zudem nicht weiter bearbeitet werden soll oder muss, bietet sich das PDF-Format an. Jeder kann es mit dem kostenlosen PDF-Reader lesen. Die Anwendungen Krita und Karbon aus der Calligra Suite bzw. KOffice verfügen über einen Import-Filter und können einfache PDF-Dateien nachträglich bearbeiten.

Dokumente öffnen und speichern im Microsoft Excel-Format

Das Öffnen von Microsoft Excel-Dateien lässt sich mit dem für viele aus der Windowswelt gewohnten Dialog - in dem man zur jeweiligen Datei navigiert - öffnen. Genauso verhält es sich wenn man speichert, wobei man hier im Dialogfenster auf den Dateityp ein Augenmerk richten muss bzw. gegebenenfalls auf Microsoft Excel-Format umstellen muss.

Datenübernahme

Allgemein

Sollte man auf die Formatierung einer Tabelle verzichten können, so kann man als Austauschformat das CSV_(Dateiformat) verwenden. Der Austausch von Daten zwischen Datenbanktabellen und Kalkulationsprogrammen bzw. umgekehrt kann auf diese Weise ebenfalls stattfinden. Da es sich bei CSV um eine reine Text-Datei handelt, können mit Zuhilfenahme eines Texteditors gewünschte Änderungen an den Daten vorgenommen werden. Auf die gleiche Weise lassen sich auch - unter sehr selten Umständen - aufgetretene Fehler relativ einfach korrigieren. Unter dem Umstand, dass man sich die Formeln in Microsoft Excel anzeigen lässt - anstelle der Ergebnisse (Menüpunkt: "Extras -> Optionen -> Ansicht", Häkchen im unteren Dialogfenster bei "Formeln") -, kann man per CSV auch die verwendeten Formeln übernehmen. Auch von anderen Tabellenkalkulationsprogrammen kann diese Möglichkeit genutzt werden, so lange man sich in der jeweiligen Software die Formeln anzeigen lassen kann. Wobei bei der Übernahme der Formeln zu beachten ist, dass einige Formelbezeichnungen in den jeweiligen Programmen unterschiedlich sein können und somit eine evtl. Nachbearbeitung von Nöten sein kann. Generell ist der reine Datenaustausch - mittels CSV - relativ unproblematisch.

Konvertieren nach OpenDocument Tabellendokument

Unter Konvertieren versteht man die Überführung einer Datei von einem Dateiformat in ein anderes. Soll nur eine Datei konvertiert werden, so lässt sich dies am schnellsten und leichtesten durch das Öffnen und Speichern der Datei unter dem gewünschten Format ("Datei -> Speicher unter...", Dateityp) realisieren.

Um den Arbeitsaufwand bei der Konvertierung von mehreren Dateien in das OpenDocument-Format einzugrenzen, gibt es z.B. in LibreOffice einen Assistenten, der unter "Datei -> Assistenten -> Dokumenten-Konverter" zu finden ist. Nach der Angabe des Ordners, in dem sich die zu konvertierenden Dateien befinden und auch des Ordners, wo wiederum die konvertierten Dateien gespeichert werden sollen, werden alle vorhandenen Dateien konvertiert.

Hinweis:

Zur Sicherheit sei an dieser Stelle abermals darauf hingewiesen, dass es zu fehlerhaften Formeln oder gar funktionslosen Dateien kommen kann - insbesondere falls Makros oder OLE-Objekte verwendet werden.