ubuntuusers.de

ubuntuusers.deWikiNautilus

Nautilus

Achtung!

Dieser Artikel beschreibt Nautilus bis zur Version 3.4, wie er bis Ubuntu 12.10 zum Einsatz kommt. Ab Nautilus 3.6 (eingesetzt bei Ubuntu 13.04) wurde der Funktionsumfang deutlich reduziert, so dass manche Abschnitte nicht mehr zutreffend sind (siehe auch Problembehebung).

Dieser Artikel wurde für die folgenden Ubuntu-Versionen getestet:

nautilus_logo.png Nautilus {en} ist der Standard-Dateimanager der Desktop-Umgebung GNOME. Seine Funktionen umfassen unter anderem das Anlegen und Verwalten von Dateien, Voransichten für ausgewählte Dateitypen und den Zugriff auf entfernte Freigaben. Zudem besitzt er eine Schnittstelle für Erweiterungen, die es erlaubt, den Funktionsumfang zu erhöhen.

Mit der Version 3.6 wurde der Funktionsumfang von Nautilus radikal auf wesentliche Funktionen reduziert. Als Antwort wurde mit Nemo eine Abspaltung (Fork) auf Basis von Nautilus 3.4 entwickelt, die an den reichen Funktionsumfang früherer Nautilus-Versionen anknüpft.

Programmstart

Eine Verknüpfung zu Nautilus ist standardmäßig im Unity Startmenü zu finden. Zudem lässt sich eine Verknüpfung zum Dateimanager über die Dash-Startseite durch die Eingabe verschiedener Schlüsselwörter wie „Nautilus“, „Datei“ oder „Persönlich“ finden. In den "Systemeinstellungen" kann man unter "Tastatur" auch eine Tastenkombination zum Start von Nautilus konfigurieren.

Hauptfenster

nautilus_ansicht.png
Nautilus Hauptfenster

Das Nautilus-Hauptfenster enthält in der linken Seitenleiste Verknüpfungen zu bestimmten Verzeichnissen. Dies sind einerseits vom System vorgegebene Verknüpfungen wie der „Persönliche Ordner“, dessen wichtigsten Unterordner sowie die Netzwerkverzeichnisse, andererseits selbst erstellte Verknüpfungen auf wichtige Verzeichnisse, die „Lesezeichen“. Ordner lassen sich als Lesezeichen hinzufügen indem man sie öffnet und dann die Tastenkombination Strg-D drückt.

Der Hauptbereich des Fensters stellt alle Verzeichnisse und Dateien des Verzeichnisses dar, in dem man sich gerade befindet. Darüber ist die Werkzeugleiste zu sehen, in der neben der Suchfunktion und den Vor- und Zurück-Tasten auch der aktuelle Dateisystempfad in Form von Schaltflächen angezeigt wird.

Hinweis:

Versteckte Dateien zeigt Nautilus nur an, wenn man diese Funktion mit der Tastenkombination Strg + H („H“ für hidden) oder über das Menü "Ansicht → Verborgene Dateien anzeigen" aktiviert.

Ansichtsmodus

Nautilus kennt drei verschiedene Ansichtsmodi:

  • Die Browser-Ansicht, wie sie im Abschnitt Hauptfenster zu sehen ist

  • Die Zwei-Spalten-Ansicht, die mit F3 aktiviert werden kann (ab 13.04 nicht mehr vorhanden)

  • Die Einzel-Ansicht, die im Menü "Bearbeiten → Einstellungen → Verhalten → Jeden Ordner in seinem eigenen Fenster öffnen" aktiviert werden kann

nautilus_spalten.png
Zwei-Spalten-Ansicht

nautilus_spatial.png
Einzel-Ansicht

nautilus_mit_tabs.png
Ansicht mit Reitern
  • In jedem der drei Ansichtsmodi lässt sich mit der Tastenkombination Strg + T ein neuer Reiter öffnen, so dass eine Ansicht mit mehreren Reitern entsteht.

  • Mit F9 kann die Seitenleiste ein- und ausgeblendet werden.

Adressleiste ein- und ausschalten

  • Mit der Tastenkombination Strg + L lässt sich die Adressleiste einschalten.

  • Nach Betätigen von Esc werden wieder die Navigationsknöpfe angezeigt.

Möchte man die Adressleiste permanent aktiviert lassen, muss man im dconf-editor im Schema "org.gnome.nautilus.preferences" den Wert des Schlüssels "always-use-location-entry" auf "true" setzen oder im Terminal den folgenden Befehl eingeben (der Wechsel auf die normale Navigation ist dann allerdings nicht mehr möglich):

gsettings set org.gnome.nautilus.preferences always-use-location-entry true 

Der dconf-editor ist in einer Standardinstallation von Ubuntu nicht enthalten. Er kann über folgendes Paket installiert [4] werden:

  • dconf-tools (universe)

Wiki/Vorlagen/Installbutton/button.png mit apturl

Paketliste zum Kopieren:

sudo apt-get install dconf-tools 

sudo aptitude install dconf-tools 

Dateiverknüpfungen

nautilus_rechtsklick.png

Bei einem Doppelklick auf eine Datei, deren Format Nautilus bekannt ist, wird diese mit einem Standardprogramm geöffnet. Klickt man mit der rechten Maustaste rechte Maustaste auf eine Datei, öffnet sich das Kontextmenü, das (je nach Dateityp) weitere Anwendungen zum Öffnen der Datei vorschlägt. Soll eine andere Anwendung zur Standardanwendung für einen Dateityp gemacht werden, geschieht dies über den Menüpunkt "Mit anderer Anwendung öffnen".

Hinweis:

Das daraufhin erscheinende Fenster bietet auch die Möglichkeit, Anwendungen aus der Liste der vorgeschlagenen Anwendungen zu entfernen (Rechtsklick rechte Maustaste auf den Eintrag) und andere Anwendungen hinzuzufügen. Dieses Fenster lässt sich auch über den Kontextmenü-Eintrag "Eigenschaften → Öffnen mit" erreichen.

Benutzerdefinierte Dateiverknüpfungen

Benutzer vorheriger Ubuntu-Versionen werden die Funktion "Andere Anwendung" vermissen, bei der man einen Terminal-Befehl zum Öffnen bestimmter Dateitypen angeben konnte. Diese Funktion ist dem Wechsel von GTK2 auf GTK3 zum Opfer gefallen, wodurch man nur noch die Anwendungen auswählen kann, die in der vorgegebenen Liste stehen.

Steht die gewünschte Anwendung nicht in der Liste, kann man sie aber auf zwei Arten hinzufügen:

  • Anlegen einer modifizierten Version einer .desktop-Datei: Dies ist sinnvoll, wenn die Anwendung in der Liste nicht auftaucht, obwohl sie ordnungsgemäß installiert wurde.

  • Anlegen einer neuen Desktop-Datei: Dies ist sinnvoll, wenn man bei der Installation des Programms die Paketverwaltung umgangen hat oder wenn man einen benutzerdefinierten Befehl oder ein Skript ausführen möchte.

Beide Ansätze sind im Abschnitt Problembehebung erklärt.

Papierkorb

Datei/Ordner in den Papierkorb verschieben

Eine Datei oder ein Ordner lässt sich mit Entf oder rechte Maustaste "Rechtsklick -> Löschen" in den Papierkorb verschieben.

Papierkorb leeren

Über das Kontextmenü rechte Maustaste des Papierkorbsymbols lässt sich der komplette Papierkorb leeren.

Papierkorb umgehen

Will man, dass Dateien sofort gelöscht werden und nicht erst in den Papierkorb verschoben werden, so kann man in den Optionen von Nautilus unter nautilus-direkt-löschen.png

  • "Bearbeiten -> Einstellungen -> Verhalten"

die Option "Einen Löschbefehl bereitstellen, der den Papierkorb umgeht" aktivieren. Ist die Option aktiviert und klickt man mit der rechten Maustaste auf eine Datei oder einen Ordner, so erscheint die zusätzliche Wahlmöglichkeit "Löschen". Wählt man diese Aktion aus, so wird die Auswahl an Dateien sofort und unwiderruflich gelöscht.

Alternativ kann man auch mit + Entf angewählte Dateien nach Rückfrage sofort löschen. Die obige Option braucht dazu nicht aktiviert zu sein.

Dateivorschau

Mit Hilfe der Erweiterung Sushi ist es möglich, sich von Nautilus Inhalte von Dateien und Ordnern in einer Vorschauansicht (Thumbnail) anzeigen zu lassen, ohne dass dafür ein separates Programm geöffnet werden muss. GNOME Sushi ist in einer Standardinstallation von Ubuntu nicht enthalten. Es kann über folgendes Paket installiert werden [4]:

  • gnome-sushi (universe)

Wiki/Vorlagen/Installbutton/button.png mit apturl

Paketliste zum Kopieren:

sudo apt-get install gnome-sushi 

sudo aptitude install gnome-sushi 

Ist das Programm installiert, muss eine Audio-, Video-, Text- oder Bilddatei mit der linken Maustaste linke Maustaste markiert und die Vorschau mit der Taste          gestartet werden. Die Vorschau kann mit der derselben Taste oder mit Esc beendet werden.

Ähnliches gilt für die Vorschau von RAW-Dateien (Fotos). Wie man vorgehen muss, damit Nautilus auch hier ein Vorschaubild anzeigt, steht im Artikel RAW Fotografie. Standardmäßig werden für Freigaben im Netzwerk und andere entfernte Dateien keine Vorschaubilder angezeigt. Das ist besonders lästig, wenn man eine digitale Fotosammlung auf einem Server abgelegt hat und ein bestimmtes Foto sucht. Dieses Verhalten lässt sich in den Einstellungen ändern. Dazu wird im Reiter "Einstellungen -> Vorschau" oben "Immer" ausgewählt. Außerdem kann festgelegt werden, ab welcher Dateigröße keine Vorschaubilder mehr erzeugt werden, um die Ladezeiten zu reduzieren.

Lautstärke der Audiovorschau

Läuft eine Vorschau, klickt man auf das Lautsprechersymbol im Unity-Panel und wählt "Klangeinstellungen". Unter dem Reiter "Anwendungen" kann nun die Lautstärke für sushi angepasst werden.

Weitere Funktionen

Daten auf Medium brennen

Nautilus ermöglicht es im Zusammenspiel mit Brasero, direkt aus Nautilus heraus Daten auf ein Medium wie eine CD oder DVD zu brennen. Hierzu wählt man im Kontextmenü (rechte Maustaste) einer Datei oder eines Ordners "Senden an…" und benutzt als Zielort "CD/DVD-Ersteller". Die hinzugefügten Dateien erscheinen daraufhin im virtuellen Ordner (siehe Abschnitt Ordner) burn:///, dem auch weitere Daten hinzugefügt werden können.

Virtuelle Verzeichnisse

Nautilus kann bestimmte Verzeichnisse und Dateien zusammenfassen und als virtuelle Ordner darstellen. Diese lassen sich über folgende Adressen direkt aufrufen:

Virtuelle Ordner
Ordner Beschreibung
burn:/// Daten, die für das Brennen auf ein Medium vorgemerkt sind
network:/// Anzeige der Netzwerkumgebung
trash:/// Papierkorb
computer:/// Übersicht der eingehängten Dateisysteme

Entfernte Dateisysteme

Nautilus kann auch mit Dateien auf entfernten Computern umgehen. Diese Dateien werden wie lokale Dateien in einem Verzeichnis dargestellt. Dazu öffnet man in Nautilus die Adresszeile und orientiert sich an folgenden Schemata:

nautilus_entfernte.png

Entfernte Dateisysteme
Protokoll Beispiel Beschreibung
Samba smb://rechnername/freigabe Linux-Pendant zur Windows-Dateifreigabe. Über Samba kann man auf Freigaben anderer Windows- und Linuxrechner zugreifen.
FTP ftp://192.168.0.1 Beliebtes Protokoll zum Dateitransfer
WebDAV dav://login@example.com/ordner bzw. davs://login:passwort@example.com Protokoll zur Bereitstellung von Dateien über das Internet
SSH ssh://benutzer@server:port/pfad/ordner Protokoll zur sicheren und unkomplizierten Datenübertragung zwischen Linux/Unix-Systemen (Angabe der Portnummer nur erforderlich, wenn diese vom Standardport 22 abweicht)
sftp sftp://benutzer:passwort@server:port Siehe SSH

Wie man erkennen kann, ist es möglich, gleich Zugangsdaten und Pfade entfernter Dateisysteme mit anzugeben.

Alle im System per Nautilus eingehängten Dateisysteme werden als ~/.gvfs/DATEISYSTEM abgebildet. Dies ist z.B. für Programme interessant, die auf eingehängte Dateisysteme nicht direkt zugreifen können. Da manche Programme Probleme mit versteckten Verzeichnissen haben, kann es hilfreich sein, zusätzlich eine Verknüpfung anzulegen:

ln -s ~/.gvfs ~/VERZEICHNIS 

Erweiterungen

Der Funktionsumfang von Nautilus lässt sich traditionell durch viele verschiedene Erweiterungen vergrößern. In der folgenden Übersicht sind diejenigen Erweiterungen angegeben, die mit Nautilus ab Ubuntu 11.10 erfolgreich getestet wurden:

  • Nautilus-sendto - Integration von E-Mail-Client und Pidgin

    • nautilus-sendto (universe)

    Wiki/Vorlagen/Installbutton/button.png mit apturl

    Paketliste zum Kopieren:

    sudo apt-get install nautilus-sendto 

    sudo aptitude install nautilus-sendto 

  • Nautilus Image Converter {en} - Bildgröße per Rechtsklickmenü ändern. Hierfür benötigt man [1]:

    • nautilus-image-converter (universe)

    Wiki/Vorlagen/Installbutton/button.png mit apturl

    Paketliste zum Kopieren:

    sudo apt-get install nautilus-image-converter 

    sudo aptitude install nautilus-image-converter 

  • Öffnen eines Terminals aus Nautilus

    • nautilus-open-terminal (universe)

    Wiki/Vorlagen/Installbutton/button.png mit apturl

    Paketliste zum Kopieren:

    sudo apt-get install nautilus-open-terminal 

    sudo aptitude install nautilus-open-terminal 

  • Datei/Ordner-Vergleich aus Nautilus. Erweiterung, in der man ein Vergleichstool eintragen kann. Als Standard verwendet es Meld. Mit dem setup-utiliy (nautilus-compare-preferences) kann ein anderes Tool eingetragen werden.

    • nautilus-compare (universe)

    Wiki/Vorlagen/Installbutton/button.png mit apturl

    Paketliste zum Kopieren:

    sudo apt-get install nautilus-compare 

    sudo aptitude install nautilus-compare 

  • Sicheres Löschen von Dateien

    • nautilus-wipe (universe, ab Ubuntu 12.04)

    Wiki/Vorlagen/Installbutton/button.png mit apturl

    Paketliste zum Kopieren:

    sudo apt-get install nautilus-wipe 

    sudo aptitude install nautilus-wipe 

  • seahorse-nautilus {en} - Verschlüsselung mit GnuPG

    • seahorse-nautilus (universe, ab Ubuntu 12.04)

    Wiki/Vorlagen/Installbutton/button.png mit apturl

    Paketliste zum Kopieren:

    sudo apt-get install seahorse-nautilus 

    sudo aptitude install seahorse-nautilus 

Erweiterungen, die nicht in den offiziellen Paketquellen enthalten sind:

  • Nautilus-Renamer {en} - Gleichzeitige Umbenennung mehrerer Dateien (Version 3.0 oder neuer verwenden; funktioniert nicht mit Dateien im Netzwerk)

  • Nautilus-columns {en} - erweitere Spaltenansicht für Audiodateien (MP3, WAV, FLAC) und Bilder (Exif-Daten)

  • Cover Thumbnailer - Symbolanzeige des Inhalts von Ordnern

  • OpenDocument Thumbnails - Symbolanzeige des Inhalts von OpenDocument-Dateien

  • Arronax - Anwendungsstarter mit Nautilus ab 3.x erstellen

  • Folder Color {en} - Ordnersymbole einfärben

Wer weitere Erweiterungen kennt, die problemlos funktionieren, kann diese Liste gerne ergänzen. Damit die installierten Erweiterungen verfügbar sind, muss Nautilus neu gestartet werden.

Erweiterter Starter

nautilus_starter.png Mit Hilfe eines Skripts kann man für Nautilus einen Starter in der Unity-Schnellstartleiste anlegen, der nach einem Rechtsklick rechte Maustaste ein Menü anzeigt, in dem alle Nautilus-Lesezeichen aufgeführt sind (eine sog. Quicklist).

Hierzu erstellt man zunächst, sofern noch nicht geschehen, den Ordner ~/.local/share/applications/. Anschließend erstellt man mit einem Texteditor [2] die Datei ~/bin/nautilus-starter-update.sh (der Name kann beliebig verändert werden) mit dem folgenden Inhalt:

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
#!/bin/bash
# tabsize: 4, encoding: utf8
#
# © 2011 con-f-use@gmx.net. Use permitted under MIT license:
#     http://www.opensource.org/licenses/mit-license.php
# 
# CONTRIBUTORS: Chris Druif <cyber.druif@gmail.com>
#               Scott Severance <http://www.scottseverance.us/>
# 
# This script updates the unity quicklist menu for nautilus to contain the user
# bookmarks. The updates will have efect after unity is restarted (either on
# the next login or by invoking 'unity --replace').

# location of template and unity bar launchers
nautempl="/usr/share/applications/nautilus-home.desktop"
target="$HOME/.local/share/applications/nautilus-home.desktop"
bookmarks="$HOME/.gtk-bookmarks"

# backup if file already exists
if [ -e "$target" ]; then
    echo "Creating backup of: $target."
    mv -n "$target" "$target.bak"
fi

# copy template
cp "$nautempl" "$target"

sed -i "s/\(OnlyShowIn=GNOME;\)/\1Unity;/" "$target"

echo "X-Ayatana-Desktop-Shortcuts=" >> $target

bmcount=0
while read bmline; do
    bmcount=$(($bmcount+1))     # number of current bookmark
    bmname=${bmline#*\ }        # name of the bookmark
    bmpath=${bmline%%\ *}       # path the bookmark leads to
    # deal with bookmarks that have no name
    if [ "$bmname" = "$bmpath" ]; then
        bmname=${bmpath##*/}
    fi
    # fix spaces in names and paths
    bmname="$(echo "$bmname" | sed 's/%20/ /g')"
    bmpath="$(echo "$bmpath" | sed 's/%20/ /g')"
    # extend shortcut list with current bookmark
    sed -i "s/\(X-Ayatana-Desktop-Shortcuts=.*\)/\1Scg${bmcount};/" "$target"
    # write bookmark information
    cat - >> "$target" <<EOF

[Scg$bmcount Shortcut Group]
Name=$bmname
Exec=nautilus "$bmpath"
OnlyShowIn=Unity
EOF
done < "$bookmarks"

# Add a root file manager entry
sed -i "s/\(X-Ayatana-Desktop-Shortcuts=.*\)/\1RootFM;/" "$target"
cat - >> "$target" <<EOF

[RootFM Shortcut Group]
Name=Root
Exec=gksudo nautilus
OnlyShowIn=Unity
EOF

exit 0

Nachdem man der Datei Ausführungsrechte gegeben hat [3], sollte nach der Ausführung im Ordner ~/.local/share/applications/ die Datei nautilus-home.desktop erstellt worden sein (Nautilus zeigt die Datei ohne Erweiterung an). Diesen Starter kann man nun mit gedrückter linker Maustaste linke Maustaste in die Unity-Schnellstartleiste ziehen und dort den alten Nautilus-Starter löschen. Dazu muss nach einem Rechtsklick rechte Maustaste das Häkchen vor "Im Starter behalten" entfernt werden.)

Die Einträge im Starter werden nur aktualisiert, wenn man das Script ausführt. Wer die Ausführung automatisieren möchte, kann dies beispielsweise mit einem Autostart-Eintrag oder einem Cron-Job realisieren.

Werkzeugleiste anpassen

Möchte man bestimmte Symbole/Funktionen in der Werkzeugleiste ausblenden, so muss man die entsprechende Funktion in einer XML-Datei kommentieren oder löschen. Diese befindet sich unter /usr/share/nautilus/ui/nautilus-toolbar-ui.xml und muss mit Root-Rechten editiert werden.

Achtung!

Fehlerhaftes Editieren der Datei kann zu Funktionsfehlern in Nautilus führen. Daher sollte vor Änderungen unbedingt eine Sicherheitskopie erstellt werden.

In der Nautilus-Version 3.2.1 sieht der Inhalt der Datei folgendermaßen aus:

1
2
3
4
5
6
7
<ui>
<toolbar name="Toolbar">
	<toolitem name="Back" action="Back"/>
	<toolitem name="Forward" action="Forward"/>
        <toolitem name="Search" action="Search"/>
</toolbar>
</ui>

Jeder <toolitem […] />-Eintrag bezeichnet eine Schaltfläche in der Werkzeugleiste. Unerwünschte Schaltflächen können durch Einfassung in <!-- und --> auskommentiert werden. Im folgenden Beispiel ist die Suchen-Schaltfläche (Zeile 5) ausgeblendet:

1
2
3
4
5
6
<ui>
<toolbar name="Toolbar">
	<toolitem name="Back" action="Back"/>
	<toolitem name="Forward" action="Forward"/>
        <!-- <toolitem name="Search" action="Search"/> -->
</toolbar>

Hinweis:

Die Änderungen werden erst nach einem Neustart von Nautilus übernommen. Zudem können bestimmte Schaltflächen, die es in früheren Nautilus-Versionen gab (Beispiel: den übergeordneten Ordner aufrufen), derzeit nicht hinzufügt werden.

Nautilus neu starten

Um Nautilus neu zu starten, öffnet man zunächst ein Terminal [1] und beendet Nautilus mit folgendem Befehl:

nautilus --quit 

Gleichwertig ist

nautilus -q 

Achtung!

Dieser Befehl beendet Nautilus komplett und ohne Nachfrage. Er erstreckt sich auch auf laufende Dateioperationen. Man sollte also vorher sicher stellen, dass Nautilus gefahrlos beendet werden kann!

Falls Nautilus nicht selbstständig neu startet, kann dieser Vorgang durch den Aufruf eines Ordners über die Unity-Startleiste erfolgen. Alternativ kann man im Terminal auch folgenden Befehl eingeben:

nautilus &  

Problembehebung

Statt Nautilus startet ein anderes Programm

Es kann passieren, dass die Definition von Nautilus als Standard-Programm zum Öffnen von Ordnern verloren geht. Dann startet statt des Dateimanagers irgendein anderes Programm. Folgender Befehl schafft Abhilfe:

xdg-mime default nautilus.desktop inode/directory 

Bei älteren Ubuntu-Versionen wie 12.04 muss der Befehl leicht abgewandelt werden:

xdg-mime default nautilus-folder-handler.desktop inode/directory 

Shell-Skripte werden nicht ausgeführt, sondern angezeigt

Ab Ubuntu 13.10 führt Nautilus Shell-Skripte und andere ausführbare Text-Dateien bei einem Doppelklick nicht mehr aus, sondern zeigt sie nur an. Das Verhalten lässt sich in den Einstellungen von Nautilus im Reiter "Verhalten" unter "Ausführbare Textdateien" ändern:

  • "Ausführbare Textdateien ausführen, wenn sie geöffnet werden" bedeutet, dass Shell-Skripte usw. bei einem Doppelklick direkt ausgeführt werden. Da man so sehr schnell versehentlich ein Skript ausführt, wenn man es eigentlich bearbeiten will, ist diese Option nicht empfehlenswert.

  • "Ausführbare Textdateien anzeigen, wenn sie geöffnet werden" bewirkt, dass Shell-Skripte usw. bei einem Doppelklick nicht ausgeführt, sondern mit Hilfe eines Editors angezeigt werden. Dies ist seit Ubuntu 13.10 die Standard-Einstellung.

  • "Jedes Mal nachfragen" veranlasst Nautilus, bei einem Doppelklick nachzufragen, ob das Skript geöffnet oder ausgeführt werden soll.

Anwendung fehlt in der Liste Öffnen mit

Welche Programme in der "Öffnen mit"-Liste erscheinen, wird über Programmstarter geregelt. Diese Starter sind spezielle Dateien mit der Erweiterung .desktop, die auch für das Menü unter Kubuntu, Lubuntu und Xubuntu verwendet werden. Im Artikel .desktop-Dateien wird ausführlich beschrieben, wie man einen eigenen Starter für ein Programm erstellt, das bei "Öffnen mit" nicht aufgeführt ist. Wenn der neue Eintrag nicht verfügbar ist (und kein Fehler in der .desktop-Datei vorliegt), muss man sich ab- und wieder neu anmelden, um diesen nutzen zu können.

Nautilus-Starter in Unity öffnet neues Fenster

Falls sich beim Klicken auf den Nautilus-Starter in der Unity-Seitenleiste ein neues Fenster öffnen, obwohl es bereits ein offenes gibt, dann muss man folgendes tun:

sudo nano /usr/share/applications/nautilus.desktop 

Nun entfernt man aus der Zeile

"Exec=nautilus --new-window %U" 

den Teil --new-window und speichert sie ab. Anschließend startet man Nautilus neu:

nautilus -q && nautilus 

Diese Revision wurde am 23. September 2014 16:51 von TausB erstellt.
Die folgenden Schlagworte wurden dem Artikel zugewiesen: Ubuntu, GNOME, Einsteiger, Dateimanager