ubuntuusers.de

Installation

Dieser Artikel wurde für die folgenden Ubuntu-Versionen getestet:

Apache_OpenOffice/apache_openoffice_logo.png Apache OpenOffice wurde bei Ubuntu durch LibreOffice ersetzt und ist nicht mehr in den offiziellen Paketquellen vorhanden. Sofern explizit OpenOffice gewünscht wird, muss die Installation manuell oder über ein "Personal Package Archiv" (PPA) [1] vorgenommen werden.

Vorbereitung

Als erstes muss eine vorhandene Version von OpenOffice oder LibreOffice über die Paketverwaltung deinstalliert [2] werden. Die Parallelinstallation von Apache OpenOffice und LibreOffice wurde nicht getestet und kann zu unerwünschten Nebenwirkung führen. Was jedoch gehen könnte: bei manueller Installation sowohl von LibreOffice als auch Apache OpenOffice sollten sich beide Programmpakete nicht in die Quere kommen.

Installation

Manuell

Über diesen Weg hat man die Auswahl zwischen Apache OpenOffice 4.0 oder dem älteren OpenOffice.org 3.3. Ein weiterer Vorteil ist, dass bereits die deutschen Sprachpakete integriert sind.

Herunterladen der Pakete

Zuerst muss man sich OpenOffice von der Projektseite herunterladen. Je nachdem, welche Version man bevorzugt, ist die benötigte Archivdatei über verschiedene Seiten zu finden:

Die für Ubuntu relevante Datei verwendet das folgende Namensschema:

  • Apache_OpenOffice_VERSION_Linux_SYSTEMARCHITEKTUR_install-deb_de.tar.gz bzw.

  • OOo_VERSION_Linux_SYSTEMARCHITEKTUR_install-deb_de.tar.gz.

Installation der Pakete

Hinweis!

Fremdpakete können das System gefährden.

Die Archivdatei muss zuerst entpackt werden [3]. Die enthaltenen .deb-Dateien werden dann manuell installiert [4]. Die benötigten Dateien befinden sich nach dem Entpacken im Ordner DEBS sowie im Ordner DEBS/desktop-integration (bei der Version 4.0.1 z.B. in ~/Downloads/de/DEBS), zu dem man vorher mit dem Befehl cd wechseln muss. Um die Pakete in der richtigen Reihenfolge installieren zu können, empfiehlt sich eine Installation mittels des Befehls [5]:

sudo dpkg -i *.deb 

Und nochmal im Ordner DEBS/desktop-integration

cd desktop-integration
sudo dpkg -i *.deb 

PPA

Folgendes PPA enthält Apache OpenOffice in der Version 3.4.1 in der englischen Sprachversion.

Adresszeile zum Hinzufügen des PPAs:

  • ppa:upubuntu-com/openoffice

Hinweis!

Zusätzliche Fremdquellen können das System gefährden.


Ein PPA unterstützt nicht zwangsläufig alle Ubuntu-Versionen. Weitere Informationen sind der Wiki/Vorlagen/PPA/ppa.png PPA-Beschreibung des Eigentümers/Teams upubuntu-com zu entnehmen.

Damit Pakete aus dem PPA genutzt werden können, müssen die Paketquellen neu eingelesen werden.

Nach dem Aktualisieren der Paketquellen kann folgendes Paket installiert werden:

  • apache-openoffice (ppa)

Wiki/Vorlagen/Installbutton/button.png mit apturl

Paketliste zum Kopieren:

sudo apt-get install apache-openoffice 

sudo aptitude install apache-openoffice 

Ein deutsches Sprachpaket {en} {dl} muss separat heruntergeladen und installiert werden.

Verwendung

Wenn das Programm fehlerfrei installiert wurde, lässt es sich bei Ubuntu-Varianten mit einem Anwendungsmenü über "Büro -> Apache OpenOffice" starten. Alternativ lässt sich OpenOffice auch über Alt + F2 und durch Eingabe eines der folgenden Befehle starten:

ooffice
# oder gleich OpenOffice Draw öffnen
ooffice -draw 

Für Writer, Calc, Impress und Base wird das Argument dementsprechend abgeändert.

Start beschleunigen

Um den Start von OpenOffice zu beschleunigen, kann es helfen, unter "Extras -> Optionen -> OpenOffice -> Arbeitsspeicher" den Wert "Verwenden für OpenOffice" auf 128 MiB zu setzen, die "Anzahl der Schritte" auf 25 zu reduzieren und den Wert von "Speicher pro Objekt" auf 8 MiB setzen. Damit das Scrollen von Texten schnell funktioniert "Extras -> Optionen -> OpenOffice -> Ansicht -> Antialiasing" abschalten. Eine besonders hohe Geschwindigkeits-Steigerung ist über "Ansicht -> Raster -> sichtbar" abzustellen, so sind die Raster-Punkte zwar nicht mehr sichtbar, aber das "Fangen" im Raster kann so trotzdem aktiv sein. Diese Werte optimieren nicht nur den Start, sondern ermöglichen auch flüssiges Arbeiten mit OpenOffice.

Problembehebung

Unterstreichen

Prinzipiell sollte man mit der Tastenkombination Strg + + U markierten Text unterstreichen können, aber es funktioniert unter Umständen nur mit Strg + U . Hintergrund: unter GNOME 2 ist die Tastenkombination Strg + + U für die Eingabe von Unicode-Zeichen vorgesehen. Abhilfe schafft in einem Editor [6] das Einfügen der Zeile

GTK_IM_MODULE=xim

in die versteckte Datei ~/.profile im eigenen Homeverzeichnis.

Xfce

Falls diese Vorgehensweise unter Xfce nicht funktioniert, kann man hier die Datei ~/.config/xfce4/xfconf/xfce-perchannel-xml/xsettings.xml editieren und die Zeile mit

<property name="IMModule" type="string" value=""/>

in

<property name="IMModule" type="string" value="xim"/>

ändern.

Zur Aktivierung - egal, unter welcher Desktop-Umgebung - einmal ab- und wieder neu anmelden.

Hintergrundfarbe für markierten Text

Es kann in bestimmten Konstellation dazu kommen, dass die Hintergrundfarbe für markierten (oder bei einer Suche gefundenen) Text in OpenOffice sehr schlecht zu erkennen ist. Die Ursache dafür ist, dass OpenOffice die Markierungsfarbe aus den Einstellungen des Desktop-Designs holt und sie dann mit einer recht hohen Transparenz darstellt. OpenOffice bot (zumindest bis Version 3.2) keine Optionen, um die Markierungsfarbe oder deren Transparenz einzustellen. Es verwendet in GNOME die Farbe, die man unter "System -> Einstellungen -> Erscheinungsbild -> Anpassen -> Farben -> Gewählte Einträge" findet. Ein daraus resultierende Problem ist, dass sich eine Änderung dieser Farbe auf viele Bereiche des Desktop-Themas auswirkt (z.B. auch auf die Farbe der Knöpfe), was nicht unbedingt wünschenswert ist.

Diese Revision wurde am 16. März 2014 11:03 von aasche erstellt.
Die folgenden Schlagworte wurden dem Artikel zugewiesen: Büro, Textverarbeitung, Tabellenkalkulation